Stuck at waiting for GPS (DJI P4)

I can’t get your app working on my ipad. It is stuck at the “waiting for GPS” I launched the DJI app to see what is happening and there are 12 birds in view and a good GPS lock. quit the DJI app but still no luck with your app. Tried turning off the RC as recommended but it didn’t help. I should mention that a competitor’s app works fine with my drone and my ipad. (ver 9.3.1, 1.5.5, DJI Phantom 4 latest firmware as of 5/23/16 - sorry, don’t have the number handy)

I’m not sure what could be causing this. There is an update available very very soon, so let me know if that helps.

thanks for the info. I’ll check the app once it’s updated.

Any updates on how to solve the issue?

I’m having the same issue with my P4 Pro V2…it’s beyond frustrating. If I open up the DJI Go 4 app, I almost immediately get a great GPS lock. Toggle back over to your app, it will just sit there with the “No GPS” lock. Tried turning the controller and drone off and then back on…still same issue. It really shouldn’t be this difficult. Is anyone else having a similar issue?

1 Like