Stuck at "Waiting for drone"

Hey

I’m using the latest version of the dronedeploy app on an ipad air 2 along with a phatom 3 advance. I haven’t had this problem before but after properly connecting the drone a message comes up in the bottom left saying “Usb connected - waiting for drone” and it will stay there indefinitely. The flight button doesn’t appear in the bottom right. Im doing the exact same as I’ve done the other times I’ve used the app but I get this problem.

When you connect the drone does it say “drone connected” in the bottom left with a little green dot?

Yes it does, it says the drone is connected but then goes to the waiting for the drone alert in the bottom left.

About the same trouble …
Once I had "drone connected for few seconds then “waiting…”
Now, always “waiting …” Bad trip.
If DD becomes non usable …

Exact same problem as me

Tried an hour ago with the last beta: connection and flys ok !
But ! … having started with DJIGo, had to perform a “cold qtart”: Killed apps, restart remote and drone before connection, if not, no connection for DD

I get the same error message ‘USB connected - waiting for drone’ but I’m using the Android app (2.0.11) and a P3S with wifi connection!

I’ve flown missions OK with Android v2.0.6 but 2.0.9 never got past the pre-flight checks.

Forgive my English, it is to google.
to me it happened to me, I fix 1- giving twice ipad round button, 2-removing the application DD ipad (without logout), 3- reopening the app DD (no login).
Then I always appears well located device and can start flying, luck.