Stuck at "Waiting for drone" - tried two different phones!

Hey guys,

I must be doing something wrong. I’ve tried the troubleshooting tips recommended by dronedeploy help section and also ones I saw in another post with someone having similar troubles (I started DJI Go, confirmed I could connect to the p3p, confirmed I could take a picture, killed the DJI go app, unplugged usb from phone, replugged usb into phone, chose ‘dronedeploy’ as the app to open, it syncs just fine and then hangs on the “waiting for drone” screen. I’ve also tried clearing data and cache and just recently I tried with a different phone. Same issue. I’ve also tried signing up for a dronedeploy app from within the app (that apparently helped someone) but that didn’t work either.

Now…the one thing the phones have in common is that they are both rooted. Does DroneDeploy not work with rooted android devices? Is that a known issue or something? I don’t know what else it could be and I’d really like to try this app out.

I’m basically having the same problem. No matter what I try it gets stuck on “Waiting For Drone”. The tablet I’m using isn’t rooted so that certainly isn’t the problem.
One thing I can’t do is turn off “Enable IOC”. It’s not showing up in the GO app.
Sorry to hijack your thread, but I’m getting VERY frustrated at this point. If I should just start a new one, someone please let me know.

@proximus Enable IOC was dropped from the DJI GO app a few updates back so no need to worry about that one. Hope DD can help you with the other issues

It’s sometimes quite hard to get the connection.
In that case, I switch all off, tab, RC and drone and restart, avoiding to launch DJIGo
Mainly, connection is ok after.
But it’s one issue DD should hardly work on, quite annoying !

Thanks Mark. At least that’s one less thing that could be the problem.

Cousin, I’ve tried all that… SEVERAL times. No luck.

Now if I can just get DD to respond here or to my emails… or anything.

Hi. Sorry to hear youre having trouble. Connecting the drone can be difficult to debug sometimes. This is due to the fact that the dronedeploy app has no info or control until itnis successfully connected.
What drone and firmware are you using? Have you tried multiple USB cables? What phone or tablet is it?

My phantom 3 pro firmware is all up to date (drone and controller), and I have not tried a different USB cable. I’ll try that, although the USB cable I’m using is the one that came with the Drone and works with every other 3rd party software I’ve tried. I just used it today with a competitor app. I’ve tried this on a Galaxy 4 and an LG volt. I have a tablet I can try it on too. I’ll try that as well.

I’ve also sent you an invite to try an early version of an updated version to see if that helps you.

I absolutely can’t believe this. I just don’t get it. Is it something with the drone itself or am I doing something wrong? I tried the beta app you sent over…no good. Same exact issue “waiting for drone”. I then tried my daughter’s rooted Kindle Fire HD and had the same issue. Just tried my wife’s phone as well (A moto G). Same issue. I’m about to give up on DroneDeploy. :frowning:

I figured it out. My ISP blocks connections to DJI servers (I knew this already) so for the initial registration of any 3rd party app I have to connect through a VPN, which I’ve done for other similar apps (or mobile data but VPN is easier if I’m at the house). When I first opened the app upon downloading it I used a vpn and it seemed to connect fine, but maybe it didn’t for some reason. So I figured since no other device is working it has to be the internet connection. Connected with my VPN using Canada as a connection and it connected to the drone immediately. I was afraid I’d have to do this every time but then i tried it after disconnecting the VPN and it still worked so my problem is resolved. I didn’t realize that when it said ‘Waiting for drone’ it was also simultaneously trying to connect to DJI’s servers. Maybe a separate error message for that issue would be more helpful to people in the future.

Thanks for the help, guys. I should be good to go now.

We use to have a good error message for that. We have a new UI coming out soon and i’ll make a note to make sure it’s clear when it happens.

1 Like

I have a P3A with the latest firmware, 1.8.80+ (App: 2.8.0 and RC says N/A) I haven’t switched USB cables since it obviously has a good connection because the GO app has no problem connecting to the drone. The tablet is an ASUS Zenpad.

No problems taking pictures, but I’m going to try to reformat the SD card anyway.

I know my ISP isn’t blocking anything.

If I don’t need to turn off Enable IOC, I don’t know what else to try.

Finally got it to work using a Galaxy S4 instead of the Zenpad tablet. Any ideas on how to get it to work with the tablet? This drone is for work and the tablet was bought specifically for this drone.

So glad you got that sorted out @ugleee - was wracking my brain…

@proximus - the Zenpad has an Intel Atom processor - the current version of the Android app doesn’t support Intel processors due to an older version of the SDK - fill out this form, and I’ll get you on the newest beta version:


Thanks jono!! I’ll hold off on getting the new Beta version. We’re still not to the point of actually using it right now. Especially since we still need a pilot’s license to fly. I can always use my phone just for trying it out. Maybe by the time we need it there will be a version available that will work on this tablet.

Thanks again! I was getting SO frustrated.