Strange issue during multi battery flight

Summary of Issue:

i downloaded dronedeploy onto my phone and experienced a strange thing, could anyone explain or at least tell me if they also experienced it.

I imported a KML file for my mission and the mission looked very large.
As i tried to take off DP warns me that the area is too big. i ignore it as i have multiple batteries.

As soon as DP finished it’s checks pre-flight suddenly the outlined waypoint map looks much smaller, i found it strange however reckon it was due to DP thinking that i only will be using 1 battery and will not have enough time to complete the multi battery mission (6 batteries) it said was needed. and because of that DP took out more than half of the waypoints.

Anyway i decided if it only flies half the mission then so be it it was getting late and i needed some results.

so i flew all the batteries and resumed many times as the batteries went flat, all went well, and at the end of the day i flew a quarter of the mine.

Went home to have a look at the data and to my amazement almost the whole mine was mapped ! 80% of it.

I just don’t understand why the grid changed in such a way that made it look like it is only doing half the area when in fact it mapped almost all of the area… Trying to explain this to my company is a no no , my colleague doesn’t even begin to understand what i’m trying to say, but there it was this weird phenomena…sigh… i hope DP will fix this in a future release.

**Date Issue Began: last week

**Drone Model: P3P

Mobile Device Model and OS version: samsung s5 android 5

DroneDeploy App Version: V 2.77.0

Hi @CeeJay,

Hmmm that is very strange behavior. Are you able to confirm if this same issue has happened with other flight plans? If possible, we’d like to know if this is repeatable behavior and we’d also like to request screenshots of the changing grid so we can see the issue you’re describing.

Unfortunately, it is very difficult for us to assess the issue without further information and reports from other users. We will try to reproduce it on our end but we’d appreciate it if you could let us know if this issue persists. Sorry for the inconvenience!


Something similar happened to me. A very large map that was going to take a dozen batteries to complete. Got through the checklist in preparation to start the mission and only a quarter or so of the waypoints appeared. Ignored it and continued. When it came in for a battery change and prepared for the next portion of the mission, more waypoints appeared. I could say if the remainder appeared or just the next batch as the map was so big it extended a long way off the screen, but at the end of the day, albeit it gave me a bit of a scare each time, it did complete all of the mission.

This happens to me with every map that requires more than one battery. It looks like DD is only showing the amount of the map that can be flown with the current battery. Every time I come in for a battery swap, the next set of waypoint paths appear. Eventually you will make it to the end of your map with enough batteries. I just assumed it was intentional by DD.

P3P and Android :expressionless:. I’ve been there my friend. Made allot of good maps and had a few wasted trips. Unfortunately the S5 isn’t supported so that might be what you get told.

Adding on to what @MichaelL has mentioned, please make sure your hardware and mobile devices are on our Supported Drones and Supported Devices (Mobile and Tablet) page. We cannot guarantee that DroneDeploy will work on unlisted setups and devices.


My hardware is all supported, lol, at your insistence and my expense, but this did happen to me.

It’s only happened once or twice in 12 months so for me is definitely a bug. It wasn’t by design.

Hi @JamesC,

My comment was not directed at you, but is a general reminder for everyone. Since the issue is not consistently reproducible on your end, it will be difficult for my team to figure out the root of the issue. If or once it becomes an issue that keeps popping up, let us know and we’ll take a deeper dive.


I was joking and knew very well you weren’t directing your comments at me. I on the other hand was simply trying to get a rise out of you and it worked. :wink:

I won’t be able to replicate it and tbh it just gave me a bit of a scare when it last did it. I wondered at the time if it was due to the size of the mission as it was hummungous and would have had a lot of waypoints to try to keep up with. If you are minded, you will find a processed map in my dashboard called ‘Holyport Village’ and it was that one that spooked me.