Screen freezing when selecting a flight in dashboard

Hi There,
I was out on site on Friday and did one flight which worked fine but when I was preparing for a 2nd flight when I’m in the dashboard and it said ‘Drone connected’ I would select a flight from the dashboard screen but it would freeze the whole page whenever I did this.

I tried closing the app down (iOS), and reopen but it didn’t work. Also tried resetting my Phantom 4 drone but nothing worked.

I’ve deleted the iOS app and am currently downloading it to see if that’ll help.

Has anyone had similar issues or can someone from DroneDeploy offer some advice it’d be greatly appreciated.

The only time I have had something similar happen the DroneDeploy site was down. Did you try restarting the tablet as well? Or just the app? When you say the screen froze, did it just not do anything or did it go blank in areas?

What device are you using?

Hi Mark,
It’s an iPad with iOS 11 and I also tried my iPhone which has iOS 11.1.2. I tried both multiple times and still had the screen freezing when I clicked on the flight symbol.

Yes I closed the app and also shut down and restarted the iPad. So when the drone was connected and I was in the dashboard I could still click the app, or setting icon and it’d function but as soon as I clicked on the flight symbol on the left everything would freeze and the whole page didn’t work including the settings buttons etc. I had to close the app each time but it kept reoccurring.

Hi Alex,

Which Ipad/Iphone are you using?

Hi Mark,
I’m using the:

  • iPad Mini 4 Model MNY12X/A with iOS 11
  • iPhone 6s Model MKQN2X/A with iOS 11.1.2
  • Drone is a Phantom 4 standard purchased end of last year

IOS DroneDeploy version 2.61.0? Just trying to run through the variables. I had this happen twice, but it was two apps ago, one iOS ago and I flew a Phantom 3 Pro. It was an on-the-fly mission that I planned in the field and recreating the mission in DroneDeploy didn’t work. I finally created the KML in Google Earth Pro and imported it. Then it worked. Sounds like different scenarios, but same base issue. I normally create my flight plans in Google Earth Pro in the office on my PC ahead of time, but I have done additional missions on the fly recently and have not had that happen again.

I’m not sure what DroneDeploy app I was using but I’m sure the iPhone version was up-to date as I have auto update for all my apps.

I deleted the DD app on both devices and downloaded them again. I went out on site this morning and was able to complete my flight with no problem.

Was DD down around 12pm Sydney time on Friday (Late Thursday Cal time?).

Thanks for your help anyway.

1 Like