Roof Report will not launch in Firefox 61.0b2

I’ve tried using roof reports for quite a while (the free test so far), but I’ve never been able to launch it.
Yesterday I did a new flight, and with a clear cut building. And it still didn’t want to launch.
I’m using Firefox.
This time I also tried launching it from Chrome, and now it worked, and launched immediately.
So it apparently does not work in FF.

Hi @fribse,

This is quite interesting. Can you let me know if you’re seeing any error messages? Do you happen to have adblockers installed as well?

Keep me posted,

Hi Christina
No, it’s a quite bare Firefox developer edition. I’ve tried both in the normal and in the developer version.
The button simply doesn’t react, until now I thought it must have been me that didn’t mark the building properly, but after trying in Chrome I found out that it was marked correctly, and I’ve now received a very nice report.

Hi @fribse,

I’m glad to hear that you were able to receive your report via Google Chrome - this is actually my preferred and recommended browser for use with DroneDeploy. If you run into other issues using DroneDeploy and any of its features on the standard version of Firefox.