Recorded jpeg-image size 16:9 not changeable to 4:3

JPGs are always recorded in 16:9 image size
Noticed beginning 26-Oct-2017 when starting to use an new IPad
Phantom 4
iPad 2017 IOS 11.1.2

Whatever I have tried in terms of camera settings in DroneDeploy and employing DJI Go 4 JPEGs of waypoint missions are recorded in image size 16:9, although I want to have 4:3. This is not the case using a Sony Xperia 3 compact with the most recent Android.

I had to manually change my setting in DJI Go. I also use the 2017 iPad, but am using a 3 Pro. Did this just happen to you? Maybe a 4 Pro firmware update?

I have tried several times to fix camera settings in DJI Go4, made images correctly in 4:3 format afterwords. When switching to DroneDeploy the camera settings automatically were set to 16:9 format using automatic settings by DroneDeploy or not. I switched
several times between DJI Go 4 and DroneDeploy trying all the time with same result (16:9 using DD).
Firmware of my Phantom 4 was always up to date!

Assuming the bird was on you were connected when changing the settings in DJI?

My Phantom was connected either to DJI Go 4, then it was also possible to make photos on th ground in 4:3 format, or to DroneDeploy afterwards. Photos made then during waypoint flight were recorded every time I tried this procedure in 16:9 format.

1 Like

Hi @Gilbert_Kattenborn,

I’ve escalated the issue to my team for investigation. If we need more info or if we have an update to share, I’ll share it in this thread. :slight_smile:

Thank you for your patience and cooperation.


Hi @Gilbert_Kattenborn,

Did you do anything differently when you flew on November 13 (when the aspect ratio was correct) vs. your flight on November 19 (when the aspect ratio was incorrect)?

Can you also upload your images?

Keep me posted,

Hi Christina,
thank you very much for your help - in fact - what I can say for the moment just looking at the images generated during several test flights I made with my phantom 4 during these days (beginning in October until 21. Nov.) that I have switched a couple of times between DJI Ground Pro and DroneDeploy in order to compare results. In the beginning of these tests no problems with image formats have occurred. Since November 16 (when using the last time DJI GSP before DroneDeploy) the problem is existing, but I don’t know if this information is useful.

How can I upload images (which I still have on my workstation’s harddisk) when flights are already deleted from DroneDeploy’s dashboard?

Warm regards,

Hi @Gilbert_Kattenborn,

My team is currently investigating another issue that may be related to this. Once I have an update to share or if I require more info, I’ll post here.

Thank you for your patience and cooperation!


I’ve had the same issue. I choose 3:2 in DJI Go4 App and even take a few pics. Switch to DroneDeploy App and it changes to 16:9 which is also causing me some issues with the aircraft camera working correctly. Thanks

Edit - Also the 16:9 mode is causing some blurring due to what seem to be delay issues taking the photo. Also after I installed DroneDeploy App and used it I was noticing some “Drone is now connected” warnings pop up on my first try. I then used the DJI App and noticed problems when taking photos in 16:9 format - the video feed would fail and camera gimbal would act like it powered down.
Reference this post on DJI support forum with video -

I there - one of my customer is having same issue which occured 2 days ago. He has flown Drone Deploy and DJI Phantom 4 for nearly 9 months now and always had 4:3 images but since the recent SW update on DJI and DD he can only take 16:9 images - I am interested in the trouble shooting. Thanks :wink:

Hello, I try to take pictures with P4P with the camera in 3: 2 and DD changes that configuration when it takes the pictures, what happens? DD does not work?

Hi, I see that DD still changes the configuration of the camera from 3: 2 to 4: 3, so with DD I have not been able to take images of 20 megapixels, because this problem still occurs?

Is there any solution?

Hi, I see that DD still changes the configuration of the camera from 3: 2 to 4: 3, so with DD I have not been able to take images of 20 megapixels, because this problem still occurs?

Dear Christina,
for completeness once again tried:

I’ve made another test flight using the Android version of DroneDeploy on a Sony Xperia Z3 . There i could easily generate images in 4:3 format. Going back to my Ipad 2017 running under IOS (recently everything updated) image format changed (automatically) to 16:9 again. Couldn’t get influence this using DJI Go 4 before using DroneDeploy.
Warm regards,

Thank you for the additional info @Gilbert_Kattenborn. My team’s still investigating the issue and I currently don’t have an update to share yet. I will let you know as soon as that changes.

Hi all,

We have now discovered the root cause for this issue and resolved it. There is a new iOS release available on the store that fixes the problem (Version 2.62). This version will now take photos with 4:3 aspect ratio.

You should be able to update manually in the iOS app store. To check your version, open the dronedeploy app, tap settings, then scroll to the bottom. You should see: Mobile 2.62.0 or similar if you have been updated.

Occasionally, iOS makes it difficult to update to the latest version, so it could be a couple of days before you see the update availability.


P.S. Folks may wonder why we have not moved to 3:2 aspect ratio. This is because we saw a considerable increase in camera capture errors when using that setting on some of the most popular DJI Drones. We will re-evaluate in future, but for now 4:3 represents the best mix of reliability and area captured per photo.

1 Like

Hi @Gilbert_Kattenborn,

Can you verify if this issue persists for you with our latest app version (2.62.0)?


Thanks a lot - I’ll do as sson as possible during the next few days and keep you informed.

Thanks again - I´ve tested it and it works - could acquire images in 4:3 format today!