Problem with mission paused half way not processing second half

Returned home mid mission because a real helicopter was heading in area. Continued the mission minutes later in Drone deploy app… but the second part of the mission doesnt show up/been processed. All 649 images have been uploaded. Only First part of mission gets processed.
Any ideas?

Thank you so much!


Did you turn everything off or did it all stay connected?

When you uploaded did you happen to notice if the perimeter encompassed all of the images?

1 Like

I would suggest uploading the 649 images through a manual upload, using the same Project.

1 Like

Hi! Thanks for your help!
I re-uploaded twice on a Mac to DD already.
Still only the first flight shows, yet the mission was completed via Deploy app with no issues.

Hi! Thank you for reply!
Yes and no. I brought the drone back and waited for the helicopter to pass. I did change th battery, but never turned off remote or app. DD just asked me Continue mission and it completed it with no issue.
Problem is processing. Although i uploaded all images using Mac to DD, it still seems to ignore second part…

1 Like

And yes the upload encompass all images (649)
Flight was fully complete with no issue.
Shows up as completed in DD
But only 1st flight prior to interruption appears and is useable

1 Like

I understand what you are saying, although what you are describing makes no sense.

Ignoring the mission, if each of the 649 images contains the required gps metadata, there shouldn’t be any reason why they wouldn’t be recognised by DD in a manual upload. If you upload all of the images into a flown mission that for whatever has had its boundary cropped (in error or through some bug), absolutely, they will be missing from the processed ortho, but not if they are manually uploaded through a separate ‘manual’ map not tied to the flown mission.

1 Like

Haha. Pardon my French if it wasnt making sense.
Ok will try a manual upload outside of that mission and see if it works.
Thank you so much for your time and knowledge


That’s what I was getting at, but if it was a single multi-battery mission this wouldn’t apply. Uploading manually will be a good doublecheck though.

@Andrew_Fraser DroneDeploy needs to look at this.

There have been smatterings of pieces of missions going missing in flight, but this is the first I have heard of any segmentation on the backend.

Also, did anyone else notice some UI changes in Chrome?

1 Like

Lol. You were making sense - I understood what you were saying. What wasn’t making sense was why or how you were experiencing issues with the processed app. I think you are still trying to upload them through the mission that’s been flown. The one with the dodgy boundary.

It sounds like you’ve been caught up in the known/ongoing bug regarding ‘continuing missions’, but so long as through one way or another you have been able to capture the images, which it sounds like you have, I cannot think why DD wouldn’t include them in the processed map if uploaded separately, in their own mission. :slight_smile:


Here we Go again way down the road without some crucial info that may or may not solve the issue. What kind of drone, mobile device and then software versions?

I have never had issues with multi battery flights except for when I tried to restart the mission to quickly in the GPS has not initialized. Wait 20-30 seconds after everything is restarted before continuing. It’s really the only sketchy part of the workflow that I have seen.

The last flight I did Michael was on 4.4.2 I think. That had issues after a battery change. Despite knowing it has done the first battery, when I clicked ‘go’, it then proceeded to starte the whole mission again. Would have been 13.something at the time on a MP1 and an iPad Pro 10.5.

There definitely a problem and from what I gather from the threads relating to later versions, things have only gotten worse. I’m reluctant to budge from the inadequate version I’m on, through fear it’s going to worse for me. I have a flight on Monday. Will be using 4.4.2 again, but on a Pro 11 v2 this time. Latest iOS.

I only wish I could revert to V3.

1 Like

Hi there

Can highly suggest using the latest version. Particularly if you fly with Mavic 2 or use Live Map as we’ve made improvements to the video feed.

Happy flying.

James, if you have an android device you can use, I have v.3.16 on my phone. I can copy the apk and you can side load it. Unfortunately ios cannot be shared the same way.

Thanks Dave.

Things might be different now, but certainly 3 years ago, I had awful problems with the app crashing out on Android.

The main reason for moving over to iOS though, was because of the constant having to switch between DD and Go4 to calibrate the camera. DD’s inability to take an in-focus picture on a MP1 means I have to swap between apps and on Android, that means I repeatedly have to remove cables and clear cache etc.

DD have repeatedly told me over the past several months, that their upgraded app ensures it stays compatible with current drones, devices and their firmware. Thing is, for me and like you I suspect, if time has stood still for us in terms of hardware and their firmware, why on Earth shouldn’t we be permitted to use their last stable version - 9 months ago!?! The V4 app for many has been a joke. The only benefit I have seen for me, is the ability to resume from the last picture taken. Everything else is wasted on me but where it has affected me is that it’s been at the cost of what was a stable and relatable app. I only wish I understood their rationale behind the decision to operate the way they do.

I can see some now, “Not this again!” :wink:

Big day tomorrow. First flight with V4.4.2 and an iPad 2020. Not worried at all! :lying_face:

1 Like

I understand. Honestly I have never flown a DD mission on Android. I have had it on my phone “just because”.

You are correct. DD v. 3.18 (ios) still works just fine on my p4p and m2p. DD saying it is not a good idea is simply rhetoric. Who knows why they would rather have problem after problem and still not offer v.3 as a backup through Test Flight. Makes no sense to me either. I really feel for you and the other guys that got pushed forward.

1 Like

Hope it went well, James!

1 Like

It actually went remarkably well.

No lag at all and all on-screen telemetry worked. 2 battery changes, with the mission picking up from where I left off from without an issue, but keep in mind I’m still running v4.4.2.

Only glitch, and I’m struggling to understand how or why, is that the continuation of the Live Map was offset from the first part of it by 200m or more and it didn’t update at all after the second battery change. No biggie, but has never done it before.

Only used up 8% battery on the iPad flying 50 mins DD and 10 on Go4.

1 Like

Glad you had a good day !