Poorly rendered elevation data

I just loaded my first set of maps for processing and the resulting elevation data is terrible. The orthomaps look great, 1 inch level detail over the entire area. however, the elevation seems to be compressed by factors of 4-5 or even more. For example, a scan from the ground on one side of a building, across the roof to the ground on the opposite side shows a range of elevation of about 5 ft when the building id 12-15 ft high! I actually had 2 set of data, one taken going cross the current winds and one going parallel and the parallel set was even worst. Flying a Phantom 3A. Is there something that isn’t being set properly? the flight was at an average height of about 200 ft AGL.

I am going to throw some of these out, so please don’t think I am over simplifying your issues:

  1. You understand that the elevations are relative to your take off location, so if you were on a hill, say elevation 10 and the top of the building is at say elevation 15, then there would only be a elevation difference of 5.
  2. Did you use any ground control points (GCPs)?
  3. What are you basing your elevations comments on? The elevation heat map? Contours? Point Cloud?
  4. how large was the total project area and what was the ground cover like (i.e. parking lots, buildings, roads, etc)?
  5. Did you take any obliques?

My personal experience with my Inspire 1 and Phantom 4 Pro’s is that the elevation data is wonky without the use of ground control points.

No, I didn’t use GCPs. Took off from the parking lot approximately mid point in the various elevations within the mapped area. Area that I have been studying is the parking lot around the building and the yard around it. Base my comments on the elevation histogram and the profiles shown when i draw a line from the parking lot across the roof of the building to the parking lot on the other side. 5-6 ft relative height between the parking lot and the roof! I did not take any obliques, primarily interested in 2.5 D, elevation contours for applications such as volume measurements, not in true 3D of the buildings, etc.

1 Like

Another silly thought, are you sure that it is in feet and not meters? Also can you share the map so we could take a look? As I previously said, my results have been mixed without GCPs.

Here is the map: http://drdp.ly/CiesZV.
you’ll see my car in the parking lot. My take off point was just behind it. The building is an abandoned single story school house. if you draw a line across the southern end of the building from the grass in back to the lot in front you’ll see that it show up as being only about 4-5 ft (yes, I double checked my units) high.

Just some additional info. The original mission was planned and flown using the Maps Made Easy app. Their processing generated similar results. Just got some feedback from them stating that in order to get good terrain that I needed to have at least 80/80% overlap (I flew my mission with 75/75%). planning another mission with increased overlap as soon as the weather here cooperates.

I see what you mean now looking at the map. Either the school was for the Hobbits from Lord of the Rings, or it messed up :slight_smile: The greater the overlap the better the information, however I would not think that the 5% was the only issue, but maybe so… Since it is a small site I would do 90/90 and add an orbit around the building to help with the facade imagery.

Good Luck!

Already have new missions planned with 80, 85 and 90% coverage for testing. Will fly them and get them processed as soon as the weather cooperates.

Just finished processing the 85% overlap map (Boone Station 85 Percent) and I am still getting 5-6 foot buildings. There has to be something wrong either in my aircraft settings or how the data is being interpreted. I did check, and the altitudes are being reported correctly in the exif files. Although, I do have ‘metric’ set in my Go app settings. Could this somehow be confusing the processing?

I am not sure… I had the same issue with the Phantom 4 Pro on my madien flight; howver, Iupdated everything and it never occurred again. From your descriptions it does seem to be at a ratio similar to the meter vs feet comparison.

No, flew a mission today with everything set to ‘English measurements’ with similar results. I even slowed the aircraft down to just 2.2 m/s as recommended by some one at Maps made Easy. And I still get similar errors if I run the images in Maps Made Easy. That makes me think that there must be something wrong with the exif data. But, I have looked at the exif on many of the images and they are all reading correct altitudes (DJI stores the altitude in above MSL using GPS). I can’t find anything wrong with the files on the images, but no one has been able to give me any insight into how to correct this problem. At this point, I am not able to create usable elevation maps in either Drone Deploy or Maps Made Easy and I’m pretty frustrated. Just about ready to throw in the towel.

Hey. I forwarded this to our team to see if they can see what’s wrong with the images.

Really interested in hearing what they have to say! in the meantime, i flew another mission over the same area using a second P3A. In that map (Boone with N806CA), the elevation results look pretty good. The few spots that I have measured came out ok and the others such as building and tree heights appear to be reasonable based on just visual observations. That would imply that there is something specific to the first aircraft that had been set incorrectly or is just, simply, wrong. Obviously, I want to be able to rely on data taken from both aircraft, so any feedback your team can give me will be very much appreciated.