Plan activates, drone goes to start position but just hovers

I am new to the dronedeply platform. My drone begins the program, flies to the ‘start’ point, and just hovers there…never beginning the route. Is there another button I have to push for it to begin the flight path taking pictures? 3 Pro - 8+ phone - updated firmware

Not on my P4P. It just takes off, flies the whole mission and then lands near the takeoff location (sometimes I have to use the controls to move it over a bit to a safer landing location).

I did see the behavior you describe one time. It was a windy day and on the DroneDeploy screen I could see the drone bouncing around the start point. It remained there for the better part of a minute before I made it return to home. Since it was so windy, I did not try again.

Hi @mringham,

Have you taken a look at our Zero to Hero onboarding videos? They’re a series of step-by-step guides on how to use DroneDeploy.

Your drone may be hovering due to low or no GPS signal. Can you verify that you are in a place with strong signals and little to no interference from other devices as well?

If you’ve followed all these steps accordingly and are still having issues, please let me know.


yes, i have gone through the zero to hero stuff
100’ agl
no interference
good signal
connects ok, starts flight ok, just hovers at ‘start’ point

have unistalled app, reinstalled app, powered on and off all devices, tried several times…still the same

Hi @mringham,

Can you switch to the DJIGO app once your drone begins hovering to verify the GPS signal strength?

Keep me posted,

My brand new P4p did this.
I selected RTH and it descended and crashed.

Not sure what aircraft you are flying?
Does your drone has crash avoidance?

The P4p hovers if it detects an obstacle close bythus preventing it from going where it has been programmed to go.