Photos taken with my Phantom 3 Professional cannot be recorded on SD card


I am using a Phantom 3 Professional. I have the latest firmware updates. However, When trying to use the camera , The pics will not register on the SD card. Can someone be kind t guide me as to finding the problem and solving it.
Thanks and regads


Hi @Jobeet,

Can you verify that you’ve tried reformatting your SD card?



Yes Christina. I have formatted the SD card. I even tried recording some data on the card. The data were recorded and then I did format the card again.

Is there a possibility that a corrupted upgrade of the RC could be the reason why the SD card can no longer record from the camera. If so, how can I erase and replace what could have been a corrupted upgrade ?

Thanks for your advice


Hi @Jobeet,

I have not seen anyone else report this issue so far. If it is an issue with your drone’s firmware, you’ll need to reach out to DJI to see if they can assist with that since we do not provide rollbacks on firmware of any sort, whether they are for DroneDeploy or DJI.

Can you verify that you experience the same issue with a different SD card?



Thanks for your reply. Unfortunately, I have nt tried an other SD card as the one I actually use never gave me any problem and I even tried recording other data on the said card. It recorded just fine. Therefore, I am quite sure that is not an issue withSD card itself. The issue got to be with the upgrade of the aircraft, the RC or the battery….

Again, Unfortunately, I dont know how tore-install all these.

Thanks for the help you tried to give me

Verybest regards



I would try a faster card such as an USHC 3.



Yusuf :
Thanks for your immediate reply……Well !!! I dont think this will change the behavior as I have used that card many , many times before ? …and it always recorded the pics. In fact, I just loaded some other pictures and data as I had put that SD card in my Mac….
What else should I try ?




Hi @jobeet,

As Christina mentioned, we advise trying a different SD card to eliminate your current SD card as the source issue. Your SD card could be old and needs replacement.

If you continue to have camera issues, please check if you’re able to capture and store images with DJI Go by taking a test photo. You can try resetting your camera settings (option is right next to formatting SD card in the DJI GO app). That should help clear out any existing conflicts with your camera. We hope these suggestions help. Sorry for the difficulties!




Thanks for ur involvement. Indeed, I purchased a new Sd Card 64 k class 10 IHSU.

I tried to capture an image thru DJI GO app. Same problem persists. It still takes 15 seconds to supposedly record the image. Then, when trying to play back, I get the prompt : EMPTY SD CARD…

Could the problem be with the newly installed Flexx cable ? The app shows LATEST FIRMWARE

Please advise . This is very frustrating

Thanks again


Hi @jobeet,

Oh no, I’m sorry to hear swapping out your SD card for a new one and resetting your camera settings did not resolve the issue. If you’re unable to capture even a test photo in DJI, this suggests you might have a camera hardware issue. We recommend contacting DJI’s Support team directly. They will have more resources to diagnose your camera.

I’m really sorry for the frustrations and difficulties!



Hi Stephanie
Thanks for ur reply. I’ve tried with DJI support with absolutely NO SUCCESS… So, I am just stuck. I have to inquire some more thru some forum….I am just disappointed with DJI not to be able to provide support in some esay way….

Anyway, thanks as you’ve tried