Phantom 4 V2 will not continue mission after battery change

My Brand-new Phantom 4 V2 will not continue the mission after battery change, it just says initializing Drone and then does nothing. I have done a hard reboot on all equipment told it to restart the whole flight everything I can think of and it just sits there and will not fly again after a battery change. I went back to check everything out and found no issues. I went back to refly the mission, and everything went perfectly up until I needed to change the battery again. Something else is that I am not able to fly it under manual control either.

Anyone ever seen this issue before?

Mike

3 Likes

He UFOMedic, I think you may be having a similar issue. Are you noticing any popups at the bottom that say that the mission exceeds maximum flight radius?

1 Like

HI,
same thing happening here - I can make it fail to continue (either locks or shows “exceeds maximum flight radius” - start flight - ask it come home - turn on and off - then fails to continue. Havent found a way round it.

also it was a phantom 4 pro - worked fine 2 days ago

1 Like

Same, it looks like they updated the app a couple of days ago to use the new DJI SDK … so guessing there’s an issue with it retrieving the maximum flight radius from DJI 4. I’m trying desperately to try to get an older version of DD loaded so I can get my jobs completed.

1 Like

Did you manage to resolve it ?

1 Like

Yes I have seen that a couple of times

1 Like

Hey mcc,

No resolution, moved to Pix4D in the meantime for the large projects.

I also reported it in a support email but only got the standard response - The template worked a few days ago so it is an issue somewhere.

I will use something else to do the flying.

1 Like

When you get the message that it exceeds maximum flight radius, go into the settings in DJI GO 4 and change the flight distance. Chances are the flight distance defaulted and now your planned flight is farther than the distance DJI GO 4 defaulted to.

1 Like

same issues here. Yesterday was the first time I’ve seen the ‘Maximum flight radius’ message. I’ve flown several missions that were much larger and much farther out, last one was last week. First flight yesterday went without a hitch, I went to the second property, set out targets and flew the first battery with incident, which was the furthest out part of the property, drone came back to for a battery change and the message popped up. I shut everything down, and restarted, this time the drone acted like it was going to go, took off and hovered about 6 feet off the ground and just hung out there…like it was waiting for something. Everything was good, had 10 satellites. I was stumped. I ended up creating another mission for the portion of the property that was left, started everything up as normal, it took off and followed the mission as planned. I lost about an hour of my day in the process of trying to figure something out. Air temperature at the time of flight was about 95 degrees, not sure if that might have had anything to to do with it.

I have the same problem. It just started happening to me. Extremely annoying. I hope we get a fix for this soon…

1 Like

Same issue popped up out of nowhere. What a pain in the ass.

1 Like

DD Support said they in deed have a problem are working to resolve it. I had the same exact issue with the drone not taking off to complete a two battery mission. Very frustrating in deed.

Same problem with mavic 2 pro. So far the only thing that seems to work is on the way back, take a screenshot to see what area is left and then when you start again adjust the map to continue where you left off.

Another thing i have tried that seems to work most of the time is when the drone lands for a battery swap, as soon as you turn the drone off kill the DD app. Start the drone up again after your swap and make sure you are connected and then start the DD app again, and MOST of the time it will ask if you would like to continue the flight and then it will properly initialize.

1 Like

Another workaround is to copy the flight plan, 180 the direction and run the remaining lanes backwards.

Good to hear, I hope it comes out VERY soon

The same situation has happened to me on several of my last flights after a battery change. Not always but most of the time. I too start up DJI Go4 and sometimes the radius is just fine so I close the app down and then DD will allow the drone to take off.

Running DD on an older Iphone because running on Android still doesn’t work on a modern phone or tablet.

Are people still experiencing this? I had my drone just sit there hovering waiting as well.

1 Like

I just had the issue where the drone hovered around 6 feet and stayed there. I hit RTH, turned off the drone, pulled the battery out and inserted it back in, then turned it on and was able to continue my flight. I’m not sure what the cause of the hovering is. Hoping to see a reason/fix for this.

1 Like