Phantom 4 RTK Controller

I just purchased the P4RTK and I can’t get a satellite view on the controller so I can’t plan a mission. Any suggestions?

The map setting is wrong. Mine shipped with the maps set to chinese.
Turn the controller on, at the screen where you have the buttons: Plan | Fly, hit the icon on the top left to expand the menu. In that menu, hit the Gear icon, to get into settings for the controller.
Under general settings, “Select map type” make sure it is set to ‘MAPBOX’.
This helped me, hope it solves your problem.

1 Like

You were absolutly correct. The controller is now showing satellite view. Thank you so much. You saved me the horror of sending this unit back to Drone Nerds and having them take 3 to 5 weeks to get me a new one.