Phantom 4 Pro Stopping

Boa Noite
Meu drone Phantom 4pro está parando a missão no meio do trabalho e me dá muito trabalho para trazer ele de volta.
Você pode me ajudar?
Desde já agradeço.


Good evening
My Phantom 4 Pro drone is stopping the mission in the middle of work and it gives me a lot of work to bring it back.
Can you help me?
Thank you very much in advance.

1 Like

Does this happen with all flights? Does it happen at a specific waypoint of after a specific amount of time?

Boa tarde
Sim e agora estou com muito medo de subir ele outra vez.
A fezes ele coleta uma o pouco mais e imagens e volta a acontecer.
Por pouco não o perdi.

1 Like

Hi @evertonfeitosa.se!
Danielle here with DroneDeploy Support. I highly recommend sending an email to support@drondeploy.com with a Flight Log of when this behavior has occured. The team would be happy to analyze the Log for you and escalate it to our Flight engineers if need be as well!

1 Like

FWIW, does the P4P stop completely or stutter during a mission, or slow to a crawl, stop, maybe resume and stutter during the mission? Have run into the stutter issue where P4P will slow down, come to a stop, either wait a while or slowly go to next point and stop or pause at each point photo taken. Have noticed this tends to happen with snow on ground, overcast with low ceiling (within ceiling and vis minimums). Fly same mission location with higher ceiling, not as cloudy, no stutter.

I have seen something similar to this with either restricted airspace or the obstacle avoidance sensors getting confused.

1 Like

Interesting, have not experienced in restricted airspace, or even in NFZ when flying with authorization and custom unlock. Concur that it tends to be a light (or lack of) and OA sensors getting confused issue. In some cases the P4P would come to a stop and just hover, then force an RTH.

I have seen it when my flight plan bumps into an area that is not shown on AirMap, but is on DJI’s self-unlock site. It does not cause an RTH though, just bounces of the zone like a bubble. Are you getting any kind of feedback in DJI Go? You can switch to it while DroneDeploy is open. My that spot has GPS issues…

I know it’s probably not recommended, but if you feel like that location is pretty safe then try turning off obstacle avoidance all together and see what happens. Personally I don’t run any obstacle avoidance unless the conditions demand it.

Have not experienced anything with restricted or in NFZ as long as custom unlock is enabled before flight. Have also observed good GPS when stutter occurs, thus thinking its OA/sensor issue. I usually will do a quick Go4 flight of area to verify unlock, verify good GPS (beyond what app says), check conditions, do some HF images, then land. Then close app etc, swap batteries, switch to other app (e.g. DD or Litchi etc) and fly those missions.

It can happen in different zones. Mine in particular was from a standard Class C at 300ft AGL to an unlabeled zone that appeared on DJI’s map. It may just be that airport, but it happened at two different projects in different relationships to the airspace. I found that if I unlocked and lifted off from the second zone that it would let me fly the entirety of the projects.

I the the OA issue was when pointed towards the sun or a surface with reflectivity of it.

1 Like

Good point and concur, not recommended, have tried that in a wide open area to see if OA was the issue. Saw some improvement, however did not completely resolve. Was thinking of trying with low light option to see if that would resolve. Seems to occur when you have vis close to min (e.g. 3m), low ceiling (say 800’ with mission at about 250’) heavy overcast and snow. Next time have conditions like that will try low light to see what happens.

1 Like

If no unlock, have seen issues, even in G when an airport needs unlock by DJI, however does not appear on other apps. However with custom unlock, have not run into any issues, other than making sure to have the correct unlock code enabled (or disabled) for a given location. Blanket custom unlocks work well except they are limited to about a 30km radius iirc, also have the custom unlock work across multiple aircraft simplifies things.

I have had this happen several times, it almost appears that the drone has bumped up against an invisible wall. I have had to turn off the Obstacle avoidance on a few mission to get it to complete because of the sun interfering and causing the drone to think it is going to hit something. I have been able to remedy this by also changing the angle of the planned pattern so the drone is not flying directly into the sun. If I go back and fly at a different time of day or on a slightly overcast day the flights that would not fly previously have worked. I have seen this happen in an unlocked “Zone” as well as in completely open space with no flight restrictions.

2 Likes

I missed the “snow” comment. I have had issues as well while flying where there is minimal to no snow and then into areas of full snow cover (totally white) during the same mission and the reflection off the snow seems to cause a bit of a stutter in the flight as the drone “realizes” it is still flying in a safe pattern. Obstacle avoidance is great but quick or bright changes in lighting conditions seem to throw it for a loop occasionally.

1 Like

Interesting, with some light, on a brighter day, did not see the stutter/stop. Here are two images, the top one did not experience stutter/stop (brighter day), second one on more overcast day, with stutter/stop. Im assuming that with the low light, snow on the ground and ground features camera was having trouble determining what to capture, thus stuttered. Was thinking OA might have been part of issue, however disabling it did not solve. I dont have my notes handy, however iirc, there were more stutters where less structure or ground items that stood out (e.g. empty field) vs where there were trees or things that stood out more.

Are either of you using DJI control of the camera? Or is it left to DroneDeploy?

I can only use it with the manual settings of the DJI GO. Unfortunately if you leave it on automatic, it misses the focus control and makes the photos unusable. A pity for all this work. I use P4P and P4A, both with the same problem.

3 Likes

Leaving camera control to DD

1 Like

Have tried both, I let DD handle the camera, then have a check list item to set camera back once shut DD down. Would be nice if DD would give you the option of saving the camera settings when it controls, then restoring them.

2 Likes