Phantom 4 - Mission exceeds maximum radius set in DJI Go

Hi there,

I sucessfully managed already one mapping flight. Yesterday I was preparing two more mappings. However when I was about to start the flight after it’s initial testing where is all pass the app crashed on my Android Samsung S4 with a do you want to send an error log.

Then I Did a Simulation run and on all my Flight plans . I realized that I get a nerror message callled “Mission exceeds maximum radius set in DJI Go” .

I did not managed to fix this error…

Things I’ve done so far.

  • Disabled beginner mode in DJI go
  • Disabled distance restrictions in DJI go
  • upgraded Phantom 4 to latest frimware
  • uninstalled and reinstalled DroneDeploy
  • uninstalled and reinstalled DJI go
  • rebuld flghts plans
  • deleted cache from applications

Manually the Phantom 4 with DJI go works fine… I do have no cule what to to in addtion with Dronedeploy.

So it’s a phantom 4 attached to a Samsung S4 mini Android phone. USB connection works fine appart from having to force application to stop when switching between DJI go and Dronedeploy…

Anyone any bright idea?

I’m getting the same error when I try to run the sim. I haven’t actually managed to run a mission for real yet - see my tread regarding ‘Waypoint upload’ and ‘Camera check’ pre-flight fail.

I think I’ve traced down the “error” with the Simulation at least.

I am planning my flights in Switzerland. If I run the sim after planning i always run into this error. I’ve realized that when you run the sim it always takes the GPS location from this park at nice San Francisco , hence my plans are a some odd thousand miles away from this GPS and then it fails

If I move my flight plan to this nice park in San Francisco where the GPS flag is located I do get the Simulation to work…

So question to DroneDeploy would be either to set the GPS point always next to the flight plan at simulation mode and/or use the current GPS is available even for SIM

I do want to do some further testing this afternoon. Perhaps my GPS was not working on my phone yesterday… and even during starting flight it checked for San Francisco…

This is probably an easy to fix “bug”.

Well done Mario! That’s one ‘problem’ solved anyway. Yes, the sim runs fine if I go to the San Francisco park and run a simulated mission.

All I need to do now is to get DD to fly a real life mission if I can get past the 2 pre-flight check errors!

…glad to help

now over to you DroneDeploy :slight_smile: . Can you please fix asap as this would help us to plan our flights offline much better…

Lucky me at least no Checking camera spinning circle option. But still I do have the app crashing.

My hope is it tries to read the androids device GPS and not the Phantom 4 device GPS. This one recorded 19 satelites found last time but I think the android gps was disabled. Something to check this afternoon

Which version of android are you using?

The sim error message you are seeing is because in the last release we incorrectly have the max altitude at 300 meters. That will be fixed soon.

The latest version DD available from the PlayStore v2.0.9

Android 5.1.1

Android 4.4.2 on a Samsung S4 mini

For the crashing I think android 4.4 is the culprit. We saw this once and it seems to be a change in the way DJI loads waypoints with the new sdk. We are talking with them about it. It causes an issue on a small subset of android devices that have a bug in the operating system. We upgraded to 5.0 and this was resolved.
We are looking into it, but the current solution is to upgrade.

very unfortunate. Lollipop 5 is not available for my “old” S4 mini .
but at least this is an answer

ok , always good to have nice neighbors :slight_smile:
I borrowed an Android5 mobile, installed both apps , connected and et voila I could run my flight without any problems…

now… obviously this is not sustainable. Is there any chance we get this to run on my old v4.4 S$ mini ?

We will start by getting some feedback from DJI and if they have a plan to fix it.

You can email support for the time being if you have 4.4 to get the older version of the app. Unfortunately it won’t have all the fixes of the latest one but might work for you.