Phantom 4 issues Nvidia Tablet / Galaxy s5

First time user. Not impressed. I am using the free trial and cannot fathom spending the monthly subscription. I can’t even get off the ground. Here is the issue:

DroneDeploy will not connect with the Phantom 4.

Here is what I have tried:

Nvidia Shield Tablet and Galaxy s5

  1. DJI Go App installed
    DroneDeploy App installed
    Airplane Mode/No Airplane Mode

  2. Drone/Controller on then turn on DroneDeploy. DroneDeploy off, turn on drone/controller, then turn on app.

  3. Force Stopped DJI Go.

  4. Changed settings to undo default app when DJI Go is installed.

  5. Uninstalled DJI Go and DroneDeploy. Reinstalled ONLY DroneDeploy.

I have tried every single combination I can think of. What’s the deal?

Up to which point are you reaching? Does it ever say anything about the drone being connected?

DJI is working on making this better for android users and we are told they should have it out soon. If you have access to a iOS device the DJI SDK doesn’t have this problem.

It did’t say anything about the drone even starting a connection. I did find a work around though. It is more than just DJO Go App interfering. I downloaded a “kill all apps” app and used that to shut of anything that was potentially running. That did the trick on both Nvidia Tablet and Galaxy s5. I think it is more of an issue with DroneDelpoy app. I am unsure what is causing it to not connect, but it was not DJI Go as I didn’t even have it installed.

It’s basically any app that has been granted access to the USB that could interfere I believe.

For what it is worth I have two Nvidia’s and do not have any issues; however, when I first started I had the issues that @chasegray mentioned. I usually was able to resolve the issue by unplugging the usb cable from the control and reinserting. The shield tablet is quirky for me with this… I do not have a galaxy phone, I have an iphone, so I can not speak to that.

My fix for this was, I could NOT have both the DroneDeploy app and DJO GO app installed on the same system. I also had to use a task manager app and shut everything down. Another app was causing the glitch. Who knows what one.

I know the Nvidia can be quirky when trying to completly close out another background app. I recently switch all of my guys over to iPad’s and have had great success. Glad to hear you resolved it.

Happy Flying :slight_smile: