Panorama Mission freezing / not completing

UAV: Phantom 4 Pro V2
Ground station : iPad Mini 6

Had a weird issue on a weekly construction site map today where ONE of the FIVE panoramas I had planned would not complete. The pano in question would just freeze the drone in position and not continue.

The project consists of:
1x cross-hatch / perimeter map plan - flown without issue.
1x Video Plan - flown without issue
5x Panoramas (centre and 4 corners) - 4 of which were flown without issue and one corner pano just would not work! (Panorama Plan 3)

Today I started with Pano Plan 1, then added plans 2, 3, 4 and 5 to the playlist to get them all done. The drone did Pano 1 and 2, moved to position 3, took a few pictures and then just stopped mid-air. No gimbal movement, no images being collected, timer increasing.

See images Pano Plan 3 and Pano Plan 3 Frozen.
Taken after completing Panos 4 and 5 OK.

As all of the other panos, map plan and video had worked and my drone checked out as fine in DJI Go 4 I concluded that just Pano Plan 3 had an issue and made a brand new Pano Plan “X” to fly instead. Software and firmware are all up to date.

The same behaviour occurred. The drone took off, went to the position, began shooting pano images, stopped after 7 and just hung there. The RTH button in DD was not working, the Manual Control button was not working either. The image counter was not taking any images, and the gimbal was in a fixed position. The timer was advancing, after 6 minutes I had to press RTH on the controller and bring the drone home.

See Images Pano Plan X and Pano Plan X Frozen

In the end I gave up with DD as I had all the data from 4/5 panos, the map and video.
I sent up an Air 2S, and manually captured the errant pano at the right location with no issue.

Had anyone experienced this or got any ideas as to how I can get the 5x panoramas to complete in order? Or what would be causing just one pano in that location to not work when all the others were fine?

New users are only allowed one image :cry: so the above is Pano 3 Frozen after completing panos 4 and 5. It shot 7 images and then just hung there till controller RTH brought it back.

Your help is appreciated. :slight_smile:

Here is a link to the troublesome “panorama 3”, as shot manually by the Air 2S…

Panorama Plan 3

Update: Site was flown again today with no changes to anything except a Drone deploy App update… and the issue no longer occurred. So I guess DD fixed it in an update! Will report back here after flying the site next week if the issue reoccurs.

1 Like

We’ve had this happen before and changing the mSD worked as well.

Thanks for your input Michael - looking through my data, I’ve flown this site five times and had the pano issue when I DIDN’T format the memory card and the project images continue from previous card data, numbered consecutively. When I DID format the memory card and the project’s images started from 0000001 the panoramas were successful… That’s weird tho, as I always flew the map plan first, followed by a video plan and lastly the 5x panos. So never have the pano images started from 001 - they have just been numbered consecutively, after the map data on the card which does start from 001.
I should always format the card before each mission, but with 64GB and 128GB cards there’s always plenty of space and I don’t always remember. But if this is the result I will have to remember to do so to prevent issues such as this. Will update if I experience this issue again and would never have thought that a partially used card could have been the cause. I presumed the latest update “fixed” the issue, but the release notes are never very specific. Thanks again.