P4P v2 + Buggy Panorama Mission + Tree = Close Call

DD just about took me head on into a cluster of trees today and completely restricted control of the drone in the process.

I created a pano mission in DD at a jobsite I fly at frequently, elevation 50’ AGL. Below are the steps that were taken. This occurrence was with a P4P pro v2.

  1. DJI Go 4 - calibrated, took off, flew to approximate pano location & elevation, set camera.
  2. Switched to DD App (Version mobile-4.41.0 - 4.41.0) on ipad (6th Gen 14.4.2)
  3. Started Pano mission (obstacle avoidance on). Drone adjusted slightly and then took the 26 photos.
  4. After taking the last photo, the drone rotated towards the home point and started flying at 50’ directly towards a cluster of trees. I hit up and back on the sticks. The drone paused for a few seconds and then continued directly toward the trees, getting close enough to clip a few leaves. I tried all directions on the sticks and could do very little. It would pause and backup slightly but i could not rotate, move side to side, or up or down. After a few seconds of backing up DD would again takeover and head for the trees. Obstacle avoidance did absolutely nothing, no warnings, almost like it wasn’t active.
  5. I tried the pause button on the DD mission but it was not pause, it was a yellow play button and did nothing.
  6. I tried switching the drone into sport mode but again, nothing.
  7. I tried the pause button on the P4P controller, again nothing.
  8. With all other options exhausted I held back on the sticks and closed the DD app completely. Opened go4 and on open it was in the Waypoint flight mode and set between the pano point and home point. I was not able to regain control until I manually exited the waypoint flight mode.

The icing on the cake is there are zero flight logs on the ipad for todays flights. (None from the disaster above or the final 3 panos i flew after with extreme caution).


  1. Why is the pause button on the DD app no longer active until the drone lands?
  2. Why does the drone return to home after a mission? Can this be turned off completely?
  3. What controls the RTH elevation on pano missions?
  4. Where are my missing flight logs?
  5. My understanding was the pause button on the DJI controller was essentially the kill switch. Is this not the case?
  6. Why in the world would the controller be restricted while the drone is returning home?

I’ll try to answer but the bottom line is that something changed and we lost complete control of the drone once the mission has finished. Difference for us is that switching all the way over to Atti and back to P does give control back.

I have experienced the same and it seems like a deliberate change that needs to be changed back. You can pause until the last point is shot and the camera starts to rise so I usually hit pause as soon as that last shot is taken but it doesn’t always make it so I Atti-back.

This is standard behaviour and cannot be changed but we should have that capability.

It should have been DJI but maybe you have found a bug where it is treating a pano differently. @Jamespipe @Andrew_Fraser

You connected the iPad to iTunes and browsed?

The RTH button?

Bad ideas.

Michael - Thanks yet again!

I didn’t catch this at first but I don’t think I went all the way to Atti, just to sport.

I did not, I connected the ipad to wifi and went into settings > flight log for the project/mission. My understanding was it may take some time for flight logs to show up in the DD web app but they should be available on the ipad. Will try iTunes.

No, the “Intelligent flight pause button” on the top right of the controller.


Well that use to do it but I have just gotten into the habit of switching it all the way.

Ahhh that one. I believe it only works in DJI Intelligent Flight Modes. It would be a question to ask why it can’t work in DD though.

Did find the logs in iTunes, sending in to DD support. Thanks!

1 Like

To update this, DD responded yesterday and said there is nothing in the logs of the controller mode changing… sure.

I tried a few pano flights yesterday and they are still insanely buggy.

  • The on-screen pause button is now active until the drone returns and lands (instead of the yellow play button)
  • Adding panos in succession did not work. The drone flew the first one and then returned home despite having 2 more in the que.
  • Flying one pano, pausing at the last picture, resetting the DD app, and trying to start a new pano mission did not work. It gave an error saying the app couldn’t focus the camera…

All in all, the 360 panos are definitely helpful for job trailer discussions but the flight mode is insanely buggy and DD seems to be updating it on the fly without notice. Flyer beware.

1 Like

I used pretty much all of this and the rest of the app functionality in succession yesterday ending with three automated panos and could not replicate any of this.

P4P V2.0
iPad Mini 5
iOS 14.4.2
DD 4.45.0

This is pretty standard for our Phantom use now so i’ll keep on it.


P4P V2.0
iPad 6th Gen
iOS 14.5.1
DD 4.43.1 - I was wrong, update is available. Will update and try again.

1 Like

I will do the same with my iOS. Bleeding edge my Friend. :slight_smile: