P4P V2.0 Not completing Flights

I went out to fly today, 8/22/18, with my P4P V 2.0, I set up the flight in the office and made sure all equipment was up to date. I have both an iPad (WiFi only) that is running the V 2.79.0 of DD and iOS 11.4.1 and also an Android, Galaxy S9, running V 2.79.0 of the DD app and is Android V 8.0.

I was able to get linked to the drone and initialized and take off. The drone then completed the first leg of the flight and made the turn to start the next leg and proceeded to fly about 100’ into the second leg and it would appear that it was hitting an invisible barrier. The speed would drop to 0-1 mph and the drone would not move. I had to abort the mission and bring it home. I tried several different combinations of power off reboot as well as using a different device to run DD. All had the same result. I tried planning a new mission in the field and flying it with the same result. We had three separate missions planned in the same area and all three had the same result.

Thankfully I also had our older P4P V1.0 with and was able to complete the mission using it. I tested it with both the S9 Android and the iPad both and worked flawlessly.

Anyone else had this issue?

I have only completed 2 missions previously using the P4P V 2.0, that being said neither one of them had any issues.

I am going to go through and make sure everything is current on all ends and try again at a different location. I am hoping this was just a bad stroke of luck and it will work itself out. If not I am back to square one with the P4P V 2.0 not working well with DD.

Thanks for any response.

Hi @ggeorge,

I’m sorry you had this issue happen to you while you were out on site. I’m going to escalate this for further investigation, but please let me know if the issue persists in a different location. Sometimes GPS signals and such are better in other areas. If the issue only occurs at this specific location, that may be the culprit.

Cheers,
Christina

Hi @ggeorge, thank you for reaching out to DroneDeploy!

I am sorry to hear about your flight inconsistencies from the P4P V2.0. We certainly want you to fly confidently!

I went ahead and check your mobile logs, and I saw that there were large periods of time for which there were bad GPS signals. When the drone doesn’t have a strong GPS signal, it will usually go into ‘atti’ mode until it can get a strong signal, and won’t follow its waypoints. A poor GPS signal can be the result of a hardware defect, of environmental conditions such as interference or weather, or can be indicative of a necessary firmware update, which I would suggest you check for the drone and for the remote controller in the DJI Go app.

Additionally, I saw compass errors, so I would recommend calibrating that in DJI Go as well. A bad GPS signal and a bad compass is a combination that will certainly cause the drone to not know where it is and to exhibit strange flight behavior.

So to summarize:

-Try to optimize flight conditions to help promote a strong GPS signal as much as possible by flying away from large metal objects, in good weather, and in as open an area as possible
-Check for firmware updates on drone and controller
-Calibrate Compass

-After all of this, fly manually in DJI Go. Wait for a ‘GPS - OK’ readiness and fly in the area to test if the drone responds as you would expect. Once you see normal behavior, I would then land, quit DJI Go, and open DroneDeploy to map.

Please let me know if you have any additional questions, or if I can assist in any other way.

Best,
Adam

DroneDeploy Customer Support Associate

This sounds very confused,
Did he have GPS problems or did he have a compass error which forced the Phantom to ignore GPS data because of conflicting data?
Calibrating the compass won’t “fix” anything .
As long as the Phantom is flying straight and hovering without spiraling, there should never bee any need to recalibrate the compass.

I understand that there may have been a GPS signal issue as well as possibly a compass calibration issue. What I am not understanding is how on three separate missions the P4P V 2.0 started the missions fine and flew the first leg and then quit at the same approximate length into each flight. As stated I was also able to change over to a different drone and complete all three missions. I did also test fly the P4P V2.0 in DJI and had no issues. I have not had a chance to get out and test this again to see if it is working in a different location, weather has prevented me from doing so.

As a side note I did check and all software/firmware for all pieces of equipment were at the latest and greatest versions.

Thanks for the info and any help moving forward. I will let you know if I get out and see an improvement in how the P4P V2.0 flies.

Greg George | Survey Crew Chief

Office: 208.664.9382 | E: ggeorge@welchcomer.com | Web: www.welchcomer.com

  • This e-mail and any attachments are intended solely for the use of the individual to whom they are addressed. Please visit our website for our confidentiality policy.*

Hi Greg!

Thank you for the follow up! Would you please be able to let me know the names of the maps for which the odd behavior was experienced? I would be happy to go ahead and look at the flight logs.

@Meta4, to follow up on your question, he had both GPS problems and a compass error. Regarding when to calibrate a compass, here is the info from the DJI Manual:

40%20PM

Best,

Adam

Adam,

Here is the info on the flights. They are in a folder named East Valley School Dist. The flights that I can tell had the issues are as follows. EVSD Flight #1, Copy of EVSD Flight #1, EVSD Flight #3. You are more than welcome to look at all the logs for the flights in that folder for comparison. WC1 is the name of our older P4P (which completed the missions properly), WC2 is the name of our newer P4P V2.0 (which had the issues already discussed).

In the end I was able to fly all three missions, or versions thereof with our P4P V1.0 using my Galaxy S9. I also ran a test in the Mission: iPad test Flight 1 using the iPad with my S9 as a Wi-Fi hotspot, that was the same setup I was trying to use with our P4P V2.0.

I also did a bit of searching on my own and saw that with a Wi-Fi only tablet (which is the iPad we have) several people are using a universal Bluetooth GPS Receiver, as using a phone or MiFi as a hotspot does not allow the tablet to have true GPS location. Not sure if this would cause confusion for the drone as it has built in GPS so it should know where it is at regardless of what the tablet shows. Either way I have ordered one and will try it next time out.

Thanks for any info.

Greg George | Survey Crew Chief

Office: 208.664.9382 | E: ggeorge@welchcomer.com | Web: www.welchcomer.com

  • This e-mail and any attachments are intended solely for the use of the individual to whom they are addressed. Please visit our website for our confidentiality policy.*

Adam … DJI has for years, had incorrect or misleading wording about compass calibration in their manuals. But for nearly two years now, they have corrected it.
If you check what it says in a manual for the P4 pro, you will find that there is no recommendation to recalibrate the compass before each flight or for new locations.
In fact there should never be any need to calibrate the compass under normal circumstances.

If he had a compass error, that will force the flight controller to ignore GPS data (even though it’s perfect).
There was no GPS problem at all. Just a compass error.
At a guess, he launched from a reinforced concrete surface or close to a substantial steel object.

George … the only GPS receiver that matters for DroneDeploy flying is the one in the drone.
Whether you also have a GPS receiver in the tablet makes no difference.

I am assuming that I did have a compass calibration issue as I was able to use a different drone taking off from the same location. That being said the drone did not show any of the flashing light combinations that would suggest this.

Greg George | Survey Crew Chief

Office: 208.664.9382 | E: ggeorge@welchcomer.com | Web: www.welchcomer.com

  • This e-mail and any attachments are intended solely for the use of the individual to whom they are addressed. Please visit our website for our confidentiality policy.*

Thanks that was my understanding as well, we do however use some of the DJI features that require accurate GPS.

Thanks

Greg George | Survey Crew Chief

Office: 208.664.9382 | E: ggeorge@welchcomer.com | Web: www.welchcomer.com

  • This e-mail and any attachments are intended solely for the use of the individual to whom they are addressed. Please visit our website for our confidentiality policy.*

The Phantom’s GPS receiver is as accurate as consumer GPS can be.
There are only two features that can use GPS from your tablet.

  1. Resetting the home point to the current location of the controller (used if flying from a moving boat/car etc)
  2. Follow-me flight
    The Phantom’s GPS is all that is used for all other flight functions.

Hi @Meta4,

Thank you for pointing that out - it does look you could apply that updated procedure retroactively. The reason they had that recommendation (to calibrate upon moving locations) is that ‘normal circumstances’ can be hard to know you experienced - sometimes a bump or passing by something with a strong electromagnetic field can go by unnoticed. We are supposed be notified when the compass needs to be calibrated if that happens, but as we all know, technology does not always work or trigger perfectly. A compass error in flight could be the result of that, or could be because of bad hardware, or because of changing environmental conditions mid-flight.

I can assure you that within this one flight, he had a bad GPS signal right alongside compass errors. It is totally possible he took off from reinforced concrete or near a substantial steel object, like you said.

I do thank you for pointing out that procedural difference and helping with this issue! We always appreciate thoughtful, to-the-book troubleshooting by other users for other users, and please continue to contribute. Have a great day!

-Adam

Hi @ggeorge

Thank you for the follow-up. I’ll go ahead and check out these logs tomorrow and report back! Have a wonderful rest of your day.

-Adam

Hi @ggeorge,

After some investigating, we believe this issue to be likely caused by the low sun triggering the obstacle avoidance of the P4P V2.

If you would like to test this (and we would love to hear the results of this test), we would recommend flying at the same time under similar conditions. However, this time, turn off obstacle avoidance in the DroneDeploy app while flight planning:

07%20PM

That flight will hopefully go smoothly. Then, try turning it back on for another flight to see if it slows to a crawl again. If the light conditions are close enough and this truly is the root cause, for this flight, it will probably hang on that first pass again.

Hopefully, with all of this, you’ll be flying very confidently again! Please do follow up with your thoughts/testing results.

Best,
Adam

I am experiencing this same issue with my new P4 Pro 2.0.
Was wondering if you was able to work out the bugs.

The first few DD flights worked like a dream, then after some time the quad copter would stop and start during its mission. The drone stayed on its mapping lines but would end up burning through batteries before the mission was completed.

It would stop and go appropriately every 5 feet from 0 mph to 6mph. I finally gave up after using all three of my batteries up to complete a 3 acre mission.

Just got back from having something very similar happen to me today. It would get to its starting point then go 0-2 mph along the planned flight path. I didn’t let it go too far before hitting the RTH button. This location is near a highway and I didn’t want it to go really crazy and go over traffic. I found this thread after packing everything up so I’m not sure if the solution given August 28th works. Fortunately, it was just for a personal project so nobody is out a map other than me. Has anyone else had any luck with the obstacle avoidance solution? It was 3:30pm-ish so the sun was on its way down. Thanks in advance.

Travis

I have only had the P4P V2 out once since this happened and it worked just fine, I did a quantities flight on a mission I had previously flown. I experienced none of the problems as mentioned above. Oddly enough I forgot to turn off the Obstacle avoidance. I have not been able to do any other testing to determine if the obstacle avoidance being turned off solves the problem. Wish other people were not having the same problem, but it does at least partly rule out that is an issue with my specific drone. I will let you know how things work out.