P4P doesn't fly with additional cameras

Today I tested P4P with two MAPIR Survey 2 cameras attached with supplied mount.
The drone took off the ground and landed after a while (about 5 seconds). I tried to launch it several times and got the same result.
Without cameras and mount everything worked OK. When I fly manually through DJI Go 4 with cameras attached, I don’t receive any warnings.
Help me please to find out, why mission was interrupted every time.

P.S. The very first launch was unusual. The drone took off, gained specified altitude and began to orbit and landed after having made complete circle. The option “Orbit at the end of mission” was checked and the starting point was set to 1.

It seems I posted to the wrong forum category as I don’t participate in beta-testing. Posted the same to Maps and Data Processing.

Did you turn on Use 3rd Party Camera under Settings?
That may help.

NO, didn’t notice when it appeared. Thank you, I’ll give it a try.

Hi Vlad

I´m interested in your results with the mapir survey 2 and mount, I have exactly he same setup but canot do anything with this setup and DD mainly becuse I canot extract gps info from Phantom 4, I also have the gps tracker, but have not sucess with the altitude info that is not conistent with the altitude registred in the Phantom