P4 Pro Flight Plan Failure

I was working on a mapping mission with my P4 pro the other day approx. 1/2 way thru the flight plan it reach a spot and stopped flying forward in the middle of a track. I brought the drone home changed out batteries and sent it back up to continue the mission. It stopped at the same place. I repeated this 1 other time after restarting the IPAD and the APP and the controller and the aircraft. No difference. Has anyone had any issues like this and what was the problem.

Have you tried the following:

  1. Create a new flight mission?
  2. Tried a different microSD card in the UAV?


1 Like

I agree, probably just a glitch in the flight plan or the full mission never really loaded to the drone.

Mr. Lambert

I changed drones to my p4 adv and it flew the remaining part of the mission without an issue. I also changed to a different ipad mini. Any thoughts

Thank you,

Have you tried the Mini with the P4P? That would be my bet. Maybe try uninstalling the app and reinstalling on the other device?

We had that same problem flying about a 100 acre tract. The drone stopped at the same spot 2 times. moved to a different part of the tract and started the mission again and it worked fine. I have no idea what the problem was.

Were there any radio/cell/microwave towers or high-voltage transmission lines near the area? Interference is the only thing I could think of, and losing GPS lock maybe?

No clean area, as I stated I brought the pro back removed the sd card loaded it in my adv and continued the mission no problems.

That is odd. There are some slight differences between the firmware of the two models so I wonder if there’s some weird restriction we don’t know about that is catching it at that point. What if you reverse the direction of your flight path?

We were a remote location. There were no power lines and no towers of any kind.

1 Like

I have also had this happen. I think in our case it had something to do with the KML boundary we had uploaded. Unfortunately for us the neighbour thought the drone stopping at the same spot over and over, was us spying on him. He then came at us with a baseball bat and hit the drone. Fun times.

We went back a few weeks later with a simplified boundary and had no issues. With the neighbour or the drone.

Either you were flying really low or he could chuck a baseball bat! Sorry to hear that happened. Were you directly over his property? If not, press charges… Seriously, the public needs to be made aware that they don’t regulate the airspace. We get licensed for a reason…

Na we saw him coming so landed and then he pounced. We were flying up to his boundary but not over it. We got the police involved with that one.

1 Like

We have run into the same problem on more than one occasion. We have found that the angle of the sun and direction you are flying will activate the obstacle avoidance function and cause your drone to essentially stop. It is like it hits an invisible wall. We were able to remedy this each time, after the 1st instance, by slightly or drastically changing the direction of the flight pattern. Don’t know if this is the same as your issue but may possibly be the culprit.

1 Like

@minitaz1 Good morning from Texas. Have you been able to try changing the flight path direction?

Like ggeorge said obstacle avoidance. the phantom 4 advanced does not have it as much as the pro. Try disabling it in the advanced menu of flight planning.

This happended to me once. It was not exactly a problem and was a simple thing. My mistake. I had forgotten the distance limit on the drone configurations was too small.

Turn off obstacle avoidance. When the sun is low in the horizon the sunlight can affect the forward vision sensors. Happened to me once and that solved it.

Did you have any irrigation systems in the area? I’ve ran into issues being overtop irrigation electrical lines and it causing issues.