Out of focus

**Summary of Issue:**My drone is switching to manual focus during flight with DD. All my photos are out of focus. At first I couldn’t figure out why no photos were sharp but I just found out that when I start DJI Go after DD focus is set to manual. I have tried several flight planes with different camera settings but all photos are out of focus. Why is it doing this??

Date Issue Began:??

Drone Model: Phantom4Pro

Mobile Device Model and OS version: Samsung S7 running Android 8.0

DroneDeploy App Version: 2.80.0

I would suggest uninstalling and reinstalling the app (if you are connected to cellular or wifi to re-download it) and also turning the mobile device off and back on to clear out possible conflicts.
That’s strange. I’ve flown hundreds of maps with the P4P and it has never been out of focus.
Make sure you firmware is up to date on the drone and controller.

Reinstalled the app. Restarted phone. Drone is updated.
Still blurry photos. Please help!!
I have been able to use DD before. Tried a few flights in the winter and they worked fine. Havend flown since and now it just wont work.
As mentioned before. When i start DJI GO after having flown a DD mission autofocus is set to manual so it is obvious that DD make the focus change. =(

Same problem here.

Reset camera
Reinstalled DD
P4Pro updated
Tried it various ways as i have read about on here to no avail

I can fly manually and video and take phots just fine.

Most frustrating no doubt

I would make sure that we’re all hard quitting DJI Go before opening up DroneDeploy and that camera settings look like so:

18%20PM

I also encountered the same problem today. Images are out of focus from DD. First time that I have encountered this problem. Tried Pix4D capture app and images are sharp there. Also sharp in DJI GO4 app.
Firmware up to date.
Latest DD app version also.

Have done so many testflights now, getting tired of it. Feels like I’ve tried everything. Uninstalled, Re-installed, restarted, tried a lot of different settings but it always changes to manual focus.
Have tried both “clear all” and “force stop” to quit DJI Go app but still no luck.

Have you tried a different mobile? Has your mobile had any updates since the successful flights?

Several updates on mobile since last successful flight. Haven’t used DD since beginning of April. Did a flight in may with blurry photos, back then I thought it was because of too long shutter-times. Now when I started experimenting with manual shutter settings I realized that the photos are actually out of focus.
Just did a test flight with another mobile, Samsung S5 with Android 6.0.1. Still all photos out of focus…

Do you have the DJI controls toggled on?

Not sure what controls you mean. The ones in the red box in Adams post?
I havetried to use manual exposure and that works fine. Normally I have them off.

Correct. Those allow you to setup in DJIGo, close it and then open DD. When toggled off by design it is supposed to bypass those settings and use DD’s auto-configuration, but it sounds like its not. I don’t see in here where you have reinstalled DGo? Path would be to uninstall both. Install DGo. Connect the drone and calibrate. Then install DD and proceed.

True, haven’t reinstalled DJI Go.Will try that to.
However, on my S5 that I tried today I don’t have DJI Go installed.

That was going to be another thought to run without, but I have never tried it… Do you have access to any iDevices?

You may have said this already, sorry it’s not clear.

Have you tried setting “SET FOCUS MANUALLY IN DJI GO” to YES, and then setting focus in Go when at proper altitude, closing, and starting DD and then the mission? And what were the results?

I understand you’ve always left focus to DD in the past and it’s worked for you. I think @MichaelL leaves everything on Auto and has good results. There are also many of us that just don’t trust DD to get it right every time and do it manually. The point at which DD sets the focus cannot be set by the user. If it happens to be on a spot with challenging lighting, or a low contrast subject, the focus could be poor. Doing it the manual way lets you pick a nicely contrasted section on the ground and pulling focus there. Then let DD set the exposure from there using your focus.

I believe DD sets the focus on the ground. You need to make sure that your camera has a clear view and is able to focus on the distance. A blade of grass or rocks being too close will throw the focus off. I set my drone on my case to avoid this.

Hey, now we’re talkin’. Maybe my problem is all user related =)
Can someone confirm that:

  1. DD is using a fix focus
  2. The focus is set on the ground

Is it the same for everyone that when starting DGo after a DD mission the focus is set to manual? Is that the way it works??

@MichaelL, I have now reinstalled both DGo and DroneDeploy but havent had the chance to fly yet. Will do soon. I do not have access to any iDevices.

@Dave, I have never used manual focus in DGo but i will try it out and then set manual focus from the right altitude the way you say

Since DD can control the tilt I wonder if it would be possible to tilt up 10deg or so for the image check?

New tests done. DGo and DD reinstalled. Still have the same problem.
Tried a flight with manual focus set in DGo at the right altitude, worked fine. Also tried to use autofocus in DD and made sure that the camera had free sight while on ground as @MichaelL wrote. Those images got blurry.
Seems like the only way I can get sharp photos is by using MF and set it in DGo while in air.

This is crazy. Never heard of a p4p having camera issues. @Andrea, can @rufus send you his logs? I still think you need to try a different device.