Obstacle Avoidance feature feedback


#1

We’re gradually rolling out the Obstacle Avoidance controls for flight planning. You will see it appear in the next week but may need to restart your app or refresh your browser. When it appears in your account, you will be able to set and confirm your preference for each flight:

Obstacle avoidance is a great feature, but will reduce the maximum speed your drone can fly. It also can have trouble when flying over reflective surfaces like solar panels or water.

Want to change your obstacle avoidance default for new flight plans? You can toggle your default setting in Settings > DroneDeploy Labs:

Obviously, Obstacle Avoidance only works for newer drones with the appropriate sensors: Phantom 4, Phantom 4 Pro & Advanced, Inspire 2 and the Mavic Pro.

We’ll also warn you in our preflight checklist if the drone would not let us enable the feature.

If you have feedback or ideas to improve, please join the discussion below.

James


#3

G’day James

Unfortunately when I was using Drone Deploy the other day after reading the message popup about obstacle avoidance and checking the Obstacle Avoidance Default tab was selected I started a mission that resulted in my P4P hitting a tree, ripping the camera and gimbal off and cracking the shell. It is still under warranty but I do not know if it will be covered when using Drone Deploy.
Can you please help me in regards to this, ie does Drone Deploy void my warranty and/or does Drone Deploy have any responsibility in regards to damage resulting from a software bug?

Thanks and Cheers
Varc13


#4

Hi @Varc13,

I’m very sorry to hear about your situation. It’s extremely difficult to hear about any incidents of this nature, but we assure you that your report is received very seriously at DroneDeploy.

We would first like to understand exactly what happened so that we can properly triage your case. If you prefer to discuss the specifics over a call, please provide your number and the best time to reach you. Do you believe the drone strayed from the intended path? What was the name of the flight plan that this incident occurred on? Please do let us know so we can investigate further.

Again, your success is crucial to our success as a community. We will always do our best to help, especially in unfortunate situations like this. Please feel free to contact us at any time.

Best,
Nipul Roy


#5

G’day Nipul
I think the issue might be that when I saw the Obstacle Avoidance Default tab in DroneDeploy Labs I assumed it was enabled. I did not know that it would appear as an option in my Dashboard. Being only a relatively new user of Drone Deploy I was unaware of this procedure and flew the mission thinking obstacle avoidance had been enabled as the default.
Cheers
Varc13

.

.
.


#6

Hi @Varc13,

That’s a good catch. Obstacle Avoidance does need to be enabled when you are planning your mission. Once enabled, it can avoid situations like these. I am also going to take your feedback and pass it along to our product team, so we can do our best to avoid this in the future.

Thank you,
Nipul


#7

Thanks Nipul
It’s a shame I didn’t catch it before the flight

Cheers
Varc13