Not able to get app to recognize Phantom 4 pro

Since they changed the interface I went out to do some mapping. On my desktop last night I drew the maps and indicated that i was using a DJI p4 pro. My first flight it reverted back to a mavic camera. I redrew the map with my phone marked as P4 pro and began again and it reverted back to a mavic camera. This time it also stated that I was not calibrated. Went home recalibrated my drone and checked my maps to make sure they were all saying that I was using DJI P4 pro. went back to field and the same event happened again. It reverted back to a mavic camera and said I was not calibrated correctly. Checked my DJI app which says everything is normal. Any help would be appreciated.

1 Like

The reverting is annoying but normal and harmless behavior. It should recognize the drone and adjust the flight plan after going through the pre-flight checklist. You’ll know this because the flight paths will widen slightly.

The calibration issue hits me from time to time, but is usually a temporary annoyance and, for me, usually only for the first little while with a new drone/iPad pairing. You should be able to quickly recalibrate in the field using the DJI Go app. It would be a good idea to connect to your drone while on a stable internet connection and allow DJI Go to check the firmware if you haven’t recently.

If your issues go beyond this, you may want to reach out to DD or DJI support, respectively, for each issue.

1 Like

Last night I refreshed my firmware. This morning and went out to start and it still reverted. I went ahead and tried to fly the mavick map But the speed was anywhere between 20 to one mile per hour. So I return to home and had to manually land it. I still can’t get it to work thanks for trying to help.

The speed may be part of a separate and known issue. Sometimes I see that in the morning, and I believe it may have to do with the sun angle and the drone’s obstacle avoidance system. I would try disabling obstacle avoidance or flying at a different time of day or at a different angle. Obstacle avoidance and flight direction manual adjustments are both found in advanced settings. Hope it helps.

Nate the speed issue seemed to be the problem you stated and the next flight a couple of hours later wasn’t a problem. I just flew a field but had the same problem as yesterday. Message from the controller was that I needed to return home for calibration. This time it didn’t force me home but it allowed me to fly the mission. It still reverted back to the Mavic camera setting. I also flew it with my backup P4 pro and the same result. Calibration issue and reversion back to the Mavic setting. I can’t seem to keep a conversation going with the support people and so far they have been no help. Is that normal?

ken

I was re-reading your comment. The problem is when the camera reverts there is no longer a button to choose a different camera.

1 Like

I’ve always had excellent experiences with support, but haven’t needed to contact them during the past year or so, so your experience may be different. I would not give up on them yet.

I’m getting some doubts that I fully understand what you’re talking about per the reverting. I’ll be flying today and will keep an eye out for anything that looks like what you’re describing.

1 Like

This happened to me several times since the updates in the past couple weeks. I returned home the first time. Then it just coming back so I completed my flights with it on. For now I ignore it when it pops up. Please Please PLEASE! tell support. If they only hear it from me, they wont fix it. This app is dangerous at the moment.

1 Like

Also the 20mph and 0 mph is something I noticed when flying to a start point and the aircraft facing the sun. Its going full speed then just brakes! And starts over again because the sun is activating the obstacle avoidance. But I refuse to turn it off. We have that for automated flights on purpose. When the app glitches out and sends the aircraft into a stockpile at 30mph, the sensors will help, but they dont really work around sundown so don’t fly a terrain awareness flight at 1830 and expect it not to fly into a tree. They cover themselves with the word beta.

1 Like

Nate. FYI. My recalibration message seemed to be a phone problem. If I restart phone each time it eliminates the message and the sending it back home problem. It did not solve the camera problem with reverting to a Mavic instead of the P4P. I still think that is a software problem but the support tech’s are supposed to get back to me.

1 Like

FYI. My recalibration message seemed to be a phone problem. If I restart phone each time it eliminates the message and the sending it back home problem.

1 Like

When I flew the other day, I did not see anything out of the ordinary. What I saw is what I am used to seeing, which is that the flight plan shows a path for a Mavic camera, but redraws to a P4P flight plan after the preflight checklist and before the take off button goes green, and it does fly those wider paths. If this is what you’re referring to, I’d have to say it’s only a visual bug and takes a little faith to know that it will be ok, but ultimately does not affect performance. There is a similar bug that occurs when manually selecting the starting waypoint, which is worse in that it doesn’t visually correct itself until after hitting the take off button, but again, does do what it’s supposed to do, even if it doesn’t look like it until the last minute. If you’re seeing something else, I can’t help you from here, but hopefully support gets on it.

1 Like

Thanks for your follow up. Yep mine is different. I do the 18 fields for 4 years and it has always taken 13 passes. Now it takes 16 to 18. I have contacted support and I believe they are working on it.

Hi Ken,

Thanks for raising these - as suggested if you bring these up with support directly we have a process to get the bugs logged and taken care of.

The resetting camera is annoying and even though it is harmless (as mentioned) - it’s confusing and something we should fix - I will talk the the team.

The calibration issue sounds more serious - did the drone reach the start point, attempt to calibrate, then say “calibration failed, returning to home”?

James

Yes, I had that issue also in 3 out of 18 flights where the drone tried to focus the camera and it failed and returned home… But the camera issue is most important to me. On my desktop I map P4p and when I use my phone it comes up Mavic. So I change it again but when I hit the start flight button it reverts back to Mavic camera. It will only fly at 22 mph instead of 27 and it does an extra 3 passes on 150 acre field.

The next issue since the interface change is the first flight I do there is not a problem. Second takeoff gives me a message that I need to return to home to recalibrate but allows me to fly the mission and the third takeoff it goes to start point and returns home saying I need to recalibrate. I first recalibrated and tested drone using DJI 4 app and tried again with the same exact result. Next I took my back up drone and tried it with the same exact results.

I eventually came to the solution that if I reboot my phone it will act like it is the first flight. That strategy worked but with a lot of effort. My phone is a Samsung S8. In the chat room I heard that one other guy seems to have a similar problem.

Any help will be appreciated.

Ken

Hi Ken,

I’ve tried to reproduce this issue on my end and am not having any luck - I wonder if perhaps I misunderstood.

Whenever you create a brand new flight plan it will default to mavic 2 pro, that’s the most commonly used drone on the market. If you change this on that flight template, it will not revert (by design, and in my testing on Nokia device) when you open the flight template on Android, unless you plug in a drone that is different to your current setting.

When you do plug in a drone, we will update to and use the correct camera setting for that drone, depending on the dimensions and field of view.

The other reported bug related to returning home due to calibration is in progress for a fix.

James

That is the problem. I map it out on my desktop and it shows Mavic 2 pro. I change the setting to a Phantom 4 pro. When I open it in the field it again comes up as a Mavic 2 pro. I change it again and then connect to my drone and it reverts back to a Mavic again ( actually it doesn’t show the name of drone at that time the box is missing but because of the pattern and speed I know it switched back)and only allows me to go at 22 mph and it of course flies a closer pattern. I did 18 fields last week at it happened every time, I also tried another backup drone which is also a Phantom 4 pro and it reacted the same way. I fly using a Samsung S8 which I have used for 3 previous years. I have flown for the last 3 years these 18 fields and it took 13 passes when it recognizes the right camera. 2 weeks prior to this flight I did the 18 fields and it did not switch cameras but I screwed up and updated your app to the most current one available.

Thanks for working on it.

Ken Allen