No mission start with Matrice M200


#1

I know the M200 doesn’t appear on the list of supported drones on your Documentation page, but there is an 8th November announcement on the DD Blog saying that the M200 is supported with iOS.

I have tried several times now with an iPad 2017 running iOS 11.0.3 to get airborne, but no joy. Everything looks good until the before take-off checklist runs and it fails the Controller check, saying “Multiple Flight Modes not enabled.” But if I return to DJI GO, multiple flight modes are indeed enabled and I can switch between them without issue.

I have tried connecting, disconnecting and rebooting the M200 and the controller, killing DJI Go, getting airborne, changing USB cables, but nothing yet seems to work. If I hook up my Mavic, the mission runs as smooth as silk.

Any clues on this one, please?


#2

I would suggest uninstalling and reinstalling the app and also turning the mobile device off and back on to clear out possible conflicts. That may help.


#3

Thanks Gary, I will give that a go.


#4

Have you tried the different flight mode switches to see if it needs to be in a different mode to pass?


#5

Thanks Chase, I have some time today to get the machine out, so I will let you know how it goes. I did try switching between modes last time and flew in Sport and Atti modes momentarily to see if anything happened, but I will be a bit more systematic about fault finding today and write it all down. I’ll also try reloading the app as suggested.


#6

Alright, I think I have tried every possible permutation of switching and configuring DD and still the M200 won’t fly a mission.

I deleted and reloaded DD on to the iPad. Checked and saved the DD flight plan whilst in wifi range and then headed out to my remote site (no wifi). Then I tried the following:

Start up without DJI Go, straight to DD, UAV connects, fly mission button pressed and pre-flight check fails at Controller check due to multiple flight modes (MFM) not enabled as previously noted.

Start DJI Go, check MFM enabled (it was), check able to fly M200 in P, S and A; all good. Land, kill DJI Go.

Shut down UAV and controller. Disconnect USB from controller. Start up. Allow controller and UAV to connect and GPS on line. Connect USB.

Start DD - hit fly mission button, fail at Controller check due MFM again. Get airborne using P mode, try DD fly mission but fail MFM; switch to S mode and try fly mission - fail MFM; switch to ATTI mode and then try fly mission button - PASS controller check but fail at upload of waypoints. Hit Retry upload waypoints button - fail MFM. Hit Re-plan waypoints button - fail MFM.

Tried all again with DJI Go enabled in the background - no change. Tried with obstacle avoidance on/off. Tried different USB cables.Tried with MFM disabled.

Finally, tried altering flight plan route but then DD won’t give me a fly mission button - I just get the Save button and nothing I do after that gets me a fly mission button back, although DD says “flight plan saved, connect drone to fly” at bottom of screen.

Pack up. Drive home.

Can anyone see a fatal flaw anywhere (apart from hovering in ATTI mode and attempting to make screen selections at the same time)?

Has anyone used DD with an M200?

Thanks.


#7

We have an M200 in the office that we test on regularly. We also have users that are flying the M200 successfully.

We’ll have someone take a look at some of the logs from your attempted flights to see if we see anything wrong.


#8

Hi @desertoak,

I had my team look at your flight logs and we noticed that these unsuccessful missions with the DroneDeploy app version 2.60.

Can you try the following?

  1. Update and verify that the DroneDeploy app to version 2.61.0.
  2. Turn flight mode switch to ‘A’ before connecting to the DroneDeploy app. We noticed that several flight logs you attempted to fly in ‘P’ or ‘S’ mode. The M200 needs to be in ‘A’ mode to work with DroneDeploy.
  3. Attempt to start mission from the ground instead of in the air

Let me know if this helps.

Cheers,
Christina


#9

@desertoak,

It is disappointing to see you having this difficulty with the M200. You really went all out exploring the logical possibilities. Spock would be proud!

Any possibility your M200 is defective? Perhaps the SDK interface to the MFM is dead. I think this may be very hard for you to determine alone. Back when I worked at IBM, it seemed like the field repair techs spent more time doing substitution testing that using their diagnostic test equipment. So can you get another M200 to try out, say from your dealer? I know my dealer has his own M200 which he would loan me if I was nearby. Or would DD test it for you if you sent it to them? Or can DD write you a quick test with their SDK for you to run that queries the MFM status as it is toggled thru the 3 settings?

I really wish there is something concrete that can be done soon to fix your issue because I was considering getting a Matrice 200 series drone for mapping with DD. But now l am going to hold off until DD can fly your Matrice M200 missions reliably.

Regards,
Terry.


#10

Thanks to everyone for all the above inputs; thanks to @SolarBarn for acknowledging the logic flow, sadly my family don’t always appreciate this dark art. I like your idea of swapping the machine out, but I don’t know of anyone else with an M200 in Tasmania and the closest dealer is in Melbourne which is only accessible by ship or aircraft, so it would be a drama to get it there. Maybe one day we will have remote UAV log-ins to allow the developer to see what is happening.

@Christina, I checked the installed version of DD on my iPad and it tells me it is version 2.61.0 - I can send a screen shot if you wish. I only uploaded this copy a day or so ago, but will try uploading a fresh one. I’ll also try a launch in A mode - I didn’t know this was the preferred operating mode for DD with an M200. Am I right in assuming DD takes full flight control in A mode, even though the DJI GPS stabilisation is disabled? Should be an exciting experience if it doesn’t.

Let’s see what happens.


#11

@desertoak,

Does Pix4D or Altizure support the Matrice M200? I tried Pix4D and it flew my Phantom 4 Pro better than DroneDeploy with very evenly spaced pictures. They have a free 15-day trial period. What I did not like in Pix4D was the lack of robustness in generating a 3D model; DroneDeploy’s generator is much more tolerant. Also I had to do local processing of the pictures to create Maps which could take 8 hours on my laptop. Allegedly they also offer cloud processing but I never figured out how to do that. If Pix4D flew a mission successfully, then at least you would know that your M200 is working well. This does not guarantee it will work in DroneDeploy but at least you will be a step ahead of where you are now. PrecisionHawk’s PrecisionFlight is another possibility to check for M200 support; I have also used it to fly a mission.

Regards,
Terry.


#12

An exciting day with the M200 and DD this morning…

Reloaded DD onto iPad; confirmed 2.61.0 and then out to field. Fired up M200 in A mode on the ground and tried a launch with DD - passed Controller check but failed to load waypoints. Got airborne in A mode and tried again - same thing; no upload of waypoints. Interesting to note that the planned track disappears off the map display completely, whereas for the Mavic the track definitely stays there as the aircraft icon follows it.

Tried Reload of waypoints button several times whilst airborne, but just as the green tick goes in to the flight plan checklist circle, the red X for Controller failure comes back. Tried changing modes to and from A, S and P to no avail. Just before I gave up and flew it home, I hit the blue tick in the bottom right hand corner which appeared to be greyed out. Suddenly I was looking at the inflight telemetry screen with battery levels, altitude etc… I tried a control input and nothing happened - the M200 just sat in the hover about 15m up. I switched from P to S to A and no response to any control input. Noticeably, in A mode there was no drift downwind, so something was keeping it locked in a stable hover.

The big red Home button beckoned on the DD display so I tapped that and got the familiar beeping and a male voice telling me the M200 was coming home. Problem solved, I thought. It climbed and started heading back and all looked good until it overshot the home point by about 10m and started descending - towards the roof of my car. I tried various inputs on both control sticks, but nothing was changing the descent. I momentarily assessed whether I had enough time to move the car - but that was a no. I tried switching again from P to A and back with control inputs to fly up and away and suddenly at about 4m altitude the M200 shot forward about 7m over to a flat area and then landed without any further input from me.

Learnings from this one? I don’t think I’ll try random flight commands again when things aren’t going as per plan. And I might leave the car keys in the ignition.


#13

Hi @desertoak,

I just wanted to update you and let you know my team is still investigating the issue you’ve reported. I hope to have some info to share soon.

Thank you for your patience and cooperation - it’s greatly appreciated!

Cheers,
Christina


#16

Hi @desertoak,

My team is investigating the issue but has been unsuccessful in reproducing the issue. They will continue with working on the issue, but there is no timeline to share for a resolution. If you’re able to test out another M200, that will also help greatly.

Cheers,
Christina


#17

Hi Christina,

Thanks for looking into this for me. I have been too busy to get the M200 airborne since my last flight. I’ll let you know if anything changes.

Regards,
Darin.


#18

I also have an m200. The exact same problem happens to me. I haven’t been able to fly yet after multiple attempts. Same exact errors.


#19

Hi @Brett_Gaulke,

Can you share where you are flying and are located?

Keep me posted,
Christina


#20

Last week I also received the “fails the controller check,” on a M200 (Cleveland, OH area). The Drone Deploy App version is 2.62.0.
After reading this post today I made sure that the controller was in A mode prior to connecting the app and it passed all checks. I did not have time to check but the only other change between the two attempts was that I had switched on the obstacle avoidance feature in the DJI Go 4 app (version 4.1.18 [3018]). Thanks.


#21

Hi @maichle,

Can you verify if you are still experiencing issues?

Cheers,
Christina


#22

Hi @Christina,

I am not having any more issues as long as my start up is:
1- Close all apps on iPad
2- Controller to “A” mode
3- Turn on controller
4- Turn on drone
5- open DD app

If the controller is in any mode not “A” when the app starts I get a “Invalid remote controller mode.” If you switch modes while the app is open then you get a “Error loading waypoints.” You have to close down everything and reopen in the sequence above to get it to work. The errors listed are also confusing because it does not mention the M200, nor do any of the other vehicles listed need to be in “A” mode to work.
Obstacle avoidance had no influence on the outcome.

Hope this helps, maichle