No Live Image?



I am using 2.64.0 version of DroneDeploy.



Also using 2.64.0. Still no live image.


Hi @SolarBarn,

Thanks for getting back to me. Can you share a few more details?

  1. How often does this issue occur?
  2. Does it only occur if you copy the same flight plan and fly the same area?
  3. Can you share a step-by-step process of how to reproduce the issue?

Thanks again,


See my video above that’s how to replicate it and it’s every map, everytime regardless of location… I’ve done 2 jobs 200 miles apart with no live image.


I am copying a prior plan but then editing it. I am flying over roughly the same 20 acres area with a few acres difference between missions. I am taking off from the same location within 3’.

I have not recently tried a mission with a new plan. Too windy today to try. Nice overcast though.



Thanks for the additional info. What I’m wondering is, has this issue happened recently since you first reported it, with a new plan? If so, please let me know.


Yes i am also experiencing same issue. P4P with Galaxy A tab. I have had it on 2 new plans since noticing the preview pane disappeared.


I am also experiencing the blackout on the live feed. Phantom 4 with updated firmware and DD 2.64.0 with a iPad mini 4. Never had the issue before so maybe 2.64.0 broke something?. But…did a cold reboot and the live feed window reappeared…not sure what changed. I do copy flight plans before launching.


Found a solution - in your application manager, find drone deploy, then hit storage - delete cache and local files - live view re-appears.


Hi all,

The engineering team is investigating and trying to reproduce the issue, but have had no luck so it will take some more time to dig into this. It seems like this is only happening with Android devices so if you are experiencing this on an iOS device as well, please share immediately.

If you’re experiencing the issue, can you try the workaround user @falconuav shared and let me know if this works for you?

  1. Go to your Applications Manager on your Android device
  2. Locate the DroneDeploy app
  3. Tap “Storage”
  4. Delete the cache and local files

Keep me posted,


I just flew a map with my Mavic today, same issue for me too - no live view or camera trigger sounds at all. Images were all there but yeah, needs fixing.


Hi @Kevieboy,

Can you verify that you’ve tried the steps I shared above?



livemap is only available on ios