No GNSS observations PPKRAW.bin empty

I did a mission test with PH4RTK with 3rth party GNSS (in mind to process in PPK mode with RTKPOST) but infortunatly i didn’t get GNSS observations. This is not the first test fly mission but the fisrt time as a resultst : PPKRAW.bin and RINEX.obs files empties even the timestamp.MRK dosn’t contain positions while the photos are geotagged.
I’m confused could someone fix me this issue?

1 Like

The files from the P4RTK were empty? At first or after you converted them to Rinex? Was the drone in PPK mode for logging?

Thank’s for interest. PH4R gives these files ordinarly :
PPKRAW.bin
Rinex.obs (converted by itself)
timestamp.MRK
PPKRAW.sig
EVENTLOG.bin
For my case i did 3 tests. The 2 first tests i got all these files normaly. But this day i got :
PPKRAW.bin 0KB
Rinex.obs 0KB
timestamp with no information (juste 0 everywhere)
So i don’t have problem of conversion just the 2 files (PPKRAW.bin and Rinex.obs) after the flight mission test in the SD card are simply empty
I didn’t have to use rtkconv.exe since PH4R gives directly Rinex.obs on the one hand and my PPKRAW.bin is empty to convert it on the other hand.

1 Like

I’m pretty sure you have to turn off RTK mode to get the logs.

I’m pretty sur i didn’t i worked with kml plan and i didn’t go to the rtk page in dji go. I’ll try tomorow meanwhile in case you find something please share it with me.
I found a comment for someone who faced same problem but with no answers.
Thanks

2 Likes

Will do. @GregO, any advice?

I found a comment for someone who faced same problem but with no answers.

Yeah, unfortunately I have seen this all over the internet and is one of the reasons why we didn’t purchase one. We have too big of a GNSS operation to buy into something that is locked down with proprietary files.

1 Like

Those files should automatically be created on the Controller.

I just checked a flight I did last week with RTK turned on and it populated all the files with data. A few of the files are binary files aka cryptic file and a few are texted base.

I would update the Firmware on the controller, drone and the base station. These all must be using the same version (matched version) of the firmware or you could get strange results.

1 Like

On the Controller or on the drone @GregO ?
i tried yesterday with the same steps “same plan in dji go” the only things i changed is i formatted the sd card of the drone (by the way which was not full and 80% was empty) curiously i found all the files populated with data. So over 4 flights 1 gives no data.
It s a serious problem for ppk because one day this will happen again without warning unless we have D-RTK with base station.
Last thing : for the 3 others good flights remaining there is one odd thing :
The 2 or 3 or 4 firsts photos are not covered by rinex data. PPKRAW.bin or RINEX.obs starts observations later by 1 or 2 seconds so if i compare TIME OF FIRST OBSERVATION of rinex.obs and the metadata of the firsts photos i found that the drone start shooting photo before starting to store GNSS data in the PPKRAW which supposed to be done on the fly (transcoding) even the conversion PPKRAW.bin to RINEX.obs
so any idea???

1 Like

Sorry, lol It was a Long day yesterday. The .Bin, .Obs, etc etc are on the SD card in the drone. The flight logs are on the controller.

The files will be generated if you have RTK turned on. I only fly with the D-RTK base station turned on.

I would go to the DJI Phantom 4 RTK Forum and ask your question there, this issue would be better answered over there. I have not experienced your issue.

Have you updated all the firmwares?

INGEMAP

Did you find a solution for the PPKRAW.bin file i empty 0 bytes ?

What where the solution - enabled or disable RTK ?, have same problem ?

1 Like

No solution to recover the data. Format the SD card and re fly. RTK disabled.

2 Likes