No DJI camera attached, no flight possible

I’m unable to fly a mission if I don’t have a DJI camera attached. This goes for both my Inspire 1 and my M600 Pro. Especially for the M600, I need to be able to do this, since I get hired to fly heavy third party sensors. I need DD to fly the usual tracks, since I refuse to use Apple. Sadly, Maps Made Easy and Ground Station Pro don’t work on Android, so I have no choice (Pix4D is too expensive).
Anyway… I plan a mission (without a DJI camera attached), make sure I have “use third party camera” selected and hit “fly”. It does its pre-flight checks and tells me that the making of a test picture failed. Very good; makes sense. It kindly asks me if I want to continue anyway, which I do of course. So then it continues with the checklist… and stops upon reaching the waypoint upload. It never gets passed this item and the show is over.
Anyone having the same issues or willing to test this with aircraft other than the Inspire 1 or M600?

Have you tried recycling power on the drone, controller and mobile device?
You might uninstall and reinstall the app.
Also, try and copy the flight plan (use the three dots to the right of the map name) and using the new one.
You don’t have a tremendous amount of waypoints do you?
You might also try and change the flight direction.

Tried all that already. Multiple times. It’s a bug… it happens with both my drones. @Nipul is aware of this; I was just wondering if other people have the same issue and if they are willing to do a small test mission without a DJI camera attached…

Does anyone want to test this quickly? You don’t need to take off; just create a small mission, remove the DJI camera, and see how far you get in the pre-flight checks… takes 5 minutes :slight_smile:

Hi @jantheeven,

If you are using a non-DJI camera, I would recommend toggle the “Use 3rd Party Camera” option that is available under Setting. Hopefully, this would fix this problem, just remember that DroneDepploy mobile app only supports 3 band cameras.


OMG… no… not this response again. You people aren’t listening and not communicating internally. For the 100th time: that stupid 3rd party camera switch doesn’t do anything, except for not triggering the DJI camera you have to have attached anyway to be allowed to take off!!

I’m sorry. I know you’re just trying to help, but I’m just getting frustrated here. Hopefully the new release will have this fixed.

Having same exact issues using 3rd party camera (slantrange 2p) with my M100. I’ve tried my Android phone and Android tablet without success. Goes through the checklist and tells me that “test picture failed”, I hit (continue anyway) and it stops when trying to upload waypoints. When can we expect a fix here?

They told me it would come at the next release… so let’s keep our fingers crossed.

Tested it yesterday with the new release of the DD app and my Inspire 1 and it works. Will test the M600 today probably. Happy so far :slight_smile:

Works with the M600 now too.

Its old but giving it a try anyways.
Inspire 1 with latest firmware and latest dronedeploy version not working any more without a camera attached?