No Camera View

Hi, I’m new to Drone Deploy and am having an issue. I am flying a Mavic 2 Pro with the latest firmware and using the Drone Deploy app to fly my projects. The app is successfully flying the projects and taking the photos. My map view is showing up fine on my screen but I’m not seeing the view through the camera. When I fly with DJI Go4 I can see the camera view. My workflow is to turn on the controller (also on the latest firmware), connect it to my iPad Mini (latest IOS), turn on the drone and check all systems in DJI Go. Then I close out of the DJI app and open Drone Deploy. Again, map but no camera view. I’ve deleted and reinstalled the Drone Deploy app and since I’ve flown a couple of projects I’ve been through several power cycles on everything. Does anyone have a suggestion on how to solve this problem? Thanks in advance.

Have you tried drone, controller then DJIG4? Also, using the toggles for letting DJIG4 control the camera? This is a very new addition to DroneDeploy and I do not own a M2P so I’m just throwing darts, but it seems that letting DJI control as much of the mission as possible is a clean path. I am sure engineering will be more than happy to take a look.

Yep, I tried it that way too. Maybe it’s an issue with the latest DJI firmware. Thanks.

It’s on DD’s end. I have the same problem with my Mavic 2 Pro using the new or old firmware, it’s been this way right out of the gate since DD updated to support the M2Pro.

1 Like

That’s good to know. I’m glad it isn’t just my machine. Is anyone else having the same problem? Is anyone with the Mavic 2 not having the problem? It would be great to know if it’s universal.

1 Like

Same problem here

Same here. Mavic2 Pro with my iPhone X. It was showing the live camera view some of the time the other day. Now not at all.

Switched to my iPad mini, and it works perfect. So seems to be a glitch somewhere. Assuming the DD app. Looks like there were some similar threads with Phantom 4 early this year.

1 Like

Hi guys!

You can help us fix this issue for you as soon as possible by emailing support@dronedeploy.com and letting us know the associated DroneDeploy flights that you experienced this with.

We have identified that there is a problem but are currently still working to find the root cause. The more examples we have, the easier it is to troubleshoot.

We are still investigating whether this is something that we can affect from our end. Circling back here with the current fix:

In the mean time, you will be able to circumvent black/frozen fpv screens by unplugging and replugging the USB cable anytime after using DJI GO 4 (this is still the case even if you’ve closed the DJI GO 4 app).

As always–the FPV screen will be black if 3rd party camera is enabled.

Does DD have any updates regarding this issue. I have a Mavic 2 Zoom with latest firmware and latest DD build and still experience this issue.

Will it take pictures even while the screen is black?

1 Like

It will, we have had multiple successful flights with it, but the last couple we started experiencing the no camera view issue. Pictures still get taken and the maps have still been looking great. I have a cross state job to do mapping orchards in a couple of weeks and don’t feel super comfortable not having a live camera view.

1 Like

@FIRM_WSU and @Maverick1

I would recommend please checking:

  • DJI Go update
  • Drone and controller firmware update using DJI Go
  • DroneDeploy update
  • Mobile OS update
  • Different USB cable
    -Unplug and replug USB cable when it happens

If after those steps you still don’t have an FPV screen, please email support@dronedeploy.com referencing this forum post. Thank you!

Does your RC have the HDMI port?

I am having the same issue with my Mavic 2 Enterprise zoom.

1 Like

Please see @Adam_Carp post from April 4th and if those troubleshooting steps do not work for you contact them at the support email address.

Same issue here
Have M2P and M2ED, both have the same problem.
All apps, fw and hw are up to date.
Tried IPad, IPhone, Android
Also tried different start ups, replugged cables
Run only 1app at a time
Still no view

1 Like

I am having the same problem with my Mavic 2 pro - Some times it shows live view, some times it doesn’t. Will try the above fixes. I’m mapping cutover areas for forestry work, and if I miss an edge and don’t know it till I upload data, it means another trip to spot to refly missed area. Costing time and money.

1 Like

You might consider running Live Map as well. You will know within 15 minutes whether or not you captured the entire subject.

1 Like

None of that worked for me. Tried everything and still no camera view.

1 Like