New Releases: iOS and Android app (version 2.0.47)

Yes, I tried it today and it worked like a charm. thanks!

1 Like

Does this also require updating any firmware? What is the oldest version of phantom 3A firmware that this new version will work with?

If you are on older firmware it may work. We don’t regularly test on anything other than the latest firmware. We recommend checking with others before updating firmware to make sure it doesn’t affect any of your flights but in general you should stay up to date with the latest firmwares if you want dronedeploy to work properly.

Updated to new DD release this weekend. Camera issues in regards to camera not capturing randomly. Worked once and did not work after that in new release. Pop up says to click shutter button. I pressed the shutter and only one picture is taken.

Flying Dji Matrice 100 with z3 camera.

Any help is appreciated.

I’m now on Version mobile-2.0.47 - 2.0.48. I’ve got a bug where I’m asked to log in every time the app is closed down - like for example switching between DD and Go4 and back.

This is inconvenient in areas where there is good cell network coverage, but makes the app utterly useless if there is no data connection available as it is not possible to get past the sign in screen.

I’ve also noticed that signing in to the app when it has been closed, rather than logging out results in the plans failing to refresh - logging out of the app through the settings tab then logging in again seems to fix the issue.

I’m using an iPad Air 2 on iOS 10.3.2.

I can also replicate this behaviour on my iPhone 7.

Noticed also posted here: Login Logout problems

For the time being uninstalling and reinstalling the app will resolve this. We are working on fixes for this.

I uninstalled and reinstalled the App and still asks for an update.

The update warning will be there for another day. I thought the problem was that it asked you to sign in each time.

I am trying to update with no luck from the App Store = although the download appears to progress normally ( where the little circle around the square icon becomes thicker until it reaches the 12 noon position), when it stops, there is a long pause, then a popup with the not-so-helpful message that states " Unable to Download App - could not be downloaded at this time". This is with a perfectly normal internet connection.

No idea what to try next.

Yes, I was getting the same thing - installed the update, still got the “need to update” message, so I uninstalled the previous version, and now the “new” one won’t download, so I have NO Drone Deploy available to use for my job today.

Ugh.

Seriously? The update warning remains even after updating? Isn’t that just going to confuse and irritate people?

Agreed. We had no way to provide such an urgent message. It updates in our system after about a day when we run some migrations.

I have already updated the app and its still asking me to do the update. Does anybody knows what is going on?

Should be gone now. Let me know if you still see it. For users that update in the future and read this, it will check and remove the message each day or so.

Issue with the iOS version today, in the field: “USB connected. Waiting for drone”. It never got past that point, even after cycling power on everything multiple times, calibrating compass, calibrating IMU… everything. Couldn’t take off. Then I tried it with Android, by hooking up my Galaxy S8: airborne within 20 seconds. Why??

Problem solved! Thnks!

The new version works great!
Before I had problems using the Android version with mission upload times to the Phantom 3 Professional, some missing pictures and loss of video feed during flights.
I have done 5 flights so far with version 2.0.47 and they all went perfect. All the pictures were taken, video feed constant during the whole duration of the flights, and mission upload was almost instantaneous.

Also no flight logs recorded…