New problem. RMSE on a single Checkpoint is extremely off


Long time user of Drone Deploy. I have all of a sudden developed a problem that keeps happening. When using an RTK workflow I now always have a single checkpoint that is extremely off, while the others are good.

232 images obtained FIX Phantom 4 RTK. Emlid RS2 was the base setup on a good NGS survey monument sending correction over NTRIP(Emlid Caster). All Nadir except for a single diagonal line for Altitude Optimization with a 30 degree from nadir oblique setting. Were in NAD83 (2011) ellipsoid but used NGS Geoid 18 Tool to obtain orthometric elevations for each image and then retagged images.
Check Points - obtained with Emlid RS2 as a base on an NGS survey monument in NAD83(2011) with ellipsoid elevation. RS+ was used to survey the points in 2 minute observation FIX only. Changed elevation to orthometric using NGS Geoid 18 Tool.

I ran the same data in Agisoft Metashape and obtained good results, 3 to 4 cm RMSE using the 10 points only as check points. If I start changing the points to GCPs, the RMSE tightens up as expected. With no GCPs the horizontal RMSE is in mm and the error is the expected vertical shift with the use of mostly nadir images.

In Drone Deploy, I keep having the same problem. I keep getting a single check point that is extrmemly off, while the others are good. I have no explanation and need assistance. This is a new problem that has just appeared.

Looking back at the Control Point import sheet, it is fine. The checkpoint in question has good data in it and agisoft used the same control points with zero problem.

Map Processing Report


1 Like

Hey Jaja, great detail. I would count it as an anomaly especially if it looks correct horizontally on the map. Maybe go back to your tagging notification and retag the points and let it reprocess to see if you get the same result.

The only thing that worries me is that there might be a reason for it and it could be affecting the other points. Considering all the others are pretty consistent I don’t think that is the case but due diligence in QC is very important.

By the looks of the data as is you should be able to do a single point elevation calibration of the mean error of those checkpoints (2.52,3.06,2.63,2.81,4.01,1.67,3.08,2.68,3.31) leaving out CP# 1 which would be about -0.29ft and get some very tight results. Personally I would throw out CP# 6 as well and use -0.23ft.

As always thanks Michael for your help.
I will try your suggestions.

This anomaly though keeps happening. I processed another members Mavic 3 Enterprise data and had the same exact problem.

Here is some more information, when tagging the control points, I was given far less images to tag then there should be (I know this from Agisoft’s processing) and I am almost certain that this is an auto control point tagging problem after thinking about it.I am partly just letting Drone Deploy know this issue as I have no idea if it is affecting others. I do have a Support communication opened also.

1 Like

Ok so you have a Phantom RTK and the friend has an M3E, with the RTK module and Beta program? Are you both flying with DroneDeploy?

I have the Phantom 4 RTK, a forum member on here (also Autel Pilots) has the M3E. I don’t think he uses Drone Deploy app for image acqusition nor do I.


Right, but is he using RTK?

Yes, he used the RTK module and used an RS2 over NTRIP as his base. On Metashape I got extremely good results. with no GCP’s and his images were all nadir with an altitude optimization line of obliques, 30 degrees from nadir.