New DJI official firmware release for P3P and P3A P3X_FW_V01.07.0060

I have successfully downloaded and upgraded my P3P to the latest P3X_FW_V01.07.0060.

Any chance to see compatibility from DD Android with it in the near future?

So the new firmware is not working for you with android?

I did not try it yet. As I recall, in the past, DD used to make statements about compatibility of application with every new DJI firmware release.

I will test this today. DJI has become better lately about breaking compatibility but I’ll do some tests.

I did test it today… The DD Android beta reported the now classic message “Could not take test photo”, I pressed Esc, the application displayed the “There is something wrong with the Inspire …”, while greening all the mandatory before flight checks, I pressed the green airplane, it took off, did the path, returned and on the microSD card there were zero pictures…

We’re going to be giving early access to some users of our new Android app in the next week or two. Hopefully a lot of these issues are better. I’m going to start adding some people to the list now. Let me know if you’re interested.

1 Like

Yes, please. I’m in.

I would love to test your new app also. I have experience with beta testing apps and games and I am new to Drone Deploy. I have a Phantom 3 Pro and a One Plus One (Android phone).

I just updated to the newest firmware last night also and was going to try DroneDeploy with it as I noticed it needed beta firmware yesterday and your guide to update firmware seemed to be down last night, and the link is still broken today. This one:

I will give DD a shot though when I go out to fly in a bit and see what results I get.

It’s not necessarily a beta test. We are just updating our app with some major improvements. There will be a period where we release to some early users that have been having some trouble with the older version to see if those are resolved. I’ll add you to the list though.

Well, I’m interested if you need another tester for the update !

I’ve invited you guys. Let me know if it fixes some of the issues you’ve been seeing. There are a few new bugs we are working out such as disconnects being a bit weird, etc.

Yeahh ! Got it ! Will try tomorrow if fine weather !
Have ou got “hard points” on which you worked especially ?

Cool I got my invite too. Also bad weather here right now. Will try it as soon as it clears up.

I also forgot to keep posting that I tried the new firmware with DD on Friday and it would continually give the error Failed to take test photo on my P3P. Not sure if that’s to be expected but figured I’d post it just in case.

Hello again, I installed the Beta and after that the beta DD ok. I poked around in the app before flying.
Here is what I found:

  1. It does not see any of my projected surveys in the Data Explorer, although on the PC all plans appear to have been synced …
  2. pressing twice the esc button does not close the app, it seems one has to go the Application Manager and forcefully close it. But that is an old bug, or so it appears. Not being able to tell which application (DJI Go, Drone Deploy, etc.) controls the USB is a weakness in itself.
  3. outside with the drone started, the app gets over quickly the test camera and the drone does its zigzag. When it returns though, unfortunately what it has gathered is a big MOV file containing still images from what it was supposed to be the test camera picture. 3 GB of it…Last time it flew I said it collected no images. That was correct, but what it did was to save a long MOV file with one of the camera stills above ground. Very weird.

I tried again, this time with a formated micro SD. I started the drone, then started the RC, the Android tablet asked me with app it should use, I chose Drone Deploy and nothing happened, I imagine it is because of the debug collection layer from Beta. I pressed the Drone Deploy icon on the screen, selected the area and then tried to change the settings of the flight (the overlap and height).The settings button is on the lower left corner but somehow it was very unresponsive, after a while it did come out, I changed the values, pressed Esc and since they do not appear anywhere on the app screen I wanted to return to the menu and double check they were all right. pressing the area of the button had an usual effect, i.e. it made the screen from landscape into portrait… Nevertheless I pressed the green airplane, did all the checks fine, very fast, took off, zigzagged and on return another beautiful camera down movie of the whole flight, since the start of the drone. Maybe the drone starts itself in default camera movie recording mode, but I could not see where such a setting is in DJI Go app to turn it off…

I tried again to power up the drone, this time without using Drone Deploy. It seems that the drone starts recording a movie the moment it has been started, which may account for the erroneous behavior I have been faced with lately… Any idea how to turn it off?

So, test flight an hour ago. P3P is the latest firmware 1.7.60, RC 1.5.8
I also had no start of drone deploy after the tab asked for the app to choose.
started “by hand” via the apps. But there, P3P also started, waiting for drone … nothing more.
Drone, RC and tab restart, still the same but DD connected to my account
On the third try, drone connected …Didn’t schedule a mission on the web so, new mission on the land.
Here, I can find again my older flight plans, that is good.
I schedule a new one, no trouble, checks OK after I had forgotten the “F” position.
But I wasn’t able to open flight datas (covering, alt) except opening the menu, taping the gear on the bird line, then ok…
Go fly ! 3 minutes later … app crashed … ;-(
Try and start again, no contact with drone.
“P” position and landed by hand.
Everything cold restarded, App manually launched, coming back to previous mission, to be restarted or continued.
Go continue, all ok.
What is nice is the litle window showing the live pictures
By the way, I found a way to slow done the bird: more front cover make it slow down.
When landed, App asks me to exit and start again if I want to fly again … Oh ?
So did I, new mission, low altitude (15m to try best image quality), warning of non avoiding obstacles, all ok, the field is clean.
Go fly !
And there, all ok but … Plan shows me East-West main legs and the bird makes North-South main legs !
It’s quite strange and I wonder what about the trees 20m behind …
Mission successfully ended, auto landing, all ok except these strange legs.
Now sending pictures to check it out.

But… my trial expires on tomorrow, any chance for a short extension of the trial to continue and check out the App ?
I’ll take monthly plan after when DD will be on final version and the job coming.

And the web app is quite more speedy to uploads pictures, so nice !

Thanks for the feedback. The DroneDeploy Android and iOS app left beta a couple of months ago which is why I am not referring to this as a beta test. We are just updating to a newer SDK and improving a few things people had some problems when using the older version.

Yeah … but still have app crash and no possibility to connect again the bird without shutting all off … ;-(

@chasemgray Read the thread here, but didn’t see whether or not we should be rocking 1.06 or 1.07 for the new ver (limited beta) of the Android app. We’ve been on the last 1.06 firmware release for the stable DD release; just need to know which you’d like us testing with! I’d like to keep firmware compatible with the DD stable Android release as well if possible for service flights. Thanks in advance!