Multi Battery Not working

I am trying to work in Class B air, and start system, RC, AC, iPad 5th gen Ver13.6, DD deleted and reloaded 2 time 1-Saturday and 1- Sunday Aug 8/9.
GO4 Updated to latest, updated firmware to latest P4Pro V2

Class B 50ft grid N of KSAN at the RC Flying Field, Flight plan = 200ft agl…Bird is unlocked

Start flight check and unlock with GO4…Close GO4 and open DD, select mission…check parameters setup on laptop PC…all checks are good to go…take off…fly about 4 rungs of the flight plan…pause, RTH…land…turn off battery…R&R Batt turn on…wait for sats…DD = continue mission…tap…all checks are done and checked off Green…bottom of the screen has a white bar error stating
“Flight Plan not loaded, In No Fly Zone.”

Did I miss a step, or what am I missing? The Flight Plan is setup as:
9:35…13 acres…1 Battery .7in/pxl

Is this because I am trying to turn a 1 battery mission into a 2 battery mission?? Any help is appreciated! I have a 5 battery mission to fly Aug 16th…185 acres in Class C air. Waiver in Hand.

1 other thing…on the PC, Adv Settings…Default Camera seems to be M2Pro…I change to P4Pro V2 yet on the iPad there is NO selection for camera in Advanced Settings

Thank you
Aerial Traffic
Randy Wynant


What version of DroneDeploy were you running at that time? There have been two updates in the last two weeks…

I had this happen twice, but on initial takeoff and I was not in controlled airspace. Once the preflight check completed I received that message and it would not even lift off. I have not had it happen again since updating to v4.12.

Thank you, I updated to 4.12 Saturday. and then delted and reinstalled Sunday… and it still did not work

Today I flew 2 multibattery missions, but this time left GO4 running in the background…that worked!! iPad got HOT but it worked.

Thank you

Randy Wynant

1 Like

Thanks for the update. Interesting… @a

Well, I stand corrected.

Thursday completed 2 over 100 acre lots 2 and 3 battery missions…I was east of Brown Field, and North of Tijuana International right near the border in Otay Mesa, Ca. No issues, and yes I needed to unlock the bird.

I tested again today at the RC flying field…unlocked the bird, sent out on 1st batt…RTH…R&R Battery keeping DD on and GO4 also running…and again after green check on preflight ( left side of screen ) hit the go button, and I get the same error message

Flight Plan not loaded, In No Fly Zone…even though the check shows the Flight Plan IS loaded.

Any Ideas…? Thank you

Randy Wynant

1 Like

Final update on my situation…The previous update was flown in Class D DJI Warning Zone…NOT Authorization Zone.

Aug 8 I updated to DD Ver 4.12 ALL other apps and systems were updated the same day. Aug 9 DD tested again in DJI Blue Auth Zone Class B air. MultiBattery did not work.

I got a Drone Tech student to bring his equipment to the field for testing…he needed to update DD, and once done we found it was Ver 4.13…We initiated and completed a MultiBattery Mission.

I then updated again from 4.12 to 4.13 and initiated a different MultiBattery Mission with my aircraft, and this time it worked just fine.

Any possibility of doing an email blast to your user base when there is an update?? Thank you,

Randy Wynant