Mode setting for Phantom 4 Pro?

I’m hoping to do my first DroneDeploy test today with my P4P. Can I leave my mode setting to P or do I need to switch to A? Any other heads-up or gotchas I need to be aware of?

You can leave it at P.
Issues I have had is connecting to the drone. You need to kill the app completely. Then start the controller, followed by the bird and then start the app. That is the only way I can get the app to recognise there is a drone.
I have a blue hue on all of my photo’s as well.
And I have had the app crash on me once, mid flight.
Depending on what device you are using you may have issues with the camera view. I fly with an Iphone 7+ and that seems to work without too many problems.

Thanks syamaphantom.

I’m using a Nexus 5 phone right now but I ordered an Nvidia Shield tablet. Fingers crossed that I will have the same success with it that others have reported.

Any idea what the blue color is from? Is that ONLY when using DroneDeploy?

I thought all these issues were resolved in the last update? I have neither of the mentioned problems since the last update. Using my iPad Pro…

If you have the blue tint turn off the auto settings and set them up in DJI Go app first, then completely close it out and open DD

Its very odd. My iPad mini performs totally differently to my Iphone 7+ even tho they are running the same version.

And yes I thought that the blue hue was resolved but I definitely still suffer from it.

Thanks for the tip to correct that !

For what it’s worth my flight yesterday, on auto settings, went well:


I am also having difficulty connecting to the P4P but unlike you I have yet to successfully connect. I’m using android and I kill off all apps that are using the USB port then follow the steps that you suggest. Still no connection. I can connect with DJI Go 4, Litchi, and Pix4D but not Drone Deploy


I use the iOS version of the app now; however, when Inused my nvidia shield tablet, which ran an android operating system, I had to get into the security settings and allow DD to have access. Not sure if that makes sense or helps…

A way to try this would be to uninstall both DJI go and DD, then reinstall only DD and see if it connects. If so, reinstall the DJI app. When reinstalling make sure to read all warnings and prompts.

The android version doesnt work as it hasnt been updated by the developers to recognize the P4P. You need to use an Apple product running iOS in order for DD to recognise the bird.


Thanks for that. I won’t be getting a n iOS device so I will just have to wait



I had tried the same steps as you. I had even tried loading DD on two devices that had never been connected to the bird but they didn’t work either. I’ll have to wait for an update


I will dig out one of my Nivida Shields and see what happens on my end.