Mission segments not being completed

Multi-battery missions - segments not being completed

31 Aug 2018

DJI Mavic Pro

iPhone 6, current OS

Latest DD version

Yesterday, I used DD for a very long-multi-battery mapping mission.

I expected it to download the complete flight plan to the drone, but it seemed to have already split it into three segments, one per battery, and only loaded that first segment.

When the battery got low (when there is any wind at all, a mission always takes longer than what DD planned for), that first segment was only 2/3 complete, and the drone returned to base for a battery change, still under the control of DD.

When after the change I instructed it to re-start the mission, it downloaded the NEXT segment of the flight plan, and completely ignored what had not been completed! The same thing happend with the third segment. So I was left with two large chunks of my area unmapped.

This is most definitely not the behaviour I expected - nor does it seem like a rational way for DD to manage a multi-battery mission. Very disappointed.

DD has been improving mulit-battery mission capability over time. The latest version now breaks the mission into essentially 1 mission per battery. Previously it would try to fly 1 mission with you deciding where to break for battery changes. This had significant issues with respect to stopping the DD app , changing the battery, restarting the app and successfully flying all waypoints without skips or repeats. The current version solves this problem. So to fix your issue would mean going back to the old, unreliable version. In a perfect world it could be made to work but only if you owned all the pieces (DD app + DJI SDK + DJI drone). From a reliability perspective the new version should win hands down. But to harness the core reliability baked into the current version is going to require your help. You will need to draw on your experience to plan your mission so that all legs will complete in one battery. I currently plan all my missions for 1 battery and have learned over time how many waypoints/distance will fit. For starters why not try adding 1 more battery change per mission for insurance which will let you cut down on the number of waypoints per battery and should provide better reliability.

Regards,
Terry.

Oh no. Something’s changed. I haven’t used DD for a standard mission for a month or so but I fear I’m now going to be in for a world of trouble next week. I’m terrified.

I never had a problem with multi-battery missions using my Mavic Pro. Ever!

In the past, I would plan a mission on my desktop and the number of estimated batteries was displayed but based on a P4. Once connected to my Mavic in the field, the number of batteries would understandably jump up by 20% or so but it wouldn’t matter as I have a dozen batteries at my disposal. After the end of a leg when the battery was getting low, I’d hit the RTH button, swap out the battery and ‘Continue Mission’. It would take off with its second battery and continue from the last waypoint it completed beforehand. No problem.

If I’ve interpreted the problem we’re now faced with and using the advice of @Solarbarn:-

Option 1 is to use an older, unreliable (albeit perfectly reliable for me) version of the DD app and when there are other useful additions to DD I will miss out.

Option 2 I think you are saying that a multi-battery mission will decide where a battery change is going to be required, only upload the number of waypoints it thinks it’s going to manage in one battery and if I call it in early, in the event it’s a windy day or the condition of the battery is not what DD has estimated it to be, it will then jump to the next portion of the mission before completing the remainder of the first I had to abandon when calling it in early? I do hope you’re joking or I have misunderstood.

Like I said, I am actually terrified my understanding is correct. I have had trouble with focusing my ”supported” Mavic but have since perfected a workaround as DD/DJI are not able to resolve and yesterday was told by DD that it was not a priority for them to enable a very simple workaround to enable their progress reports to work correctly, despite going to great lengths to explain and demonstrate the problem.

Please somebody tell me I have completely misunderstood and when I fire it up next week it will behave normally.

James.

Your Option 2 is precisely what I am saying happened - 100% correct. And it makes no sense at all to me. If there is any wind at all, the mission (and each segment) will take longer than DD estimated. The downwind legs will not be flown any faster than the planned speed, but the upwind legs may not be able to reach the planned speed. It is plain dumb for the DD app to assume that the segments will be flown exactly as IT planned, It should resume from the location that the drone decided to RTH from (or was instructed to).

Well that’s buggered it then! [shakes head]

A few questions for the DD staff if I may:-

  • How on Earth can DD estimate the atmospheric conditions and hold the drone to meeting its expectations?

  • Is the dictated pit stop estimated on the drone connected (Mavic in our case) or a P4 as per the planned mission?

  • Sometimes I’ll have half a battery to use up before moving on to the next. Does it know I only have half a battery or do we now have to start a mission with brand new, full life and fully charged battery?

  • What if I’ve had to pause the flight to avoid a flock of birds? Presumably the mission now needs completely aborting and started again to ensure I can attempt again to manage it’s expectation in one battery?

  • What possible reasons could DD take away all manual control over something that requires human intervention?

I suspect this has not been very well thought through although am still hopeful we’re still missing something. If not, this is bad. Very bad.

I actually don’t think it’s about the DD app removing human control - quite the opposite. I want the DD app to say “OK, that part of the flight plan was not completed; who cares why - we’ll simply resume from where we left off”.After all, MY instruction when I drep up the flight plan was simple “map this complete area”. It was DD’s decision to split it into segments. This seems to me to be to be a daft way to do if. First time round, download the complete flight plan to the Mavic (or any drone). If the flight plan is lost when the battery is swapped (I don’t know if it is) then simply download the full flight plan again, MINUS what has been completed.

It is my responsibility to supply batteries (at whatever state of charge) one after the other until the mission is complete.

It is the DD app’s responsibility to fly the complete flight plan if possible, no matter in how many legs, as long as it is repeatedly “refuelled”.

But by continuing where it left off just leaves us back with the original app and removes whatever advantage they were hoping to benefit from with the changes. And when I mean removing ‘human intervention’, I mean presumbly we have no ability to drag back the extent of the first ‘mission’ prior to initial take-off either. That way we could at least try to estimate the wind conditions but that would then leave a great big opportunity for wasting a ton of battery if the wind wasn’t as bad as we thought. I just can’t fathom it.

Either way, the outcome is the same and a mess, rendering the app almost unusable for me if what you are describing is indeed the case and aa paying customer I am not over the moon about it.

Please could someone advise what the last version of the app is that didn’t behave like this (2.77 was it?) and provide detail of how to obtain and install to my iPad? I have little understanding of how iOS works and only went to the Dark Side to use with this app, but even that seems to be heading south now.

Then perhaps your objectives are different from mine. Mine are simple:

  • I plan a mission. It takes multiple batteries
  • I want the DD app to control my drone to fly precisely that mission, no matter how many battery changes I need to make, no matter how many low-battery RTHs happened, intiated by me or by the drone or by the DD app (I don’t care which)
  • When it executes a RTH, and I change the battery, I expect it to return to the last point it took a picture and resume the mission
  • Repeat previous two steps until mission is complete or I run out of fuel.

But whatever your objectives, the current behaviour makes absolutely no sense to me

What you are describing is how DD behaved before this radical change and how I would prefer for it to remain. This is the DD we know and are accustomed to. We are saying the same thing.

What I can’t understand is the sense in why (or how) it is considered ok to let DD make all of the decisions without allowing us to intervene in the event of a delay or something DD hasn’t been made aware of ie. wind or flock of birds.

Uhoh. I didn’t realize there had been an official change, but I’m going to try this today. @Christina? I just flew one on Friday and it sounds like I might have gotten lucky that all the pieces fit together correctly. 200 Acre - 3 battery mission went fine as far as I know. I’ll pay a little bit more attention this next time.

Feedback here is good motivation for DD to continue work on improving multi-battery missions. But the old way was not without failed missions as witnessed by many forum complaints. It fact all the failure reports I read resulted in me not even trying a multi-battery mission. But with the new implementation and my many mission experience with using the DD app to tune my 1-battery missions to harness most of the battey power, I have much more confidence that I can get multi-battery missions to work well. I found the DD app to be very accurate in the mission time for a variety of mission parameters (flight speed, waypoints pattern & area covered). Then I added some margin for the estimated wind on the mission day. Obviously there will still be failures but at least I will be in control of making fixes rather than struggling to get a glitchy app to work. For those who never saw app glitches on multi-battery missions, the new approach may seem misguided. But for those who tore out their hair trying to get the old version to work, the new approach may be welcome.

As a programmer I know there are limits to how well you can fix your code when there are factors outside your control. I think this is what DD experienced with the old version of the multi-battery app. To move forward I have to find another method to provide reliable results. And then continue to make improvements. I think DD is on the same path. So walk along with them for a bit to provide feedback and ideas for improving this part of the app. I am sure there are dozens of ideas that are worth considering for improving the app. The first that comes to mind is a scale function: say you get to the site and find the wind is stronger than you planned. So you input a scale factor, like 0.8, and each battery sub-mission has its waypoints reduced by 0.8 and some some missions are added to cover the dropped waypoints. This is one way to improve the new version. I am sure there are many more.

Regards,
Terry.

The only problem I had or heard regularly about the original method was the inability for the app to send the drone back to where it was instead of the last major waypoint.
Like I said, I just flew Friday and I didn’t see anything different than before so either someone can post the link on an official announcement or I will talk to them on Tuesday before I believe there was any major code change.
If there was, I disagree with giving the machine/app more control of a scenario like this. Without sensors that read variables like wind speed, humidity and ambient air temp there is no data to act upon and it is then making assumptions under lab conditions. I will definitely be taking a hard look at my logs if there was a change that coincided with my crash.

That’s the only problem I had Michael. I learnt to adapt and work with the major waypoints and to be honest, it worked well. All of my missions without exception are multi-battery and only once did it miss a waypoint in a whole year but that was due to me hitting RTH at the wrong time. I learnt from my mistake and it hasn’t happened since.

Looking through the version history, something is certainly mentioned about the multi-battery missions but it doesn’t give detail. I last used DD on v2.77 so haven’t yet experienced the change it mentions in v2.78 but from what has been described by the OP and Terry, DD does its own thing now without consideration for any outside influences and we have no control over it.

Over the past day or so I’ve been trying to imagine how I might adapt to allow for it and I honestly can’t think of a way to make it work. High winds will inevitably prevent the first leg of the mission from completing on time and it will RTH having potentially abandoned half a dozen waypoints. Swap the battery out and it will ignore the unflown waypoints and fly straight to the next portion of the mission. There is literally nothing I can do to prevent it from happening and why the app is now rendered useless to me unless I learn how to run an old version of it and stick with it. My concern then will be wondering if Go’s updates will conflict with the old but reliable DD version I’ll be stuck with.

I can understand from DD’s perspective that they perhaps need to take a step backwards occasionally to move forwards with a reliable app that works for everybody, but I cannot see how this works for anybody.

image

@jamesc, Thanks bud.

Ok, I do remember seeing that, but a splash screen changes nothing except that it told me what I already knew and didn’t change anything that the program actually did. You can still RTH and continue later if you like.

I’ll be interested to see what they say because I think Ukeastangle is experiencing a bug and not an intended program change.

I’m retired, and I spent well over 40 years in the software industry, the last 5 as a business analyst.

To me the ‘use case’ for this one is fairly simple (using informal language)

  • DD app has the flight plan
  • DD app downloads as much of the flight plan as it sees fit to the drone (at LEAST one battery worth)
  • Drone attempts to fly mission
  • Drone either finishes the mission successfully, or has to RTH either due to a low battery or user instruction to do so
  • Drone lands and user changes battery
  • DD app detects that there is a new battery, and downloads the next segment of the flight plan, CONTINUING FROM THE LAST POSITION AT WHICH AN IMAGE WAS CAPTURED. If necessary, it generates a new waypoint (at this position)
  • Repeat from 3rd step above until out of juice or mission completed successfully or user aborts and decides to call it a day.

This simple approach approach avoids any need to take account of extermal conditions such as high wind. It acknowldges that the DD planning software and phone control app can’t be perfect but it DOES rely on the DD phone app making a few simple, sensible decisions ‘on the fly’. In von Moltke’s famous phrase “No campaign plan survives first contact with the enemy” The enemy here is the weather, especially the wind :slight_smile:

Like you Michael I am hopeful this is a bug but with Terry’s input above I worry it might not be. A bug is the only rational explanation in my mind as it literally makes no sense to remove the operator’s ability to control something without first receiving sufficient data to allow it to make such decisions itself. DD shouldn’t be guessing. Let me do the guessing.

About 6 weeks ago I did fly a very large mission (I’ve mentioned this in another thread somewhere), whereby only a portion of the waypoints were uploaded at the start. It did worry me as I had not seen this before but I let it continue and was relieved to find the remaining waypoints uploaded for the second battery. It never occurred to me that it might not return to it’s last major waypoint after a battery change (as it would normally do), but it did. I think it was only on the first battery it only uploaded the first bunch of waypoints as all of the remaining waypoints, including those it hadn’t completed using the first battery, uploaded for the second battery. There might have been 6 or 7 changes on that mission but each time it continued where it left off. The mission was run using 2.77.

In reading @UKeastangle 's latest post above mine, his complaint now appears to be regarding the position of where the drone returns to after its battery change ie. last major waypoint vs last image taken - DD’s current inability to insert an intermediate waypoint when the drone RTH between two major waypoints, but this is something I have learnt to live with. That being the case however, there shouldn’t be any gaps in his mission as originally reported, but instead he should just be left with doubled up areas.

Please let this be a bug and DD, it would be nice to have an intermediate waypoint when RTH to conserve battery.

Did you have any luck @MichaelL? I’m likely going to be out in the field on Thursday and would rather know if it going to work beforehand. The alternative is run a multi-mission over the office tomorrow. :slight_smile:

Cheers, J

So a bug it was. Successfully flew two 2-3 battery missions today with my Mavic and without a hitch. On initialising the flight, the app did indeed only upload the first portion of the mission and tbh I can’t imagine a P4 would have been able to complete it all, let alone my Mavic.

This is how it all started…

image

At this point it I manually RTH (using the RC) to swap the battery out… (note the position of the drone and waypoint by Lily Hill Road]

image

After the battery change it returned to the last completed waypoint and added another portion of the mission, again without any hope of completing with one battery.

image

Once again, I swapped out the battery…

image

And once again it returned to its last completed waypoint. This time it uploaded the rest of the mission for it to complete.

image

The only differences I found in 2.79 over 2.77 was firstly I was faced with a new splash screen to continue the mission on each entry into DD (having focused the drone in Go4 after each battery change), and secondly, if I reentered DD too soon having RTH, I wasn’t able to continue the mission straight away. Instead the mission was displayed in the Dashboard as ‘processing’. I can only imagine it’s whilst the Live Map was updating. I left it two or three minutes and it was fine but it certainly was a heart-stopping moment as I haven’t previously encountered this since I adopted iOS and Live Map back in April. A bit annoying having to wait too. Internet access was fine so don’t know what it was, if indeed it needed access.

Another example… [started with 39% battery following the end of the previous mission and completed with another couple of batteries]

image

image

image

Off topic but something I would like to know is why does Live Map upload all skewed? In the first image above in particular, you can see that drone is flying in a straight line between waypoints, but the Live Map has an incredibly inconsistent line that doesn’t follow the direction of the waypoint at all.

James

1 Like

Thank you for your in depth testing and screenshots James - the context is exceptionally helpful.

To answer questions in the above posts:

  1. Continuing from last completed waypoint: Your drone should always return to the last completed waypoint after a battery swap. Any behaviour other than this is a bug which our support team will investigate if you drop them an email.

  2. Section of flight plan - how is it generated? DJI limits the maximum number of waypoints we can upload as a mission plan. This is the “section” of the flight plan that you see on the checklist screen when flying a mission with many legs. It’s not related to battery - as was guessed above, we can’t very accurately guess battery usage except based on historical data. DJI automatically returns the drone if the battery gets low, but the user can override earlier if they like.

  3. Live map visual stitching issues or GPS alignment error. Live map may struggle when there are large elevation changes such as trees or tall buildings. This is the cause of some of the “jitter” issues or misalignment.

  4. Multi battery flight improvements. We added that splash screen to help people more reliability complete multi battery missions. So far we’ve seen a 30% drop in time to complete the battery swap. I’m disappointed to hear you are still having focus issues with your drone. Have you tried allowing automatic focus with DD recently? We added automatic focus calibration for Mavic Pro a couple of months ago.

  5. Live map “processing” - This is not supposed to be shown for multi battery missions - you should see the ability to continue as a priority over the “processing” state.

Hi James. Thanks for your input.

In answer to your numbered queries:-

1 - A bug was the only rational explanation and indeed what Michael suggested might be the case. Thank goodness this is what I found, in that the drone flew back to the last waypoint. Any other outcome would have been disastrous.

2 - Again this is what I presumed. The only thing that conflicts however is that only on two occasions have I ever experienced a ‘partial upload’ of waypoints, despite doing many many missions involving a high number of waypoints using 4 or 5 batteries. Doesn’t matter however so long as the app doesn’t loose count with what it’s fulfilled and what’s left to go.

3 - Makes perfect sense.

4 - The splash screen was just a bit of a shock as I wasn’t expecting it having re-entered the DD app. Focusing is a very sore topic for me. You may have read that I’ve been having problems focusing a Progress Report mission and am very disappointed to learn from Andrea that you don’t have any plans to fix. This is a big problem for me and does feel like a bit of a kick in the teeth having worked so hard to mould the way I work to accommodate the app’s characteristics. I haven’t tried the automatic focusing recently because firstly the workaround with the manual focus works perfectly for me right now and secondly, the fact that the Progress Reports are incapable of focusing a Mavic (and @Andrea more or less confirmed that to be the case in a pm to me), leads me to conclude that a normal mission won’t either. Please can I ask you to have a look at Progress Report - Images Out of Focus and perhaps throw some weight around to provide the manual toggles to the mission? It must surely be a very simple addition for you guys and albeit is just another workaround, will almost certainly fix the problem like you did with the toggles originally.

5 - Again, I would think the same as you, only I was faced with ‘processing’ each time I dived back into DD. I have always received an email from DD notifying me of the Live Map being updated a couple of minutes into the next battery/portion of the multi-battery mission, but on this occasion I was physically prevented from continuing when re-entering DD from Go4. Like I said, after say 4 minutes of landing the first battery and exiting DD to go back to Go4 it did correct itself. Just a bit of a pain having to wait, not knowing for definite it would correct itself.

Thank you again @Jamespipe and if you can do anything to influence the focusing fix for Progress Reports I would be extremely grateful. Given many will want to manually choose their exposure settings in any event, I’d almost consider it an oversight for DD not to include the two manual toggles in Progress Reports.

James.