Missing Images

https://app.airdata.com/share/FvDOVd

https://app.airdata.com/share/FvDOVd

GregO

    June 16

I think the Missing Images and the Shifted Images has the same base issue.

The issue I documented is this: (I’ gonna shorthand Lat/Long/Elevation as XYZ)

Normal Process:

  1. Move Drone to correct XYZ location
  2. Gets XYZ Location (Drone at the correct location)
  3. Take Photo (Drone at the correct location)
  4. Write Photo
  5. Repeat Step 1
    Actual Process:
  1. Drone starts moving to XYZ location (The next Photo Location)
  2. Gets XYZ Location (Drone not at correct XYZ)
  3. Drone continues to correct XYZ location
  4. Take Photo (Drone at the correct location)
  5. Write Photo
  6. Repeat Step 1
    In the case of a actual missing photo (big gap in the Dot Map where it’s obvious there should have been a photo, not a dot that has shifted) looking at one of the DD Logs it looks like it could be taking over 2 seconds for the complete Take Photo process to complete. DJI’s SDK API calls checks to see if the camera is busy, if so what appears to be happening is it skips the photo and moves to the next Photo Location.

I’m still waiting on more examples that we can track down the issue inside the DD logs and opening up a case with DD. I’m still waiting on a few files for the DD engineers in the Shifted Images thread. The steps above was generated from what I seen via the photos the end-user supplied. I took 8 photos wear you could see a distinct area in the photos and from photo to photo the area moved the same distant even though the exif GPS Data was reporting the wrong location.

I’m willing to work with anyone that can supply me a DD Log File and photos (in the area that is missing images, however many to show the issue)


Visit Topic or reply to this email to respond.


In Reply To

Sergey

    June 16

After reading the threads I looked in the blanks on their missions. A survey conducted by the 08.06.2019 G. Found two sites are located near the larger distance between the survey points. A detailed examination revealed that the number of frames as if normal, but P4P twice took 2 pictures with exact…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

С уважением, Сергей Яблоков
jablokov@mail.ru
К этому письму приложены ссылки на следующие файлы:
1. _Тараса 2 08.06.2019 г-.zip (30 Мб)

Ссылка для скачивания файлов:
https://cloud.mail.ru/stock/bU96A8ncBUxwuxyPZ8QeCB2a

Файлы будут храниться до 15.09.2019

(Attachment 5ce500d052f6b53003f1221b_2019-06-08-123355-820_2019-06-08-124222-534.log is missing)

**Can’t send DD Log File via forum. Let us know the e-mail address to which you can send **

@Sergey, I sent in your files to DD Support. If you can get me the data I asked for in the last message I sent you that will help them a lot.

I seen something in the DD Log file that may help with the Uneven and the Missing Photos. Unfortunately it just didn’t have as much Error Log as I would like to see, so I asked them for that as well.

Did you look at this example ?

A subset of the original images are in a folder HERE.

Do you have the DD Flight Log and the DD Map URL for this mission? This is what is needed by the DD Support Team.

You can open the DD Flight Log in Excel as a CSV file (Tab Separator) and then you can select the R Column (Aircraft Latitude) or S Column (Aircraft Longitude) and search for the GPS Decimal for either one (you may have to truncate to the 5 number past the .) and you should find a match. If you look at Column BF you will see Yaw Follow or Free. When I see a photo being shifted over (Uneven Photo) you will see two rows of Free. When you see where a photo is missing you will see three rows of Free.

Column BF is Gimbal Mode, the default mode is Yaw Follow in the DD Log, you will see Photos that are evenly spaced (working correctly) and the Gimbal Mode is Yaw Follow and anywhere there is a photo shifted or missing the Gimbal Mode is set to Free. Now I don’t know why the DJI SDK API is switching from YAW Follow to Free, it appears that DD is calling it correctly because it’s resetting eventually back to YAW Follow after a Free Gimbal Mode.

Work Modes

The gimbal has several work modes that define how the gimbal follows aircraft movement, and how many axes are available for control.

  • FPV (First Person View) Mode : Only pitch is controllable. Yaw and roll will be fixed relative to the product while pitch remains controllable.
  • Yaw Follow Mode : Pitch and roll are controllable. Yaw will follow the products heading.
  • Free Mode : Pitch, roll and yaw are all controllable, meaning the gimbal can move independently of the product’s yaw. In this mode, even if the product yaw changes, the camera will continue pointing in the same world direction.

I tried looking at the DD Log to see if I seen a High Wind issue but there isn’t a Wind Column, there is a Aircraft Pitch (Degrees) and Aircraft Roll (Degrees) but those look normal (compared to YAW Follow and Free), so I don’t think wind had anything to do with it.

I flew my P4RTK in 20+ MPH winds on Thurs and Sat using DJI Terra Front-End Software and had no issues with uneven spacings. So at this time until I see DD Error Logs (aka Debug Mode) it’s hard to tell if it’s a DJI SDK issue or a DD issue at this time.

A link to the log on AirData was included. I did not process this with DD. I’m not sure what relevance that would have on the issue we are trying to resolve with the flight app?

The gimbal was in Follow Mode. Free mode is not available on Phantom or Mavic series craft.

I agree, the problem is with the SDK and or the DD integration with it. (without looking at any logs)

I looked at your AirData and your Photos. The relevance is if I take this to DD Tech Support, they are going to ask for the DD Flight Log, the Flight Log tells them a lot of information:

#DroneDeploy 3.10.0
#Flight Recorder
Session ID xxxxxxxxxxxxxx
Session Start xxxxxxxxxxxxxx
#Device
Device Model iPad
Device User Interface Idiom iPad 1
Device Operating System iOS 12.3.1
Device SSID
#Aircraft
Aircraft Model Phantom 4 Pro
Aircraft Name xxxxxxxxxxxxxxx
Aircraft Firmware 01.05.0600
#Aircraft Battery
Full Charge Volume (mAh)
Remaining Life (%)
Discharges
#Components
Battery Cells Number 4
Battery Serial Number xxxxxxxxxxxx
Battery Firmware 02.00.07.30
Flight Controller Serial Number xxxxxxxxxxxxxxx
Flight Controller Firmware 03.02.44.07
Gimbal Firmware 01.50.13.17
Remote Control Serial Number xxxxxxxxxxxxxxxx
Remote Control Firmware 01.04.01.00
Camera Serial Number xxxxxxxxxxxxxxx

As you can see in this snippet of the DD Log File it says wht version of the DD app, The Type of Drone, Firmwares, etc. This answers a lot of questions without having to ask them.

The rest of the DD Flight Log has all the data as to what the drone was doing during it’s flight. This data can tell the location of the drone, the tilt of the drone and the tilt of the gimbal. If the drone was flying in heavy winds and was severely tilted and the gimbal was tilted to the max that could be a issue.

Without having data it’s really hard for you to say the problem is this or that. It could be a firmware issue thats causing the DJI SDK to fail which causes DD to fail. Oh wait was you using DD’s front-end?

Follow up because I don’t want to edit above

After jumping through hoops and getting your Flight Logs from AirData and running them through Phantom Help I was able to download a Verbose CSV of your flight and it shows similar data as I posted above.

What Front-end app was you using to fly this mission?

1 Like

The flight was flown with DD’s flight app. And, it’s the processing of the map that I said was irrelevant, not the flight log. I apologize linking the log via AirData. I assumed you were familiar with the platform where you can visualize the log and / or download the log in many formats including the original file.

Yes I use AirData all the time. And Yes I clicked Original to download your Flight Log as well as the CSV file. I took the AirData Original Downloaded Flight Log and uploaded it to PhantomHelp to be able to download a PhantomHelp Verbose CSV Flight Log.

The AirData Original Flight Log Download is a binary file that was formatted in a DJI format not DD text format, hence why I asked what Front-end you used.

The AirData CSV Flight log is a condensed version of the flight log, it doesn’t show everything.

The PhantomHelp Verbose CSV Flight log is similar to the DD Flight Log but doesn’t have the DD header that I posted above. But it does show similar data and that data from your flight showed the same issues I reported with YAW Follow/Free Gimbal Mode.

The only issue is without the original DD Flight Log I can’t pass that to DD since the columns are in different order and different names (close but different) and I don’t know if DD has a in-house app that can read DJI format Flight Log and have it show them all the DD header information.

Remember I’m here trying to help folks with issues and the more complete data I get the more I can help try and figure out the issues. It beats being told to go report it to Tech Support all the time. In some cases the forum can resolve the basic issues while the Tech Support team works on the big issues as well as add new features. I’ve been a programmer for 35 yrs, Network Engineer, 4th Level Tech Support etc etc and I’m doing this for fun while sitting at a fire station waiting on calls.

2 Likes

I would suggest using DJI Ground Station. It just works and you have full camera control in flight. People need to realise the software used to CAPTURE the data shouldn’t be tied to any particular company as long as you collect to correct data for your job. I have tried PIx4D, Dronedeoploy and ground station. After extensive trials I only use ground station.

2 Likes

I use DD, Pix4D, DroneHarmony,DJI Go RTK, DJI Terra, Litchi and I think I’ve missed a few. You are correct the front-end software doesn’t matter at all.

The only thing is if it does the same issue in the other 3rd party software or not. The real issue isn’t that it’s missing a photo or a photo is shifted because of the Overlaps but it’s how the back-end server sees and processes the image with the wrong exif GPS Data (for shifted photos).

The shifted photo is where the big issue comes into play, it the Map Engine thinks the photo is at X,Y,Z it’s going to try and tie the points from the image to the same photos of that area vs the image being 20’ to 80’ (depends on Altitude) shifted. This could lead to a blurry images and/or a lot longer processing time for the Map to be generated.

Missing photos is no big deal to process, if it ain’t there I ain’t gotta process it!

Interesting. It was definitely a DD flight. My workflow is to start in GO, set exposure and focus, close out GO, open DD and start the mission. Perhaps the header is written differently in this instance? I will pull the log form the iPad again this afternoon so we can see if it differs from the “original” that AirData supplies but I doubt it.

No calls may be boring, but is a good thing, right!

1 Like

I installed GSP, signed their ridiculous release, played around with mission settings and closed out. A little while later, I opened it again and it wants me to sign into the app again. Does your sign-in persist for you or does it ask for you to sign in each time?

The experience that I am having is that there is definitely a miss and when two shots are then taken right next to each other their coordinates are not the same when you take it down to the thousandth of a second. This is confirmed by the Emlid PPK as there is no event where the apparent missed image was. I think this also verifies the fault in the triggering that you have found.

@Dave, DJi has a stupid 7 day rule, it forces you to re-login every 7 days. Sucks if your in the field with no service.

@Sergey, I have sent your Photo Link, DD Map, DD Dot Map to Erika at DD Tech Support, She is escalating the issue to the engineers. I will let everyone know when they update me with what they find.

I will still work with others that is having what appears to be missing photos, that way DD Tech Support will be able to look at multiple flights and can compare between the two missions.

This is what DD Tech Support will need:

  1. DD Flight Mission Link
  2. DD Flight Logs
  3. DD Dot Map (The display showing the dots when uploading the photos)
  4. DD URL to the Processed Map

The more data we can collect the better/quicker they can resolve the issue. If others are willing to test other 3rd party front-end software like Pix4D to see if they have the same issue. This will help pinpoint where the issue may be, SDK, 3rd party app.

Thank you for your work

С уважением, Сергей Яблоков

jablokov@mail.ru

1 Like

Yep, really bad today. New client about 90 minutes away so I sure hope it doesn’t screw the point cloud!

What the hell is that?? That’s got to be up there with your worst Michael.