Mavic Pro Won't Focus with 2.57.0 on Android


#1

Did my first mission with Drone Deploy today on the Mavic Pro.Had no issues with the flight. However upon landing, I found out that all the images were out of focus. The pictures I had take with the DJI Go app were however in focus. I had updated the firmwares this morning, reinstalled Drone Deploy and formatted the SD card before flying.
I’m using a Moto Z Play running Android 6. Automatic Camera Settings were on during the flight. Should I turn this off and check?

With Drone Deploy:

With the DJI Go app:


Manual Camera Settings
#2

Hi @arunabha42,

I suggest disabling the Automatic Camera Settings and rebooting your devices to see if you still experience the same issue.

Cheers,
Christina


#3

Hi,

We fixed Mavic focus issues for the majority of our Mavic users recently. We’ve found that our fix is not working for 100% of users unfortunately. We are planning on adding some sort of calibration similar to DJI Go so that the focus values used are specific to each drone.

Sorry for the trouble.


#4

Thanks, I’ll try that out. Does this mean it’ll use the last configured values in DJI Go app? What I usually do is open up the DJI Go app to verify my Mavic is Ready To Go and then close it and open up Drone Deploy.

Does this mean if my Mavic is currently having focus issues, it’ll continue with the current versions until a fix is rolled out?

Thanks for all the help!


#5

Hi @arunabha42,

We’re still currently investigating issues with Mavic drones not focusing properly. I’ll be sure to update you as soon as I have info to share.

Thanks again for your patience and cooperation.

Cheers,
Christina


#7

Looks great!
I haven’t had much luck though. I’ve been trying all the various ways to try to get focussed shots but nonee of them have worked. I’ve tried switch apps at mission altitude, tap to AF then switch to MF, reinstalled apps but all photos still come out blurry.
I’m on 2.57.0 on Drone Deploy and latest firmware on the Mavic.


#8

Following, have had the same issues with the Mavic and DD on the ipad app.


#9

I voiced my disappointment in a similar thread last month. Having updated the app to 2.56.0 it did help somewhat and at some point the app has since automatically updated to 2.57.0

Where I am now is that the focus is still off, but not by much. Can I live with it? Probably not. To date I’ve been taking off with my Mavic in DJI Go (also Android), elevating to the desired altitude, adjusted manual settings before pulling the USB cable, wiping the defaults and restarting in DD to initiate the mission. The Android work around I can probably live with, but I wish the focus could be mended.

Unfortunately, my trial has now expired and whereas I was evaluating on behalf of my company, I am no longer able to carry out the various functions required to prove its worth. I have received a quote from a DD Reseller and before taking the order they suggested I continued with another trial period first. I do have an email out to Eric to reactivate my account and await a response.


#10

Hi @JamesC,

Thank you for sharing your feedback with us. We’re still working on a fix for the issue with Mavic drones not focusing properly. We understand that this is not an ideal situation for our users, but we’re trying our best and hope to have an update to share soon.

I see that Eric has looped in our support team into your email as well so they should be able to provide more insight for you.

Cheers,
Christina


#11

Hi Christina.

Unfortunately I woke this morning to an email from Support suggesting I use ‘manual settings’ instead of ‘automatic’. In case I have not been clear in my message above or emails to Eric/Support, DJI Go is set to use manual settings and the DD mission is set to use manual settings. ‘Automatic settings’ is turned off in the DD mission yet there is a vast difference between the image I took after manually adjusting the focus in Go and the image DD took from the identical spot at the start of the mission.

I’d upload the images I’ve sent to Eric and Support to this page if I could find the upload button. :slight_smile:

Thank you. J.


#12

Hi @JamesC,

I apologize for the miscommunication from our support team. I can verify that the issue with Mavic drones focusing is still an ongoing investigation at this moment.

Cheers,
Christina


#13

Manual settings are not going to fix your focus issues at the moment. We are working to get a fix out ASAP that will help.


#14

So confused… I thought that was the whole point of going into manual settings - to select manual focus and prevent DD from being able to take control.

Thanks Chase.


#15

Manual settings are disabling the control of things like ISO, shutter speed, white balance, etc. Their original purpose wasn’t a fallback in case things that should be working (such as focus) failed. We are revisiting this and should have something out soon.


#16

Hi James,

Unfortunately our manual camera settings apply only to shutter speed and iso on Mavic. Focus is still set by our app and it seems the Mavic camera lens is both variable and sensitive to focus issues.

We are considering making this to fully manual, so that you can open DJI Go and edit as needed.

James


#17

Ah ha. I misunderstood from stuff I’ve read online and indeed from other threads in this forum and emails I’ve received from your Support. Completely understand now however, thank you. So if I’m happy with the various automatic settings DD use (bar focus), there is zero reason for me to go into Go first and then switch to DD? And going into Go first and selecting MF makes zero difference to the images DD take?


#18

Yes - I’m really sorry that’s the case, but right now there is no focus override available.


#19

Seems I have support coming from all angles. Very much appreciated. :slight_smile:


#20

Same issue on ios. I hope there will be a fix soon. I am trying different altitude with a test misson to see where I get the best focusing, but this will limit all other settings.


#21

I used to be able to get good focus by GO MF in mid air then switched to DD for mission. But with the recent updates of DD, this old trick no longer works.

Recently I found a way to make it work again by Disabling both DD AF & AE then launch mission. While ascending I switch to GO, get focus and keep the setting in AF & AE then switch back to DD to continue the mission. In my case, in order to get control between apps I need to unplug and re-plug the USB cable most of the time.

I’m using DD iOS.
-Focus height 150m+
-Mission Height 300m+

Hope this helps!