Mavic Pro - No pics taken in flight plan

I’m using DD v2.0.35 on Android 7.1.1, Nexus6P.

  1. Starting with no apps running on my phone. Turning on the Mavic Pro, Controller, and connect the phone to the controller and having it start the DroneDeploy App (Just once, no default), It fails to take any pictures 100% of the time.
  2. Same as above, starts the DJI GO app. Choose Go Fly, and take a pic. Verify it took the picture. Exit DJI GO. disconnect the phone, reconnect the phone, choose to open the DD App. Sometimes takes pics, sometimes not.

It’s very unreliable.
What are the steps to get DD to work 100% of the time?


Just chiming in, I’m seeing the same problem here, no pictures taken.
It follows the path perfectly, but no pictures :frowning:

Tried again today. Reformatted the SD card. Now I could see the window get black, indicating that it was taking pictures. The counter didn’t change from 0, but when inspecting the SD card, it had stored pictures.
So now I’ll try and upload them, to see what happens.
The phone connected is a Sony Xperia Z5 running Android 7.0 (Nougat)

I just had this problem today as well with my Mavic. I am using an old Galaxy S4 running DD 2.0.35 and Android 5.0.1.

When I noticed the picture count not changing from 0 while following the flight path, I started to manually take pics using the controller button. When I got back I noticed it did take the pictures when I pressed the button, but not any other time automatically. I will try to reformat the SD card and try again tomorrow. I was looking forward to using the DD app to capture images quickly, hopefully this gets resolved soon!

I had a similar problem with my Phantom 4 Pro, except that it took 5 pictures and then stopped. I continued to fly the mission perfectly but the camera was facing forward and no more pictures were taken.

If I press the ‘camera’ button on the controller, it levels the camera forward instead of downwards.

It doesn’t seem stable to the Mavic, it took about 30 pics, but there are definite holes in the mapping, despite having chosen both sideways and frontoverlap on 75%.
I haven’t supplied angled images yet, only top-down pics, so the map is quite weird as is.

I have exactly the same problem when I use DD with a Mavic Pro and a Samsung Note 5 running Android 6. Perfect flight but no picture taken. When I use DD with the same Mavic drone but with an iPad Air no problem at all and the pictures are correctly taken. Obviously a bug in the Android version !

I am having the same trouble s well. Any news or updates on a fix?

I’m having this exact same problem with my Mavic Pro and Samsung Galxy S6. It takes off and flies the path ok and lands at the end, but when I go to upload photos there are none. I tried again today and notice the photo counter (which I hadn’t noticed before) never changes from zero. Does anyone here know the solution?

I tried this today and it flew the mission perfectly but took no photos. Using Mavic Pro, Samsung Galaxy S6. I’m interested to get notified when this is fixed.

I had the same problem today with the new DD update. I have a Phantom 4 Pro with a iPhone 7 plus. I noticed that the battery indicator is red with a ? mark and the photo camera is tracking the picture count is not displayed. Any help is appreciated!!

I have a similar probelm. Flying Phantom 3 Standard. Although after take off my flight plan changes from rows that i set to a big triangle. It flies and takes no pics. Apparently offline mode does not work either. I had to access data to load an “offline” map. I had the same problem with Precision Flight, thats why I downloaded Drone Deploy. I guess I will have to pay for an app that works.

Same issue - mavic pro iphone 7+ all firmware and apps updated - 2nd time no photos were taken but the mission was flown twice… this has been going on for a month and nothing?

and I’m a paying customer… first the overblown white balance now no pics?

I can tell you that the issue is not specific to DD. I fly three of the Mavic Pro’s using iPhone 7Plus and also using the iPad Pro. I can tell you that there were some issues in the past but this was related more to the update in firmware from DJI. Even Litchi published a month ago that their software was having issues with the DJI firmware update but has since released a comment stating that the new update from DJI fixed it (or something like that).

Mavic Pro is a bit tough at times but this is mainly due to the fact that it likes to control ever aspect of the drone. Meaning, have your tried to fly DD without accessing the Mavic APP? This is how I do it and I see no problems. However, when I have the the Mavic App (DJI4) running in the back, I do notice a few times where I do not necessarily have control with DD.

Try connecting to the system without opening the DJI4 APP and then see if that helps. If not, turn off the automatic settings on the DJI camera settings and then run the DD software. If that does help, let me know and we can do a live video so set yours up the same way I have mine and we can see if it works then.

Andriod 7.0.1
DGI Go 4.0.6
DD 2.0.42

Same story here. My Mavik was taking great pictures then just stopped with DD… I bought a new, bigger, memory card and just re-flew the flight plan. This time my Mavic decided to take 5gb of (blurry) video and no photos. Totally confused.

On the Android version, I have only been able to make the DD work if I’m absolutely sure that the DJI Go 4 App is not running.

It’s not just a Mavic issue; I have it too with my Inspire 1. Very unreliable… I don’t know what’s going on…

My experience so far with Mavic Pro and Android.

On first DD flight, it launched, flew the route, took photos, but they were out of focus.

A few days later, I tried to redo the route to get in focus pics. Mavic got to first waypoint and just hovered, no photos, no following mission, nothing.

Yesterday, tried again. Took three batteries. Using DJI pro, went up to altitude, manually set camera focus and exposure, killed DJI GO, started DD. Went to first waypoint and drone just hovered. Tried to get it to go but it just sat there. Finally brought it back and changed battery.

2nd try, same procedure, Use DJI GO, up, focus/exposure. Kill DJI Go. Start DD. Off to first waypoint. This time it starts going, but it is not taking photos, and the camera is pointing at the horizon rather than down. Try to force camera down, but it just returns to horizon. Return to home.

Last try, fresh battery, Use DJI Go, Up, focus/exposure. Kill DJI Go. Unplug controller from tablet, plug in to tablet. Select DroneDeploy. Start mission. Same as before. Goes to first waypoint to start mission but camera immediately goes to horizon.

So, not having much luck finding that perfect sequence of events to get this to work on Android. And using DJI first to go up, hover at altitude, set camera, close DJI, Start DroneDeploy, get everything loaded there, uses up about 10% of the battery so…