Mavic pro chklist ok then obstacle error

Hi! I bought an ipad mini 5 couple of days ago just so I can use terrain awareness. Drone deploy installed without error. I prepared the flight plan using the web-based interface. I then accessed the flight plan using the flight app. The app communicated properly with the mavic controller. Upon detecting presence of drone through the controller, the app said drone connected. Proceeded then to the flight checklist and it successfully gone through the various items. Once checklist checking was done an “obstacle” error showed up at the top of the app interface! Tapping on the takeoff button made the app load the flight plan to the drone but after a while it just goes back to the green colored take off button. Thinking internet connection is required, used a hotspot to connect to the internet. Still obstacle notification shows up! Any suggestion how to resolve the problem? Thanks

1 Like

Maybe a dumb question, but…is there an obstical? Like, are you pointing the MP at a wall or some grass or something else close?

If not, was it pointing into the sun? I hear that sometimes messes with the obstical avoidance system. Turn the MP away from the sun, try again.

Hi! Thanks for the reply. The obstacle avoidance was purposely turned off. When terrain awareness was disabled the drone was able to execute the ~100 hectares multiple battery mission without adjustment to how it was position initially on the ground before take off. Any additional thoughts?

Just wondering about this:

Was this successful mission flown with the new ipad mini?

Yes it was a successful mission. However, the objective of using the ipad mini 5 to use the terrain aware feature encountered the obstacle error and the plan mission for that objective failed.

1 Like

Then unfortunately I’m out of ideas. If that mission completes successfully with your ipad mini 5 with terrain aware off, but not when terrain aware is on, that’s going to be a support issue.

HI All!

WildDoktor thanks for helping diagnose the problem.

I am attaching the elevation profile of the path I was trying to map out with terrain on. Perhaps, you guys out there can have insight on why dronedeploy did not execute the flight. As I have stated before, without terrain aware, the flight was successful. The path consist of going northwest then coming back and land. The entire path was 2km+ in either direction making the total flight equal to 4 km. Above ground level was set at 75m and take off point will be the beginning of the path.

Many of the reports that have popped up over the past couple of weeks have been the MP1 so there has to be something in the code that it doesn’t like. We have a Mavic 2 Pro on Android and a couple of P4P’s on iOS and never have seen anything like this.
That said TA does add another layer to it which is probably a completely different issue but there are some keys. When using TA your system could think that you are going to go beyond the allowed altitude since it is calculated from the Home point. TA missions also create allot of extra waypoints for the changes in trajectory. You have allot of elevation change so there will be a good amount of extra points but the run itself is pretty small so I don’t think it is surpassing the limits which I think is 99 points. Last thing I can think of off the top of my head is that terrain like this with allot of relief can cause issues with GPS and if your can’t get a good lock then the drone’s altitude will be limited and the mission won’t start. These are just typical scenarios that could be contributing.

1 Like

Thanks for the perspective. On a side note, terrain aware is now on Android?

On the aspect of GPS I would think reaching the point of green and ready for take off is indicative of good lock unless the code is anticipating that down the path it projects GPS to be problematic and accordingly does not want to start the mission.

1 Like

Unfortunately, I’ve not been able to execute any flights with DD for the last 3 months or so, using either Android or IOS. So…


1 Like

I’m not sure who you were replying to but no TA is not on Android yet. I mentioned Android because I am using other flight software for the Air 2S until DD adopts it.

Hi Michael! Thanks for pointing possible TA code conflict with MP1, at least base on recent postings. Yes, I was replying to your note on android. 'Just want to be sure buying the mini 5 was the right thing to do to test TA as indeed that feature is not available on android.


Hi All!

Tried again today shortening the distance just to see if the internally added waypoints by DD to the one I defined in the general area is not the one causing of the obstacle error. Still no luck! Drone just sitting and receiving uploaded code thinking about it and deciding again not to fly.

I guess investing in an ipad mini was a wrong move. 'Will try the flight path tomorrow using litchi. Hopefully, will accomplish the mission though down on funds!


I know people won’t like it and I don’t know how long you have had yours but we need to realize that it is 6 years old and with most technology that’s at least two generations. Once DroneDeploy gets the Mavic Air 2 dialed in hopefully the iOS mSDK will be available and then they can roll right into development for the DJI Air 2S. That would be a good time to upgrade.

1 Like