Mavic Pro 2 Return to Home Slow

Post is to see if anyone experiencing mapping job where mid flight battery swap or end of job the return to home process, this has happened on 2 of last 6 flights the past 10 days, the return to home begins but my Mav2 stops every so many feet then starts moving again and (undetermined time or distance at this point) then stops, then starts and stops. I have not been able to determine any consistent pattern as i first thought maybe the wind was blowing hard into the face of the drone but it was not as it was flying cross wind back in one instance. The 2nd instance occurred yesterday and was on completion of flight. The first occurrence became concerning because it was a battery swap need and I was 300 yards away and i finally started to try taking over manual control or I would have likely seen the drone land as I was down to 3% by the time i landed due to the slow return. I have just started to try to troubleshoot since i saw this a 2nd time on totally different job and location. Initial check of logs there is nothing out of the norm to this point with motors, sensors, etc showing it just seems to be issue with starting and stopping during the RTH step. I can confirm it was not strong winds in the face of the drone causing the slow flight RTH. That’s all i can confirm but wanted to put out here to see if anyone else has started to see this. I’m not seeing this behavior in any other instances of using the drone to this point except the 2 times when using Drone Deploy Mapping and at this point can’t say it’s a definite Drone Deploy issue but this is where it occurs. No warnings, errors and plenty of GPS Satellites available during flight as well and it no loss of remote connection as I could see full bars and could start to manually take over.

It has been reported that the obstacle avoidance sensors can be fooled into thinking something is in front of the craft if the sun is at a certain angle to the lens. It is rare but could that have been a factor in your cases?

1 Like

Thanks for good feedback and possible factor I can watch for if it continues.

First occurrence it could have been possible as I know I recall thinking how clear and bright a day it was but the sun would have been behind and above drone direction based on time of day 11am range. The drone obstacle avoidance beeps would have been going off as well wouldn’t they? Great thought to watch for though I hadn’t thought of sun and sensors.

2nd occurrence it was completely overcast for that flight so I don’t think that was possible factor.

Good start with something else to watch for as that’s what I’m after as I think this will be one of those process of elimination type issues and hopeful it was just a fluke and doesn’t come back as it’s an on the job issue that we all hope never happens. I think drone would have just landed and I’d have to go pick it up but in both mapping jobs occurred first would have been in a water pond and 2nd would have been on top of metal shops (worst case scenario) so I do want to solve if it’s in need of but at this point it appears I can switch to manual mode and take over.

I’ll add more info if it occurs again. I don’t have anything scheduled for a while so I may just go out and set up some random mapping jobs to see if it happens in more of controlled area.

1 Like

You’re assuming the sensors are working properly. Just for the crack, turn off obstacle avoidance and see how you get on. It might come to nothing, but at least you can then rule it out.

OA was my first guess also. :slight_smile:

I have not tested this myself, but I think it is the control app that controls how a craft alert is handled. So, DD may not alert to OA the same as DJI GO does.

I always turn off OA while scanning for this very reason. It’s better practice to manually fly over to an area of concern and eliminate it in the flight plan if at all possible. I guess there are instances when it might be more practical to leave OA on just in case with the caveat that sensor error may occur. So long as you’re aware that it can happen.

It shouldn’t be if was solid overcast. How far out was the craft when it happened? And no connection loss alerts in DD, correct?

This. I never turn it off, but have only come across the issue once. A month ago maybe? Sun was low and was doing a perimeter oblique thing. It faced the sun and halted.

Took me a moment to work out what the problem was likely to be but like you say, there was no warning or anything from the RC. No beeping as you’d get from Go4. I switched to S-mode, rotated the drone by a few degrees and flew home manually/sideways. It was the end of the mission anyway.

All that said, I always check the area at my mission height to make sure there aren’t any obstructions, but have never thought to turn it off the extra safety feature. Makes no sense, I know. I don’t understand me either.

Perfectly fine, James. OA is a nice tool. I also do a fair amount of video that sometimes is too close to objects to be able to pull it of with the OA on. Otherwise, if there is nothing that OA will get in the way of, I have it on.

Thanks everyone for the input this is exactly what I was expecting with the sharing of experience and tips to try.

Both jobs were flown at 70 meters or higher and wide open areas so no obstacles. 2nd flight I was only about 35 meters away directionally and 70 meters high. No issues with connection and I did look at remote strength and had full signal on both at time of issue.

I think with the feedback provided I’ll just have to go out and run some test mapping efforts to see if I can get it to re-create or hopefully not re-create.

Weather is not the best here lately but as soon as I’m able to try a few test mapping jobs I’ll come back and provide some additional follow up feedback on any new findings and hopefully this will turn into a non-issue.

Thanks again to all for the feedback.
Neil in Texas

1 Like

Sounds good, Neil. For the record, can you tell us the platform (ios/android), OS version and DD app version? Thanks!

You bet.

Latest firmware for Mav Pro 2 and controller.
Apple Ipad OS vers - 14.2
DD version - 4.29 ( this recently updated so at time of flights it was whatever the version before this would have been) I have it auto update

1 Like

Just adding some “me too” to the thread. As long as you’re flying above Minimum Obstacle Clearance Altitude (MOCA), there’s nothing gained with OA. I fly with mine turned off almost all the time because of the very problem you describe with un-commanded halting of the flight. OA is a great idea, but it’s just not been a mature enough feature for me to get much benefit from it, and I almost always get some downside from it.

The S-mode suggestion above is a recommended way to re-take control when the bird is in an autonomous mode like a RTH. I sure as heck would not fly the battery down that low except in an extreme emergency. My own personal minimum is 15%. There are just too many ways that things can go horribly wrong at the very low battery percentage you mentioned. That battery percent is just an approximation of the net of 4-cells. If you have one cell getting weak or any of several other possibilities, you could have the whole rig drop out of the sky on you.

You might want to check whether you can still have the mapping flight resume where it left off after a battery swap if you interrupt the autonomous RTH with a Sport mode intervention. Would be good to know. For sure, if the mapping mission if complete, I don’t hesitate to S-mode it on home.

Please let us know what you conclude. Regards… R

The very same thing happened to my Phantom 4. It occurred on back to back battery swaps and unfortunately resulted in a crash the second time. I continued the project with my second Phantom with no issues. It also happened on a previous project that resulted in a minor crash but I assumed it was a fluke. I contacted both Drone Deploy and DJI but never got a definitive answer. It seems counterintuitive to turn off OA. Most of my flights are for utility lines. My level of trust has greatly diminished.

1 Like

This is just me, but I always turn off OA unless the area is a little dicey in which I will always fly manually. I have seen too many questionable actions in autonomous flight with OA turned on.