Mavic out of focus?



Would it be possible to enable the feature on my account that will calibrate the focus once the drone reaches mission altitude?




Hi, i am useing iOS and how do I verify if the new focusing is working on my DD? I have been using the manual focusing which is not optimal.Will the Mavic Air be compatible with DD?


Hi @Skydeskiven and @BrianP,

I went ahead and enabled the Calibration feature for you both. Please let me know if you still have issues. Giving your devices a quick reboot and double-checking to make sure you have “Set Focus Manually in DJI GO App” and “Set Exposure Manually in DJI GO App” disabled in the DroneDeploy app.



Hi @Christina & @Jamespipe is there a possibility you could enable this focus setting on my account too, I have been running into similiar issues, for example if you look at the area I flew below, I seem to have issues with the roof times always being jagged/blurry.;jwt_token=eyJhbGciOiJIUzUxMiIsInR5cCI6IkpXVCJ9.eyJ0eXBlIjoiUmVhZE9ubHlQbGFuIiwiaWQiOiI1YTZmN2YzYzU4ZmQ3NWVlNWFkZjM3ODQiLCJleHAiOjI1MzQwMjMwMDc5OX0.LkooWpNBid1NKz4upBuOIp3P5JxwiUfJY7z3VN2K6E_q1vlbXqacsyaStKQeHUjW8mO2JMULyWLYraRSNYvGoQ


I’m having the same kind of issues. The photos it took are completelly blurry with my mavic pro, making the results unuseable. Could this issue be fixed or should i try another app?
Kind regards,


@LukeEdAllen If you already have updated to our newest version of our app, this calibration for your Mavic is done automatically. Your Mavic should launch into the air and grab focus before continuing its mission. This new update will not fix the autofocus issue users are experiencing with their Mavic Pros. The above advice is the current work-around.

@RudiNieuwenhuis I would update your app and see if you are able to grab focus with your Mavic.

If automatic focus is crucial, the DJI GS Pro app is available for automatic flight planning. However, this app will not be supported on the Mavic Pro series.



Hi Yusuf,
I think i already have the latest version, because i just started using the app last weekend. I did find a workaround: first launch the mavic pro with the DJI Go4 app, set it at the altitude i plan to capture the terrain in, set the focus, then land the mavic pro, switch app, then fly the already planned flight plan. This worked but as you can imagine it’s a bit of a drag.

I currently only use the app to gather the photos, because i really want full control over the processing of the images. Will the app function after the 30 day trial period and is the 30 day trial just for the cloud based service, or will it stop after 30 days? I really like the idea of getting back in the car where it’s warm while the mavic is flying around on its own for 15 minutes, doing the hard work. :slight_smile: Call me lazy, go ahead!



Thank you for your response. With the new update, the workaround you mentioned should be done automatically in the DroneDeploy app. Sometimes this does not work and users report having to do the manual way of setting focus in the DJI GO 4 app as you mentioned. I understand your frustrations as switching between our app and DJI’s might be cumbersome.

As far as your trial, your 30-day trial will allow you to be on our Pro plan. After the 30 days is up, you will be dropped to our free Explorer plan, which has limited export resolution and functions.

As much as that sounds like a dream, I would suggest always having visual line of sight of your drone just in case you need to take control of the drone or steer it away from danger. Also, with large metal objects (your car), connectivity might be at risk. Just something to think about!



Thanks Yusuf,
don’t worry, I kept and will be keeping an eye on my mavic at all time, and the door of the car was left open during the entire time. :slight_smile:
When you say limited functions, are any of these functions related to capturing the photos or only to the processing of them in the cloud after the fact?
For now, i’m only interested in the flight plan part of the app, not the processing.


Hi @RudiNieuwenhuis,

You can see the differences between the Explorer (Free) and Pro plans on our Pricing Page. Hope this helps!



I would love to have this feature activated as well! I have a mission I am flying tomorrow and didn’t realize this was available.


Never mind, I read to the bottom of the string and see it is already in the newest version of the app. Thank you anyway!


Dear DroneDeploy,
It’s really a shame that the focus of the camera is not working with the dronedeploy app. In the little screen on the phone i’m using it’s impossible to judge the focus and once back at the desk to check the images, it’s too late to retry.
I don’t understand why this is such a difficult thing to fix, specially because it makes an otherwise great app completelly useless.
Please tell me you’ve got a solution to this problem, because if you don’t, i see no other solution then to abandon :frowning:


Hi @RudiNieuwenhuis,

I’m sorry to hear your photos are out of focus. Can you verify that you’ve tried manually focusing your images as well?

Keep me posted,


I’m also interested in receiving the autofocus fix on my account please. Got two maps from today where the images came out slightly blurry and negatively affected the final product.


Hi @jwramp,

As @Yusuf mentioned above, with the latest app update, this feature should already be implemented automatically. Can you verify that all of your apps and firmware are up to date?



I also had the same problem with my Phantom 4 Pro, but i found a solution that should work with the Mavic, too. Both, with the autofocus and with the manual focus, the images were always blurred.
The solution is to focus in DJI Go with autofocus on an object in about 30m distance and then immediately switch to the manual focus (so that the focus can not be changed anymore).
Thereafter, all objects are focused at a distance between 15m and infinity, regardless of the aperture (hyperfocal distance).
In DroneDeploy, under advanced settings, turn on “Set Focus Manually in DJI Go”!
I have written a manual in german language for my colleagues in which the details are dealt with and examples are also provided. Here is the link (if interested):

Best regards


I carried out a couple of missions last week and was jumping with joy when I downloaded the results from the first.

However, my celebration was not to last. After carrying out the second mission it was not so good, reason being the first mission only used one battery whilst the second used four. First mission, perfect, first battery of second mission, perfect, batteries 2-4 of second mission, all out of focus. Despite being on ‘manual focus’ in DJI Go and “Set Focus Manually in DJI Go” in DD, DD took a horizontal picture on take off of each of the subsequent batteries and threw the focus out again. Very disappointing.

I keep questioning what I’ve done wrong or what did I miss, but I can’t think of anything. Up with DJI Go, 50m, take vertical picture, pull cable and exit Go (Android), clear settings, reinsert cable, open DD, start mission. I’m now wondering if I have to do this workaround on each battery and not just the first. Latest DD and latest DJI Go and firmware.



Hi @JamesC,

I’m sorry to hear your maps were not what you expected. I can see how it’s disappointing when you take time to map an area and the quality or results are not what you want. Can you share the name of the affected map(s)? I’ll have my team take a deeper look into this.



Thanks Christina. It’s the latest in my list. “B.M. Mhead”.

It’s only frustrating for the fact that I thought I was there and although I wonder if there will ever be a permanent fix for the focusing issues DD has for the Mavic (not through lack of effort on DD’s part), I honestly thought I could live with the workaround. Grrrrrr. :slight_smile:

Thank you.