Mavic Air Compatibility with DroneDeploy

I’ve also tried Pix4d capture and that doesn’t work. With the air

?

@Mark_Vickers Mark, I’m sorry for your troubles. But to be honest, the Mavic Air is one of the least desirable craft to use for mapping. If that was your main goal in purchasing it, you kind of messed up. You could have gotten the best current platform for nearly the same cost. I hope you find a solution that works for your Air. But if you are serious about mapping then it’s probably best you sell the Air and get a more appropriate tool.

Good Luck!

1 Like

Thanks for your reply. I thought I had indeed messed up. I chose the air for portability. But as you say its simply not man enough for the job. I’ve just bought the Mavic Pro, as I originally intended. Would you say this is more suitable from your experience?

Best wishes,

Mark

The P4P/P4A is the currently the best tool because of the 20mp sensor and mechanical shutter. The Mavic Pro will work better than the Air.

1 Like

Have you potentially found a solution to the error? The options may have changed since the latest firmware update. Maybe DD app is looking for a setting that no longer exists. I would really like to use DD for my inspections, but I really don’t want to have to buy a different drone. I purchased the Air specifically because the DD specs stated that it is compatible.

same problem here (Mavic Air) with DD giving me message re controller when I try to fly route. Pissing me off. I’m in NZ fwiw.

Hi guys. Not sure if it helps. But I wrote a post with my first experience with DD and Mavic Air. Everything worked fine. Probably you did but, have you updated firmware of MA and the remote? Have you tried resetting MA to factory settings.
This is my post

1 Like

Thanks @glaso. That’s what this community is about!

Same issue here. I thought it was a compatibility issue with the new Samsung Note 8 phone that I had gotten, because I had no problems prior to getting a new phone. It must have been a coincidence with timing though. Now when I try to fly with the mavic air and my Note 8 I get the same controller issue that everybody else is getting. However if I go back to my older entry-level phone with probably a previous version of Drone Deploy, the Mavic Air flys.

So it’s not the mavic air firmware itself. It must be the Drone deploy app version in combination with the mavic air firmware, perhaps… in my humble opinion. I will check and see which DD version i have on my old phone and I’ll report back.

I have DD app version 3.1.0 on my previous LG smartphone, and the Mavic Air could fly. With my Note 8 on DD app version 3.4.0, I get the controller error that many others are reporting. I hope that helps the team in fixing this issue. Thanks!

Can anyone provide feedback on which app version of DD you are using and if your Mavic Air flys with it? Can anyone from DD provide feedback on this possible app version issue as well? Thanks.

v3.5.0 on android, just recently released - works perfectly on my Mavic Air!
Had been trying with v3.4.0 , and was having issues getting through pre-flight checklist, something to do with the flight mode options in DJIGo

Sean, thanks for the response. I’m on DD version 3.5 also, but still having issues. I’m on DJI Go 4 version 4.3.14. How about yourself?

Same, DJI Go v4.3.14 - I have also recently updated the drone & controller firmware (but before the DD app update - so not sure what effect it might have).
Have you checked that DJI Go isn’t set as default app in android settings? I believe having it set as default messes with DD trying to take control.
Failing that, it may be time to pray to the drone-gods and call tech support?

1 Like

No defaults set on my drone apps. So it must be some combination of software issues. Maybe I’ll uninstall and reinstall both apps, and see what happens. Thanks.

I am happy to report that I am able to connect the Mavic Air to DroneDeploy again… for now :wink:

2 Likes

Indeed please. My office is thinking about the Mavic Air as a reinforcement/travel ramble. It is incredible to have the capacity to utilize it with DD Tutuapp 9apps Showbox

How long does it usually take to complete your testing phases. Can we expect to see compatibility in the coming weeks or would it be months away? I’m really excited to see dronedeploy support the mavic air as I have one and would like to use it with your app.

How about now? I thought it was compatible since last August?

If it works on some and not others then it is no longer a feature request, this thread needs to be closed and specific bug report threads need to be started.