Mavic 3E Issue - Gaps showing up in maps


It looks like I am getting gaps in my maps with the new Mavic 3E while using DroneDeploy.

I first was concerned it was an issue with the SD card. I was originally using the SD card that came with the drone which was the Lexar 1066x 64gb U3, so I tried switching it out with a Sandisk Extreme Pro 128GB (The highest performing sandisk that I know of). I tried a write test(basically copying the same set of JPG images 20gb worth back to the formatted card) and it seems like both sd cards are fully capable of handling the fast data rates for prolonged time.

The days where I was recently mapping and seeing the issue, it was quite windy.

I am attaching a screenshot of the images versus location (with satellite removed for confidentiality purposes).

This image was collected with drone speed limited to 20mph.

This was done with the default speed of 27mph.

Another at 27mph.

Pilot 2 test 1

Drone Deploy Test from… will check date and update soon

Mavic2 pro example DD

For pilot 2 I used the capture by distance instead of interval.

I am not sure if the issue is tied to windyness or just a general issue with dronedeploy and the M3e. I have not been seeing the issue with the pilot 2 app, but I also use dronedeploy much more.

Anyone else seeing this kind of issue with their mavic 3e’s?

1 Like

I just tested again using a brand new Lexar 1066 128gb memory card (formatted using the Mavic 3E drone) still seeing gaps.

Overlap set to 75% forward and 75% side for all tests

Dronedeploy 27MPH @ 150ft

Dronedeploy 16MPH @ 150ft

DJI Pilot 2 27MPH @ 150ft

All had gaps, but it looks like the Pilot 2 provided a better performance at 27mph than the DD but with wider spacing than the 16mph DD.

All screenshots were collected with the same scale. I just toggled between the dotsets.

1 Like

I’ve not flown the M2E with the Drone Deploy Flight app but here is a square mile site flown using a Phantom 4 Pro V2 using the flight app.

Here is the same site flown with an M2E using Pilot 2 with capture by distance.

Both were flown at max speed, 31 and 33 mph respectively. For what its worth, the gaps in the photos never caused any issues as it was taken care of by the overlap and I never really gave it much thought. I don’t think it is an issue with the SD card.

The sandisk extreme pros are more than capable of handling fast writes, I use them for 6K & 4K videos with no issues. Try flying your missions slower at lower altitude e.g. 150’ slow down to low teens. Also make sure you have not accidentally set your camera settings to J+R. Wind is a possibility if its gusting up in the 30s, however you would also see some combination of zig zag saw tooth in your flight logs of aircraft path, as well as speed fluctuations.

What was your altitude out of curiosity?

They were both flown at just under 400 feet.

1 Like

Thanks, makes sense.

I ran another test @150ft 75% front and side overlap both examples. 18MPH

Pilot 2 app - Timed interval shot - RTK Installed and enabled

Dronedeploy - No RTK module installed - Low light toggle enabled

Just a shot showing both data sets for scale

It looks like timed interval shot might be the trick for the most complete maps! Maybe dronedeploy is forcing distance interval shot mode instead where the drone is buggier. I will try timed interval shot at full speed later to see if looks as good.

I ran the 150ft, 27mph, 75%/75% overlap, timed interval test as promised and the results were very interesting!

The pattern was really good again, with only one “Gap” showing up(see the yellow square photo#136/137). The square south after the gap was photo#138. I compared 136 to 137, and from the image itsself reviewing with my eyes, it is clear #137 took place in the center of the gap(This is just based on the amount of spacing the pictures advance in this region where the drone is traveling 27mph in the long straights). However, the metadata for 137 has identical GPS as 136.

My conclusion is this happened due to stale GPS data or GPS delayed update. This is very interesting because if the photos are distance interval delayed gps updates might perfectly explain the random gaps in the photosets. If the test location is noisier or the GPS signal is worse, this will be more prevalent. Also, timed interval will be more resistant to this since the trigger is less likely to be missed, and even if the gps hasnt yet updated when the photo was triggered, there is more time for it to update and get added to the photo instead of just being missed.

I will put in a request for a timed interval capture toggle in DD.

I also want to add that the rtk might also fix the gaps perfectly in a distance interval test since rtk can update location much faster and more accurately than gps.

I did one final test 27mph 150ft 75%/75% overlap, distance interval with the RTK module installed and enabled, this really helps with the gaps for this same reason.

1 Like