Mavic 2 Pro not recorded images to SD card

Hi everyone!

I had today a very annoying issue. I completed a flight mission succesfully, but when I wanted to copy my images to my PC, I just realized that the images weren’t recorded to SD card, neither to the internal storage of the drone. Yesterday I also had a flight, but there was no problem.
What was this? An application bug? If so, please fix it, because it is really outrageous…

1 Like

Hi szasz! Have you tried another mission with that card and another card?

1 Like

I had the same thing happen to me one day with my P4P. I was able to return to the same location and refly the mission successfully. It has only happened to me that one time in 1,200 flights. Hopefully it will be as rare for you. But, I agree it shouldn’t ever happen. Stability, reliability, and speed should be the primary focus of any software, but especially so for one involved in potentially hazardous and litigious situations.

1 Like

Guys, I can’t believe it!
After 2 days I tried a test mission to see if the problem is still there, and after that when I checked the SD card, the images just appeared on the storage :smiley:
Maybe there was a file writing issue, which was completed on that test flight, I don’t know, luckily the images aren’t gone.