Map process failed


#1

Hello - I’m using the 30 day trial version of pro plan, and have successfully completed 4 maps. I uploaded the files for my 5th map yesterday morning and the icon showed that it was processing. Shortly afterwards, the icon changed from processing to a red circle with an X saying it failed. When I checked back an hour or so later, it had changed back to the gray circle showing processing. It is now showing failed again. I have two questions… 1) does anyone know why this may have failed? There are 80 photos and the area photographed was forest. Is it possible the program was confused by to many similar looking trees? 2) does the failed map count as one of my 10 maps in the 30 day trial?

Thanks for any insight.

Date Issue Began: 12/25/17

Drone Model: Phantom 4 Pro

Mobile Device Model and OS version: iPhone 7 plus ios 11.1.2


#2

It looks like the map was processed two times - once with the regular algorithm and since that failed, it tried again with another algorithm - which apparently also failed.

The problem here is likely effective altitude. For instance 250 feet over flat open ground may have worked fine, but the 80-100 ft tall trees lower your effective flight altitude (as far as the camera and field of view goes) to about 150 feet. This does not give enough unique reference features in each image’s field of view to align and stitch properly. It would probably be better to fly at 350 - 390 feet with about 75/75 overlaps over trees.


#3

I fly missions at 300’ over 2000 trees in a 17 acres area with heights up to 110’ and usually get good results. To achieve this required:

  1. 80% front and side overlaps
  2. Overcast days
  3. Low wind
  4. Low enough speed to avoid any noticeable blurring in the photos.

Recently when I used the automatic exposure settings and defaults (speed up to 34 mph), I got blurry photos even though DroneDeploy reduced the speed to 12 mph. When I manually reduced the max speed setting to 9 mph, the photos showed very little blurriness. I notice the advanced settings page, which provides access to the speed control, is now changed and shows 10 mph default. So maybe the default could now be ok.

I review all the photos from a mission and remove any that are noticeably blurry. Almost all photos at turning points are blurry so I remove those. But you have to look more closely, at least at a few photos, to make sure there is not a small amount of blur in the direction of travel. If so re-fly the mission at a lower speed. Overcast days mean slower shutter speed so the mission time will go up. You need to find a balance between speed and mission time and photo blur. A multi-battery mission becomes necessary at some point. Or you could make separate, one-battery maps.

Bottom line: mapping trees can work well but you need to be more careful with the overlaps, altitude, flight speed, wind and illumination (with overcast being favored). Look at the RMSE results for your mission. My best is RMSE error is
4.5ft with X = 7.5ft Y = 1.3ft and Z = 1.4ft. To see these numbers click on the title of your Mission when on the Data page (this page says <- Dashboard at the top). If you get RMSE’s in this range, I think your maps will look good. But as Gary points out, you need to fly high enough to achieve this.

I think part of the reason my RMSE is so low is that I fly only E-W dominate missions (1200’ E-W with 70’ N-S at the turn ends). This keeps the latitude (Y) constant for the long E-W legs with only the longitude (X) changing continuously. You could try flying some missions like this (or long N-S legs and short E-W turns) and see if it helps.

Regards,
Terry.


#4

Terry,
Very helpful information. Appreciate it greatly. I plan to re-fly today and try again.


#5

I tried this again with a second flight on a cloudy day, flying at 350’ with a speed of 10 mph. I was in an area with no cell coverage, so I made the maps available offline. When I got home, the flight showed as if I hadn’t flown the mission and I was not able to upload the photos. Later in the evening everything synced up and I was able to upload the photos. There is no stitched 2d image, but there is a stitched plant health image. Any idea why I can’t see a 2d image?


#6

Have you reviewed your photos? Do the ones you uploaded look good with no bluriness? How many did you upload? On my 17 acres I upload about 200 photos from my mission flown at 300’ with 80% front & side overlaps. This is about 12 photos per acre. At your altitude it would be about 9 per acre. Is this close to your number per acre?


#7

SolarBarn - I just rebooted my computer and now the 2d image displays. The flight area was 28 acres and I have 119 photos.


#8

Good to hear. How good are the results? What front and side overlaps were used in the mission? The one thing that strikes me is that there are so few photos per acre, only 4.25.

Regards,
Terry.