Lost Drone (Flyaway?). What May Have Happened?

I am posting this on here mainly to see if anyone has had a similar issue or has advice for next steps and/or preventing this from happening in the first place. I am new to using UAVs but as far as I know I set things up the correct way and took the necessary steps that I was supposed to take. Please let me know if I am wrong.

I created a new project on Drone Deploy and loaded a property boundary KML which was roughly 300 acres. Set all of the necessary parameters (300 feet, 70% overlap). I saved the map/project and moved on to setting up drone (Mavic 2). I connected controller to iphone, turned on the controller and then the Mavic 2. Opened the DJI Go App where I got a “New Firmware Update is Available” message. I updated the firmware and repeated this step for all four of my batteries.

When I got out into the field I took everything out, connected phone to controller, powered on controller and then drone. I opened DJI Go App and checked camera, did general visual inspection, moved drone up and down etc. This is where I saw a message that I needed to calibrate the compass, so I followed the directions which involved me rotating the drone horizontally and vertically. After a short period of time I got a notification that the compass had calibrated successfully. GPS lock acquired so from here everything looked good.

I opened up Drone Deploy, opened project and ran through checklist. Everything came back good so I launched the drone to begin the mission.

Almost immediately I did not have live images coming to my iphone like I have in previous flights. I was not particularly worried about this as I still had visual of the drone and live updates of the drones location on the flight path, battery power, time elapsed etc. However, roughly halfway through the first transect the handheld controller read “disconnected” and the drone position on my handheld froze. This position was roughly 500m from my location on the ground (drone was 300 ft/90 m altitude). I walked around a bit trying to get the controller to reconnect to no luck. At this point I could not locate the drone in the sky. The Drone Deploy App was still not updating – the location was still at a fixed point and the battery was stuck at 91%. The only thing that was updating was time elapsed. I tried to switch to a manual mode but the controller said disconnected and the DJI Go app would not connect to the drone (black screen only). Being that I did not have visual and the Drone Deploy App was not updating I decided to press the return home button in hopes that it would be able to connect and bring the drone back to the launching position. When I pressed the button a notification at the bottom of the App told me that the drone was returning home. After waiting a few minutes without seeing or hearing the drone I was still relatively optimistic as I thought worst case scenario it would fly until it was at 20% battery and return home on its own. I waited 45+ minutes and never saw a sign of the drone again.

At this point I spent a few hours hiking around the heavily wooded area below the location that the Drone Deploy display was frozen on. No luck in finding the Drone. The DJI Go App Find My Drone feature showed the last known location as the home point where I launched the drone.

I eventually went home and sent the flight log to Drone Deploy. They told me that the drone lost GPS signal and that when I pressed “Return Home” it was not able to figure out where home was. They said that the correct course of action at this point is to put the drone in manual and fly it home that way. However, my handheld controller was not connected and I was not able to do anything manually. They sent me the coordinates to the “last known location” and just like the DJI Go App it showed the home point where I launched the drone.

I am not knowledgeable on reading the flight logs, but looking them over myself it looks like the GPS Signal is listed as Very Good or Very Strong the entire time. The only two locations shown on the Flight Log that I see are the home location and another location about 0.5 miles up the road, completely outside of the boundary. I did not search this area yesterday but will return to it to see if there is any luck.

Anyway, I apologize for the long post and explanation. Has anyone had a similar experience or have advice on what I can do next to possibly find the Drone? Does this sound like software/hardware error or did I do something wrong?

Sorry for your loss, I hope you find it.

In your narrative above, you did not mention that you force-closed DJI Go before opening Drone Deploy. Are you absolutely sure you successfully did that?

I am not. This was the response I got on another forum as well. I can’t recall if I completely closed out of DJI Go.

Do you suppose that if I had them both open this would be enough to cause communication errors?

It is a possibility. NOT having more than 1 control app open during flight has been a cardinal rule since the SDK was released. In theory, when you lost communication while in DD, it’s possible that communication was switched to GO running in the background without your knowledge.

If that were to happen, I guess the drone would just hover in place until either Smart RTH kicked in (if you have that enabled), or just land in place when the battery level dropped to critical.
All just conjecture though.

In the future, I would advise paying close attention to closing out one app before jumping in to another. I change apps during flight quite often but am pretty careful about this.

It would be interesting to look at the flight log from GO as well as the DD log.

At least it landed safely, otherwise the whole plane was broken and it was even more troublesome