Lost control during landing part of mission

I flew 3 maps today all in different locations. Preflight and flight went as normal but when it began to return to home it was about 20 feet off the home point. I’m already used to switching back to P when landing because its usually a tight area when I fly.
This time however when I switched to P the controller had zero response with the drone. The controller constantly beeped (as it does for RTH) and I did not regain control until after I closed the DD app and opened the DJI app. As I was switching apps it did continue to descend, then when DJI go opened I gained control of movement but descent continued. On the second map same thing happened except that I had movement but descent stayed constant, and I had no problems with the 3rd map.

The only time this has happened to me is when the battery was critically low on battery. I have had the RTH activate when I was a couple thousand feet away and the return trip got me down in the 10% range. Even in the DJI GO app, at that level the drone typically descends but I can move it left or right to line up the landing.

Yeah I understand if the battery is low anything can go wrong but when I make a map it’s typically 3 and a half minutes per job and I had a fresh battery in each time.

Everything was updated and calibrated. First job of the day, worked fine every other day of the week. Everything worked correctly up until RTH start after the mission is complete.

I have had the same issue recently with my P3, we are chatting about it here too;

Was out flying a road construction project on 12/02/16 and had the same thing happen to me. I have the latest DD app version (love the new UI improvements). I have always taken control to land except when landing on a large hard surface (concrete or asphalt) to keep the dust down and off the motors and camera. Twice when coming in to land, I switched from “F” to “P” on my Inspire 1 RC when the bird was about 50ft from the ground but it kept coming down. I was on a grassy area with lots of dirt around but was able to add enough power to fight it in for a smoother landing in the grass. Lots of dirt over the bird so I had to cease operations and clean it with a can of Nitrogen. I will be finding a larger area for launching and landing until this can be solved.

Not sure if this is exactly the same thing but during the flight, the app seemed to freeze. I lost the in flight view and the map was not being updated as the drone flew along the path. I went crazy for a minute as I thought I lost the drone altogether but saw that it finished the pre assigned path and began the return home. For some reason it continued taking photos until I turned the battery off. I was using an Ipad Mini 2 if that helps troubleshoot at all. I ran the map engine and everything appeared ok. Just a bit of a surprise when it just all of a sudden quit showing the data.

HI!, Yup, I have the same happening. P3P: all up dated of last weekend. Landing portion is not right. Manual control is not possible. The only thing you can do is add thrust to keep it from coming down too fast and to put it where you want laterally. its “going” to land, so be prepared. You will not get a go-around if things are not right for touch down. This is a MAJOR safety issue.
I need to do the test:
As soon as the last leg is finished, switch to manual, let it hover. See if you have manual control of the return.
Maybe switching to manual earlier would give better results?
Anyone try this?
thanks all!

I’ve got a P3P and I’m still seeing the no manual override on landing. At this point, I’m letting the drone start the decent, switch to ATTI, kill DD app, switch to P mode and then I’ve got control. Sure seems like a safety issue to me. In about 10mph wind today, I had to ATTI into the wind a ways so that I could do the app kill and not get into a worse spot. To me it seems this issue has had way too long of a life cycle. Maps Made Easy can get it to work, I’m not sure why DD can’t get it. When I flight Maps Made Easy, I let the decent come down to about 15ft and take over from there by switching to P mode and it works flawlessly.

Any word on a fix for this issue? This is beginning to become a problem.

I am having the same issue, can’t take control during landing, very unsafe as RTH is sometimes much as plus/minus 2 metres from takeoff point.

This should be resolved in the latest releases.