Lost 2 Phantom 4 Pro in 2 days


#1

We just lost 2 drones, both Phantom 4 Pro yesterday and this morning. When our team fly the first drone yesterday, it lost the signal when the drone is climbing the altitude at around 85 meter. The remote control and iPad both crashed, and restarted. The remote never connect to drone anymore (red light) (tried everything to try to connect to drone - restart, unplugged ipad). The drone continues its mission and never return. Deploy a group of people to find it but couldn’t find it. This morning we use another drone to find the first drone, using the same mission but at lower altitude. Thought we can use the image captured to find the first one, but, the same thing happened again. The drone gone haywire and never return again.

I know there are a lot of missing information in this topic as I am not the one who fly the drone too. I will be updating the topic when the team returned.

All the drones, ipad, cables and batteries are brand new. Conducted 7 mission without problem before the first drone gone rogue. Then followed by the second drone.


#2

It sounds like there is some serious electronic signal interference in that area to shut down the iPad and controller.


#3

Hi @sth001,

Thank you for reporting your recent experience with us. It’s extremely difficult to hear about any incidents of this nature, but we assure you that your report is received very seriously at DroneDeploy. Please reach out to us at support@dronedeploy.com and we’ll do our best to help you locate your drones.

Best,
Stephanie


#4

Hi Stephanie, our team has returned. I think there is no way we can locate our drone without actual go and find it on foot. Both remote controls react the same way: when the mission start, and the drone start to climb the altitude, in a sudden the DD app turns unresponsive as the remote control led turn red. The drone continued to climb and fly away. Weirdly it does not even follow the pre-planned mission, where the drone fly out of the boundary we set earlier. Our team tried very hard to track down the drone but still failed. So if the remote control led turned red at the departure point of the drone, there is no way we can track down where it goes. There is no log file in the remote control too.


#5

Hi Gary, nope, there is nothing at the rural area of our plantation. Nothing at all.


#6

Hi @sth001,

I’ve sent you a private message requesting additional info. Please let me know if you have not received it.

Cheers,
Christina


#7

I would strongly consider adding a separate tracking system, such as Marco Polo for RC aircraft if I were you. Any lost system is quickly retrievable.


#8

Hi Christina, thank you for you support. I will be following up with you. We have found the second drone a few days ago but I still don’t have the drone in hand. Another thing is that our pilots are on leave too, and I also need to follow my management’s decision on this investigation.


#9

Sounds good @sth001. My team is here to help when you’re ready.

Cheers,
Christina


#10

I’d fire my visual observer.