Longer missions stuck at "starting mission" screen with P3P


I have earlier tested Dronedeploy for small areas without any problems. Two days ago it was first time I tried to map a little larger areas, with about 15 minutes of mission length. Both saved offline missions and areas set locally. However, the mission process stops at the “starting mission” screen. I also tried setting small default sized areas, that worked fine. But when i set the altitude to over 100 meters, the mission progress was stuck at “starting mission” again.

Today I tried again with my mobile device connected online. Longer missions still don’t work. Sometimes it was stuck on the “starting mission”, sometimes it returned error 3 or error 12, telling to try smaller missions if using older firmware.

I have the Phantom 3 Pro with the newest firmware.

Any ideas what might be causing the problem?

hi @aquatic - is there any chance there was an altitude limitation below 100 meters set in DJI GO?

The altitude limitation was set to 150 meters, so it should not be the problem.

This one was solved: the maximum distance limit was earlier set at 500 meters with the DJI Go app. Now I have set the distance limit off and the longer missions seem to run perfectly!

1 Like