Log in and refreshing plans not working

I was working in DD this morn. I put a location marking in and went to move it. Could not select it. Could select other items on the map, just not that one location marker. After trying things like going back out to dashbrd, I tried quitting chrome on mac and logging in again. Now I can log in with that account but refreshing plans fails. No images are in any of my maps now. Log out, try another of my accounts. Log in gets a hang at the log in page. Wont log in. Try the first account again. Log in gets refresshing fails, no images are in the maps. Clear cache, try firefox, same problem. This seems like its on DD’s end and not my 2 macs, firefox, chrome on my end.
Any Ideas??
thank you

Having the same problem. I tried logging out since nothing was loading and I can’t log back in.

I’m having the same issue with logging in. Had to create a new account using Google sign in credentials.

Same here. I have tried everything. Every browser. I cannot log in even on iPads.

Please advise ASAP!

Im glad to hear its not just me!!! Now Login page hangs. Cant log in with any account. Must be system bug. Would be great to have DD post here when system is back up.

Was just able to get logged in on computer and iPad. You might try it again.

All is working now for me. Wonder what happened?

All good now for me. Thanks all!

There was a server issue. It is fixed now.

1 Like